Jump to content
misterfox

[Решено] Не работает ЧПУ (стандартный и SeoPro)

Recommended Posts

Доброго времени суток!

Столкнулся с такой проблемой: Не работают ЧПУ, как стандартный, так и встроенный SeoPro.

 

Стоит чистая ocStore 1.5.4.1 на Денвере.

 

При использовании SeoPro на всех страницах, кроме главной:

post-666936-0-06819100-1365494824_thumb.jpg

Настройки:

post-666936-0-18425400-1365494880_thumb.jpg

 

 

При стандартом ссылки остаются, как и были.

Share this post


Link to post
Share on other sites

htaccess  переименовали?

Share this post


Link to post
Share on other sites

Нет, на что переименовать?

Share this post


Link to post
Share on other sites

У меня на денвере тоже не работало. А на реальном хостинге вполне. Так что денвер в этом плане не показатель.

 

Переименовать надо .htaccess.txt в .htaccess. Файл лежит в корне.

Share this post


Link to post
Share on other sites

Переименовывание не помогло. 

На счёт денвера, планируется переход с одного движка на другой, поэтому хочется, что бы всё было отлажено, что бы на реальном сервере сразу стало работать как надо.

Share this post


Link to post
Share on other sites

Переименовывание не помогло. 

На счёт денвера, планируется переход с одного движка на другой, поэтому хочется, что бы всё было отлажено, что бы на реальном сервере сразу стало работать как надо.

 

Оно и будет работать как надо. Тут скорее проблемы у денвера.

Share this post


Link to post
Share on other sites

Есть ли хоть какая то возможность протестировать на локальном компьютере?

Пробовал Open Server - аналогичная проблема.

Share this post


Link to post
Share on other sites

У меня такая же история все переименовано раньше работало отключил на пару дней по причине дублей чтоб ридерект настроит когда включил ошибка страница не найдена((( в чем может быть трабл?

Share this post


Link to post
Share on other sites

Я свою проблему решил - оказалось, что это я дурак, не правильно установил сайт на локальный сервер. ЧПУ в OpenCart не работают, если он установлен в подпапку.

Share this post


Link to post
Share on other sites

не совсем так :)

не работает, если не читать то, что написано

 

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /

  • +1 2

Share this post


Link to post
Share on other sites

не совсем так :)

не работает, если не читать то, что написано

 

# SEO URL Settings

RewriteEngine On

# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /

Добрый день!! Подскажите как правильно прописать путь RewriteBase /.

 

На локальном сервере сайт находится по адресу Z:\home\мой-сайт\www/

На хостинге /home/папка/вложенная-папка/мой-сайт/public_html/

 

У меня не работает SEO ни на локалке ни на хостинге, при включении ссылки корректные но в итоге при переходе страница не найдена. SEO использую стандартный. Файл htaccess переименован, ничего в нем не менял.

Share this post


Link to post
Share on other sites

в файле .htaccess

 

RewriteEngine On прописано?

 

а у товаров поле SEO URL заполнено?

 

если путь как у тебя "На хостинге /home/папка/вложенная-папка/мой-сайт/public_html/" , то 

RewriteBase /

 

если магазин будет распологаться во вложенной директории типа /public_html/myshop , то 

 

RewriteBase /myshop/ иными словами, плясать от директории "myshop"

Edited by Zeppelin
  • +1 2

Share this post


Link to post
Share on other sites

в файле .htaccess

 

RewriteEngine On прописано?

 

а у товаров поле SEO URL заполнено?

 

если путь как у тебя "На хостинге /home/папка/вложенная-папка/мой-сайт/public_html/" , то 

RewriteBase /

 

если магазин будет распологаться во вложенной директории типа /public_html/myshop , то 

 

RewriteBase /myshop/ иными словами, плясать от директории "myshop"

в файле .htaccess

 

RewriteEngine On

 

он вообще стандартный, ничего в нем не менял. Никак не разберусь где загвоздка. Единственное менял название папки админ и соотвественно данные в файле inex.php . Но затем вернул все обратно. Что непонятно почему не работает стандартный SEO.

Share this post


Link to post
Share on other sites

Добрый день!

 

Если путь на сервер D:\vhosts\сайт.ru\httpdocs\.htaccess

то текст в .htaccess должен выглядеть так?

 

Options +FollowSymlinks

Options -Indexes
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>
RewriteEngine On
RewriteBase /сайт.ru/httpdocs/
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^yandexmarket.xml$ index.php?route=feed/yandex_market [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
php_flag magic_quotes_gpc Off

Share this post


Link to post
Share on other sites

попробуй

RewriteBase /

или

RewriteBase /httpdocs/

 

короче :)

так тоже не верно...

 

посмотри что у тебя записано в конфиге Apache в качестве Document Root

 

если D:\vhosts\

то RewriteBase /сайт.ru/httpdocs/

 

если D:\vhosts\сайт.ru\

то RewriteBase /httpdocs/

 

если D:\vhosts\сайт.ru\httpdocs\

то RewriteBase /

 

думаю так будет верно :)

Edited by Zeppelin

Share this post


Link to post
Share on other sites
RewriteBase /

Share this post


Link to post
Share on other sites

не работает не так не так. На denwer работало. При переносе на хостинг перестало. 

Выдает ошибку 404

 

Not Found

The requested document was not found on this server.

Share this post


Link to post
Share on other sites
D:\vhosts\сайт.ru\httpdocs\

а что, хостинг Виндовый или это опечатка?

Share this post


Link to post
Share on other sites

а что, хостинг Виндовый или это опечатка?

 

виндовый.

Share this post


Link to post
Share on other sites

хостер ищет что у него там прописано в конфиге Apache в качестве Document Root.

 

я пока он ищет перепробывал все варианты. Ни один не подошел.

Share this post


Link to post
Share on other sites

хостер ищет что у него там прописано в конфиге Apache в качестве Document Root.

уж не с помощью ли google он это делает?...

= = =

открой index.php; добавь в конце, перед

?>
такое

if (
обнови страницу, полученную ошибку покажи нам, восстанови index.php.

Share this post


Link to post
Share on other sites

Вот что ответил хостер.

 

На Windows хостинге установлен IIS а не Apache. Поэтому файл .htaccess не обрабатывается. Возможно вам больше подойдет linux хостинг?

 

 

добавление if (  выводит только белую страницу без кодов ошибки.

 

менять хостинг на linux? других вариантов нет?

Share this post


Link to post
Share on other sites

менять хостера

Share this post


Link to post
Share on other sites

перешел на linux хостинг. Все стало и заработало с первого раза. 

 

Спасибо

Share this post


Link to post
Share on other sites

Может кто подскажет, сео ссылки работают, все отлично, осталась только одна ссылка на контакты, вида  /index.php?route=information/contact уже и в базе прописывал, и htacess переписывал, ничего не помогает.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.