Jump to content
Osvald

Не работает менеджер картинок

Recommended Posts

Warning: curl_setopt(): supplied argument is not a valid cURL handle resource in /www_host/hosts/mstyle.xm6.ru/admin/model/localisation/currency.php on line 103

cURL отключен, должен быть включен.

Share this post


Link to post
Share on other sites

Как я говорил: по результату отчета OpenCart "дал зеленый цвет" на все пункты при установке. Вот скриншот с cURL.

Изображение

А из-за этого может быть проблема с заливкой изображений? Может мне следуют обратиться к хостеру почему ошибка такая появляется - так и поступлю. Спасибо.

P.S. Самому ближе форумный движок phpBB3 с модами (не в рекламных целях _ublaze.net.ru_ - мой сайт именно на нем)..., просто диплом нужно сделать с интернет магазином, вот я и хочу взять за основу OpenCart, для этого второй акаунт на хостинге приобрел под новый сайт. Сейчас снесу симплу - и заново поставлю OpenCart.

Отредактировано.

Заново установил ocstore_v0.1.0 - проблема так и осталась. Написал в суппорт хостинга:

Здравствуйте.

Я установил движок https://myopencart.com/

По результатам проверки, при установке данного скрипта, было выявлено что все технические параметры хостинга подходят - скриншот: http://i55.tinypic.com/mb4jrb.png

но когда я захожу в панель администратора, то получаю следующее предупреждение:

Warning: curl_setopt(): supplied argument is not a valid cURL handle resource in /www_host/hosts/mstyle.xm6.ru/admin/model/localisation/currency.php on line 103Warning: curl_setopt(): supplied argument is not a valid cURL handle resource in /www_host/hosts/mstyle.xm6.ru/admin/model/localisation/currency.php on line 104Warning: curl_exec(): supplied argument is not a valid cURL handle resource in /www_host/hosts/mstyle.xm6.ru/admin/model/localisation/currency.php on line 106Warning: curl_close(): supplied argument is not a valid cURL handle resource in /www_host/hosts/mstyle.xm6.ru/admin/model/localisation/currency.php on line 108Warning: Cannot modify header information - headers already sent by (output started at /www_host/hosts/mstyle.xm6.ru/admin/index.php:72) in /www_host/hosts/mstyle.xm6.ru/system/engine/controller.php on line 27

Судя по логу - ошибка вызвана cURL.

и панель отображается так http://i54.tinypic.com/fuqkxe.png

исправляется это сменой кодировки, если сменить с Кириллицы (ISO-8859-5) на Юникод (UTF-8) или просто дальше перейти по любой вкладке, то все "встает" в норму (кодировка сама автоматически меняется на Юникод (UTF-8)) http://i56.tinypic.com/2l978li.png

Можно-ли это как-то устранить?

Спасибо.

P.S. Версия движка ocStore v0.1.0

Ссылка на движок http://myopencart.googlecode.com/files/ ... v0.1.0.zip

так же тестировалось на OpenCart v1.4.8b RUS v0.1 - этаже самая ошибка в панеле администратора, однако у других пользователей данного движка такой проблемы не возникало, да и предложенное демо https://myopencart.com/demonstration.php работает без данной ошибки.

Share this post


Link to post
Share on other sites

Добрый день, таже проблема с менеджером на хостинге. Версия - опенкарт 1.4.9.1, обновлялся с 1.4.9...протестил на Денвере - все было в порядке, сначало тоже не видело картинок вообще - но потом когда добавил новую - все подхватило и картинки отобразились и можно было дальше нормально добавлять новые товары.Обновился на хостинге - и там уже работать отказывается.Права уже где только нужно было выставил на 777, причем заметил такую особенность - зайдя по фтп можно поменять права на старые картинки, если же добавляешь новую - она появляется в каталоге, но поменять на нее права нельзя. Честно говоря зашел в тупик и куда двигаться не знаю. Спасибо за любую оказанную помощь.Небольшое дополнение:сейчас мучаю на Денвере - менеджер картинок все картинки видит, но есть одно но! - новую картинку добавить можно, и выбрать ее для товара тоже - но в самом магазине она не отображается, а остается no_image, любую другую картинку из ранних новому товару присвоить можно и она будет отображаться в магазине нормально.очередной UР:домучал я наконец - из всех предложенных решений мне помог совет с созданием в менеджере картинок новой папки в каталоге image, установить для нее права 777 и заливать новые картинки для вновь созданных товаров туда...

Share this post


Link to post
Share on other sites

Как у всех выше писавших все работало потом бах и ...Перечитал вдоль и поперёк истыкал всё поперетыкал но "Менеджер изображений" как был пуст, так и остался. Может, кто подскажет выход, как вылечить менеджера.Все методы изложенные выше не помогли.Версия 1.4.9.1

Share this post


Link to post
Share on other sites

Ещё раз прочитал, все экспиременты повторил и все срослось.Удачи следующиму! :?

Share this post


Link to post
Share on other sites

У меня лично следующий полтергейст...На ocStore 0.1.3, при добавлении любой новой фотографии (с англ. названием и любым расширением), она загружается, что видно через фтп, но после этого менеджер изображений перестает показывать каки либо изображения.После удаления загруженной фотографии, менеджер изображений "работает".Пробовал играть как с именами файлов, так и расширениями. Создавал новые дир-рии, ничего не помогает.Права на запись 777.На этом же хостинге, на OpenCart 1.4.8 все работает нормально.Ума не приложу в чем проблема...

Share this post


Link to post
Share on other sites

У меня лично следующий полтергейст...

Именно перестает показывать или окно увеличивается в размерах, появляется прокрутка и все картинки внизу окна?

Share this post


Link to post
Share on other sites

Именно перестает показывать...Пока в ручную не удалишь через фтп загруженную фотографию...Поставил на тот же хостинг, но на другой поддомен ocstore с нуля, все работает.Установки register_globalsmagic_quotes_gpcодинаковые (в офф)...Буду ковырять дальше...есть подозрение, что проблема именно в пхп настройках моего хостера, т.к. значения скрипта установки и панели управления хостера (register_globals, magic_quotes_gpc) отличаются...

Share this post


Link to post
Share on other sites

После перехода с windowz на *nix хостинг перестал работать файлменеджер картинок. Я нашел у себя в /images картинку с русскими буквами в названии, после удаления её, заработало.

Share this post


Link to post
Share on other sites

Привет всем!

Тема до сих пор актуальна! После переноса с локального на хостинг, перестал работать менеджер картинок. На папку image, и на все внутренние файли и папки поставил права 777, но все равно менеджер изображений ничего не видит

Как это лечится, подскажет кто?

Share this post


Link to post
Share on other sites

Та же проблема, хостинг nx0, на зервере все робит. А вот на этом хосте отказывается работать.

Share this post


Link to post
Share on other sites

Лечится все очень просто.

Причина одна:в папке с картинками /public_html/image/data/ у нас присутствуют файлы, которые "ломают" Менеджер картинок, а именно:

- неправильное имя файла (кириллица, которая после заливки на хостинг могла покосячиться в страшные символы, недопустимые символы и т.д.) - поможет переименование

- некорректный формат файла (слишком большой размер, разрешение и т.п) - поможет переконвертация фотошопом или др.

Т.е. просто найдите этих гадов, и приведите в порядок. Если не знаете, как, то методом тыка.

Можете скопировать себе локально все содержимое папки, а на сервере удалить, потом в локальной найдите порцию "правильных" файлов, и залейте на хост. Проверьте работу менеджера. Если все ок - так порциями и заливайте, проверяя каждый раз.

Share this post


Link to post
Share on other sites

Вобщем вот такая история: перенес свой вебсайт с дугого хостинга на nx0. Все прошло без особых проблем, за исключением файловый менеджер не работает если я заливаю новую картинку, просто перестает отображать все. Названия картинок везде английские, весят они по 60 кб, доступ к папкам стоит 777, в htaccess выставленно php_value magic_quotes_gpc off.

Есть возможный способ решения это можно добавить следующую строку сразу после <?php в нужном *.php файле: set_magic_quotes_runtime(0);

Вот только в каком ????

Share this post


Link to post
Share on other sites

Лечится все очень просто.

Причина одна:в папке с картинками /public_html/image/data/ у нас присутствуют файлы, которые "ломают" Менеджер картинок, а именно:

- неправильное имя файла (кириллица, которая после заливки на хостинг могла покосячиться в страшные символы, недопустимые символы и т.д.) - поможет переименование

- некорректный формат файла (слишком большой размер, разрешение и т.п) - поможет переконвертация фотошопом или др.

Т.е. просто найдите этих гадов, и приведите в порядок. Если не знаете, как, то методом тыка.

Можете скопировать себе локально все содержимое папки, а на сервере удалить, потом в локальной найдите порцию "правильных" файлов, и залейте на хост. Проверьте работу менеджера. Если все ок - так порциями и заливайте, проверяя каждый раз.

Действительно, проблема только в "неправильных" названиях файлов, хостинг не при чем. Загружал фотки по номерам артикулов, попались такого вида BL000047, изменил на bl000047 и менеджер показал изображения, а у меня их 6800 и все в одной папке.

Share this post


Link to post
Share on other sites

webmix, в папке /image/data/ один файл 1.jpg

менеджер изображений все равно не работает (

Share this post


Link to post
Share on other sites

webmix, в папке /image/data/ один файл 1.jpg

менеджер изображений все равно не работает (

Такая же проблема.

Share this post


Link to post
Share on other sites

Попробуйте с менеджером изображений elFinder, если у вас ocStore из последних...

Share this post


Link to post
Share on other sites

Попробуйте с менеджером изображений elFinder, если у вас ocStore из последних...

elFinder пишет "Некорректный ответ от сервера".

Share this post


Link to post
Share on other sites

У меня при добавлении изображения к товару браузер совершает ритуальное самоубийство и схлопывается.Видимо.пытается получить автоматом лист всех файлов в папке image,а изображенйи у меня там около 10к.

Неужели нельзя сделать,чтобы просто выбрать фотку через обычный проводник и нажать_Сохранить?

Пробовал создавать подкаталоги в папке image-все равно долго,грузит браузер на грани схлопывания+фотка автоматом не присваивается,ее еще надо выбрать после загрузки(как ее найти-то там если загружено уже 1000 изображений к примеру).

Ужоссссссс

Share this post


Link to post
Share on other sites

Проблема решена!

Вообщем, у меня сайт chickenbro.ru на форнексе (я этих ребят с удовольствием буду пиарить, так как они красавцы). Так вот, отчаявшись пишу в тех поддержку, причем пишу то же самое что и здесь, они ответили (ну минут через пять), что

Для выполнения этого скрипта недостаточно памяти. Для вашего тарифа ограничение составляет 64 Мб.

Тариф изменен, проблема решена! Все довольны! Ура!

Кому не понятно, то кратко: для решения этой проблемы необходим тариф, где на выполнение скриптов выделяется больше 64 мб памяти (желательно 128мб).

Переводите свои сайты на этот хостинг: Выделенные серверы

И самое вкусное, они бесплатно помогут с переездом на их хостинг

Официальный сайт: fornex.com

Выделенные серверы: это как Билаз, но по цене Оки

Ну и естественно регистрация

Все ветки про менеджер изображений слиты в одну. (19th)

Нужна помощь

Не работает менеджер картинок ,в левой менюшке +image(не открывается) ,справа пусто(картинок нет) ,из файла не обновляет(не добавляет),права на папку установил 777

магазин OpenCart 1.4.0 RUS v0.3

в журнале пишет

post-11627-0-86720000-1314488533_thumb.jpg

Share this post


Link to post
Share on other sites

Я со сломанным менеджером картинок справиться не смог.

Вчера вечером ни с того ни с сего перестал работать. Причём в описание товара (Общие) нормально добавляет фотки, а с разделом Данные и добавлением изображения товара отказывается работать. Все советы проглядел, всё проверил, вертелся как уж на сковородке - никак.

Решил что у меня слишком кривые руки и просто перезалил движок, картинки и базу по новой. 15 минут и всё снова как часики.

Надеюсь, не повторится.

P.S. пробовал новую версию (ocstore_v0.2.2), но старая база данных на ней косячит - не показывает описания товара в разделе Общие, хотя на витрине магазина всё ок.

Share this post


Link to post
Share on other sites

post-12910-0-50372300-1317623590_thumb.pngРебят, помогите пожалуйста, вроде бы уже все возможные способы перепробовал и ничего не помогает.

В php.ini ставил на офф, мэджик..

изменил менеджер изображений, пробовал картинки разные, даже удалил все все картинки относящиеся к товарам - все равно не помогает.

Стоит Ocstore 0.2.2

Ах да, еще когда выбираю одну из картинок сайт "коверкает" перестает распознавать кодировку русскую и вместо букв - символы. Из плагинов стоит ИМПОРТ/ЭКСПОРТ в EXCEL и вывод категорий на главную.

Share this post


Link to post
Share on other sites

post-12910-0-50372300-1317623590_thumb.pngРебят, помогите пожалуйста, вроде бы уже все возможные способы перепробовал и ничего не помогает.

В php.ini ставил на офф, мэджик..

изменил менеджер изображений, пробовал картинки разные, даже удалил все все картинки относящиеся к товарам - все равно не помогает.

Стоит Ocstore 0.2.2

Ах да, еще когда выбираю одну из картинок сайт "коверкает" перестает распознавать кодировку русскую и вместо букв - символы. Из плагинов стоит ИМПОРТ/ЭКСПОРТ в EXCEL и вывод категорий на главную.

я уже около года не обновлял скрипт. первый раз были проблемы довольно похожие: после установки загружаемые картинки товаров не отображаются.

решение: у хостинга по умолчанию файлы создаваемые без указания прав создавались с правами 600. все файлы с картинками что я загружал были с такими правами, как это проверить в вашем варианте с помощью фтп клиента filezilla зайдите в нужную папку и посммотрите права, потом возьмите все папки и файлы вашего сайта измените права на 755 для папок и 644 для файлов, если после этого картинки уже добавленных товаров появятся то у вас та же проблема.не забудьте что файлы с настройками типа config.php должны быть 600 по моему.

чтобы решить проблему я взял все файлы отдаленно напоминающие что могут участвовать в загрузке картинок и кешировании, открыл их и первой строкой написал:

umask 022;

эта команда говорит что все файлы создаваемые данным файлом будут создаваться с правами 644, а папки с 755

Share this post


Link to post
Share on other sites

Та же самая проблема. на стороне хоста все в порядке, при закрытии менеджера изображений выдавало следующую байду - http://floomby.com/content/8zrEBqKEEi

после нашел в папке \admin\view\javascript\jquery\ui\themes\ui-lightness\images тысячу файлов без расширений, выглядящих как анкоры, все на английском языке. Снес их всех, и вроде все заработало, единственное пропал крестик для закрытия окна менеджера...но бог с ним, главное остальное работает.

Share this post


Link to post
Share on other sites

Почисть свой компьютер от вирусов, смени пароль доступа по FTP и вычисти сайт от всякой нечисти...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.