supmener

Как включить SEO на локальном сервере?

Рекомендуемые сообщения

supmener    12

После включения SEO перестал работать сайт (совсем не загружается).

На локальном сервере Endels (это ответвление от Denwer) в Windows XP установил Opencart 2.2.0.0. Не русифицировал. Примерно зашёл (по русски)  в:
"Система" - "Настройки" - "Управление магазинами" - "Изменить". Вкладка "Сервер". Включил SEO.
Сайт на домене, не в папке. В .htaccess:
RewriteBase /

Также очищал \www\system\storage\cache\.
ПК перезагружал, не помогло.

Прошу подсказать другой локальный сервер, на котором это у Вас точно работает или нюанс или ошибку, если её не замечаю.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
PeterStudio    12

Укажите правильный путь в RewriteBase

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
supmener    12

А чем он отличаться должен от того, что написал, как сейчас там прописано?

Изменено пользователем supmener

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
supmener    12

А те, кто пользуются Денвером, обратили внимание на данный нюанс и как в нём обстоит дело по данному вопросу?

 

Вот эта сборка у меня показывает хорошие результаты http://www.usbwebserver.net/en/ при включении SEO (при установке могут быть проблемы, так как в настройках надо сменить номер порта MySQL, чтобы совпадал, там был 3307 вписан, а в Opencart 3306). Только не пойму, как сделать имя сайта похожее на то, что в интернете, там сейчас localhost.

Ещё была мысль попробовать Xampp-win32-1.8.2-6-VC9.

Изменено пользователем supmener

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Shureg    127

openserver  попробуйте. Там штатно можно задать любой необходимый абсолютный путь к папкам, как на хостинге. И имя сайту дать реальное.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
hoolygan    81

Лучше попробуй linux поставить, и заодно, если имя сайту хотите сделать поиграйтесь с файлом hosts, и не партесь больше со всякими денверами.

Учитесь работать напрямую с серверами, потом проще будет при переезде на VPS/VDS.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
supmener    12

openserver  попробуйте. Там штатно можно задать любой необходимый абсолютный путь к папкам, как на хостинге. И имя сайту дать реальное.

Спасибо за совет. OpenServer у меня стоит на другом системном блоке. А в той которой работаю сейчас, хочу что нибудь более легковесное.

 

Чтобы Линукс устанавливать, пока не имею жёсткого диска под это дело.

 

Вот пользуюсь часто USBWebserver. А как написал, не работает в нём SEOURL. В настройках есть такие строки:

#LoadModule reqtimeout_module modules/mod_reqtimeout.so
LoadModule rewrite_module modules/mod_rewrite.so

Кто то знает насчёт этого?

Когда ставил Opencart, значки с галочками все были зелёные.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
hoolygan    81

Чтобы unix-like ставить - нужно всего навсего виртуальная машинка. Она бесплатная - http://www.ixbt.com/news/soft/index.shtml?16/58/54

Ставь на здоровье - и не парься с денверами.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
supmener    12

А какой Линукс лучше для этого дела? А какой лучше не применять?

Изменено пользователем supmener

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Похожий контент

    • От Jolly1371
      Здравствуйте.
       
      Помогите пожалуйста разобраться. Установила на локальный сервер(точнее опенсервер) сайт версия 1.5.1.3.
      Были иероглифы на всем сайте, поменяла настройки на php 5.3. Все заработало хорошо, кроме вкладки дополнения - модули в админке. 
      Когда ее нажимаешь появляются иероглифы на всей странице, а если переходишь на какой-нибудь модуль, то он открывается нормально на русском. Ошибок никаких не выдает)
       
      Подскажите, пожалуйста, в чем может быть причина?
    • От bitpad
      Добрый день!
       
      После переноса с Денвера на сервер почем-то стал жутко зависать "Менеджер дополнений". Иногда данная страница в админке просто зависает или ничего не отображается (белая).
      Сам сайт работает исправно. Версия ocStore 2.1.0.2.1, переношу вместе с vqmod, пути в config прописал, системный кэш и vqmod почистил.

      Может кто-нибудь, сможет помочь? Заранее спасибо!
    • От lesmanora
      В общем. Бекап сайта перенесла на локальный диск ( денвер)...
      И полностью слетели стили и в админке, и на самом сайте. 

      Вопрос : как исправить? 
      <?php // HTTP define('HTTP_SERVER', 'http://localhost/ocart/'); define('HTTP_IMAGE', 'http://localhost/ocart/image/'); define('HTTP_ADMIN', 'http://localhost/ocart/admin/'); // HTTPS define('HTTPS_SERVER', 'http://localhost/ocart/'); define('HTTPS_IMAGE', 'http://localhost/ocart/image/'); // DIR define('DIR_APPLICATION', 'Z:/home/localhost/www/bekap/catalog/'); define('DIR_SYSTEM', 'Z:/home/localhost/www/bekap/catalog/system/'); define('DIR_DATABASE', 'Z:/home/localhost/www/bekap/catalog/system/database/'); define('DIR_LANGUAGE', 'Z:/home/localhost/www/bekap/catalog/language/'); define('DIR_TEMPLATE', 'Z:/home/localhost/www/bekap/catalog/catalog/view/theme/'); define('DIR_CONFIG', 'Z:/home/localhost/www/bekap/catalog/system/config/'); define('DIR_IMAGE', 'Z:/home/localhost/www/bekap/catalog/image/'); define('DIR_CACHE', 'Z:/home/localhost/www/bekap/catalog/system/cache/'); define('DIR_DOWNLOAD', 'Z:/home/localhost/www/bekap/catalog/download/'); define('DIR_LOGS', 'Z:/home/localhost/www/bekap/catalog/system/logs/'); // DB define('DB_DRIVER', 'mysql'); define('DB_HOSTNAME', 'localhost'); define('DB_USERNAME', 'admeen'); define('DB_PASSWORD', '1111'); define('DB_DATABASE', 'fr33838_bio'); define('DB_PREFIX', ''); ?> Админ
       
      <?php // HTTP define('HTTP_SERVER', 'http://localhost/ocart/'); define('HTTP_IMAGE', 'http://localhost/ocart/image/'); define('HTTP_ADMIN', 'http://localhost/ocart/admin/'); // HTTPS define('HTTPS_SERVER', 'http://localhost/ocart/'); define('HTTPS_IMAGE', 'http://localhost/ocart/image/'); // DIR define('DIR_APPLICATION', 'Z:/home/localhost/www/bekap/admin/'); define('DIR_SYSTEM', 'Z:/home/localhost/www/bekap/admin/system/'); define('DIR_DATABASE', 'Z:/home/localhost/www/bekap/admin/system/database/'); define('DIR_LANGUAGE', 'Z:/home/localhost/www/bekap/admin/language/'); define('DIR_TEMPLATE', 'Z:/home/localhost/www/bekap/admin/view/template/'); define('DIR_CONFIG', 'Z:/home/localhost/www/bekap/system/config/'); define('DIR_IMAGE', 'Z:/home/localhost/www/bekap/image/'); define('DIR_CACHE', 'Z:/home/localhost/www/bekap/admin/system/cache/'); define('DIR_DOWNLOAD', 'Z:/home/localhost/www/bekap/download/'); define('DIR_LOGS', 'Z:/home/localhost/www/bekap/admin/system/logs/'); define('DIR_CATALOG', 'Z:/home/localhost/www/bekap/catalog/'); // DB define('DB_DRIVER', 'mysql'); define('DB_HOSTNAME', 'localhost'); define('DB_USERNAME', 'admeen'); define('DB_PASSWORD', '1111'); define('DB_DATABASE', 'fr33838_bio'); define('DB_PREFIX', ''); ?>  


    • От garyk
      Здравствуйте. Хочу попросить совета у знающих, опытных форумчан. Что-то зашел в тупик.
      Дано: сайт на CMS OpenCart на хостинге.
      Версия движка: 2.0.1.1
      Задача: сделать копию этого сайта (на OpenCart) у себя на локальном сервере (OpenServer) и успешно открывать рабочий сайт.
      Трудности: перечитал ряд инструкций, делаю точно также, но открыть на локалке полностью рабочий сайт не могу. Какие-то недочеты, ошибки.
       
      Взял за основу вот эту инструкцию: http://forum.opencart-russia.ru/threads/perenos-sajta-na-lokalnyj-xosting.1844/
      1) Скачиваю новую версию OpenCart. Или надо 2.0.1.1? (пробовал 2 варианта). Кидаю дистрибутив в папку в OpenServer. Открываю. Проходит процесс установки. Выбираю название БД (как в реальном хостинге), пользователь: root, пароль: (пусто).
      2) Скачиваю сайт с хостинга - копирую в папку OpenServer'a с установленной OpenCart. Только config и admin/config - не трогаю.
      3) Дальше иду в БД (OpenServer). Захожу по: пользователь: root, пароль: (пусто). Создаю БД (название как хостинге). Импортирую туда содержимое БД (с хостинга). Проверяю: config и admin/config. Там вроде все данные правильны.
      4) Запускаю сайт. И вижу какие-то баги. То сайт на 30% загружается, то выдает ошибку в какой-то строке, то кривой текст и кодировка и т.д.
       
      ВОПРОС: что делаю не так? Направьте пожалуйста в нужное русло. 
    • От supmener
      После настройки категорий и добавления товаров на локальном сервере Endels (http://www.endels.ru/) надо перенести каталог на хостинг в интернете. То есть не полностью с движком файлы и всю базу данных, а только товары. Какие есть варианты?
       
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу