Перейти к содержанию

Рекомендуемые сообщения

Здравствуйте.

Есть сайт на версии 1,5.

Естт ли возможность автоматического обновления до версии 2,0?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Также нужно обновить если это физически возможно с версии Version 1.5.4.1 до OpenCart v2.0.2

Хотя бы алгоритм подскажите пожалуйста.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сами данные - товары/описания/категории и тд перенести не так сложно..

 

в первую очередь нужно понимать, что при обновлении с 15х на 2х - придется забыть про все модули, шаблоны и правки (если нет их версий для 2х)

 

магическим образом это не обновится - только полной правкой либо использованием аналогов именно для 2х.

вы к этому готовы?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Готовы. О гуру-сенсеи, подскажите как нам быть

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

сделать новый сайт на 2.0 а потом перенести в него нужные данные.

Это ЕДИНСТВЕННЫЙ работающий способ

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как правильно обновиться с 1.5 до 2.1 с сохранением категорий и товаров? Это возможно вообще? Шаблон планирую поставить новый, под новую версию.

Попробовал обновиться ради эксперимента, вылезло куча ошибок при обновлении. Зашел в админку, там тоже много ошибок.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как правильно обновиться с 1.5 до 2.1 с сохранением категорий и товаров? Это возможно вообще? Шаблон планирую поставить новый, под новую версию.

Попробовал обновиться ради эксперимента, вылезло куча ошибок при обновлении. Зашел в админку, там тоже много ошибок.

многое зависит от того, какая именно версия 1.5.х - чем она выше, тем меньше расхождений в БД в сравнении с 2.х

также имеет значение, оригинальный opencart или сборка

 

если своих знаний недостаточно - обратиться в раздел платных услуг

если есть желание сделать самостоятельно - подучить mysql, освоить phpmyadmin (или подобный софт) и адаптировать данные под новую версию

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Как правильно обновиться с 1.5 до 2.1 с сохранением категорий и товаров? Это возможно вообще? 

 

Возможно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте, не подскажете способ переноса товаров с ос 1.5 на 2?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Правильно понимаю, что просто установив новую версию движка на старую базу - ничего не получу?

Просто полазив, ничего толкового не нашел о том, как переехать с 1.5 на 2.0 без потери данных (на модули вообще побарабану).

Для ocStore аналогичная ситуация, ведь так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кто то подскажет или нет? Как переехать с 1.5 на 2+ с сохранением только товаров и категорий? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кто то подскажет или нет? Как переехать с 1.5 на 2+ с сохранением только товаров и категорий? 

 

многое зависит от того, какая именно версия 1.5.х - чем она выше, тем меньше расхождений в БД в сравнении с 2.х

также имеет значение, оригинальный opencart или сборка

 

если своих знаний недостаточно - обратиться в раздел платных услуг

если есть желание сделать самостоятельно - подучить mysql, освоить phpmyadmin (или подобный софт) и адаптировать данные под новую версию

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Можно потаблично перенести в базу нового магазина.Только вот рассказать  это,тоже самое  что "за меня сделай".

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Можно потаблично перенести в базу нового магазина.Только вот рассказать  это,тоже самое  что "за меня сделай".

Подскажи хоть какие таблицы нужно сохранить только товар и категории.  

Может есть парсер для OcStore 2+ чтоб можно было с донера спарсить. Или какая-то обработка прайсов? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Всё что относится к ос_product и ос_category (ну или какой там префикс используется).Насчёт парсера,какой то перебор....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Тогда получается что лучше установить новую версию и перенести все товары и все остальное ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

При наличии навыков возможен любой вариант.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как правильно обновиться с 1.5 до 2.1 с сохранением категорий и товаров? Это возможно вообще? Шаблон планирую поставить новый, под новую версию.

Попробовал обновиться ради эксперимента, вылезло куча ошибок при обновлении. Зашел в админку, там тоже много ошибок.

Подскажи хоть какие таблицы нужно сохранить только товар и категории.

Может есть парсер для OcStore 2+ чтоб можно было с донера спарсить. Или какая-то обработка прайсов?

Самый постой с помощью https://opencartforum.com/files/file/467-csv-price-pro-importexport/ переносите Товары/категории/описания. Изменено пользователем vilka

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Самый простой , купить кодированный модуль с привязкой к домену? ))))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Самый простой , купить кодированный модуль с привязкой к домену? ))))

)))) Ну а если руками не выходит??? А то потом начнется "я что то где то как то....и ничего не работает"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

купить в данной ситуации платный модуль закодированный равносильно перекладыванию проблемы на техподдержку модуля. Что само по себе является стратегической ошибкой и ведет к провалу проекта

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так по данному совету придётся видимо два их брать.Ставить на разные домены.Скачивать с одного и заливать  на другой.Потому как модуль не универсален и работает только на своей версии движка.

 

Странное мягко говоря решение....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так по данному совету придётся видимо два их брать.Ставить на разные домены.Скачивать с одного и заливать  на другой.Потому как модуль не универсален и работает только на своей версии движка.

 

Странное мягко говоря решение....

Скорее всего вы правы. Но у меня он был приобретен. Я создал копию всей базы. И потом перенес ее на двойку. Хотя не вижу смысла так рваться, и переходить на 2.0. В итоге все равно вернулся на 1.5. Многие правильно говорят, есть смысл устанавливать 2.0 если делаете магазин с нуля.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.