Перейти к содержанию
nadim

[vsfilter full] OcStore 1.5.5.1.1 при отк. категории можно зайти по прямому пути, а должно показывать - Категория не найдена! Как исправить?

Рекомендуемые сообщения

OcStore 1.5.5.1.1 при отключении категории - она как-то не полностью отключается - можно зайти по прямому пути - только вот открываются все товары которые есть в магазине и лезут ошибки (стикеры - индексы.). Вчем может быть проблема и как сделать, чтобы при отключении категории - по прямой ссылке выдавало - категория не доступна или что-то в этом роде.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нашёл проблема в фильтре Vsfilter Full. только как исправить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Похожий контент

    • От mario512
      Добрый день. Помогите вывести статус товара в категории. Варианты, которые находил в сети, не работают на OCStore 2.3.0.2.
      Я себе это представляю так:
      Если остаток > 5 тогда статус = "В наличии" Если остаток < 5 тогда статус = "Заканчивается" Если остаток = 0 тогда статус = "Нет в наличии" КонецЕсли КонецЕсли КонецЕсли Как это реализовать в контроллере?
    • От redmoon
      Всем привет, суть задачи: есть категория в которой товары выводяться например по 15 штук по 4 ряда и 4 столбца, тоесть последняя клетка грубо говоря пустая. Вот в нее нужно поместить ссылку на следующую страницу в категории, при переходее не нее уже будет на ее месте ссылка на следующую и так далее. Никогда не работал  с классом  Pagination, как правильно с него получить данные о следуюющей странице и вывести в списке товаров? Ocstore 2.3
    • От autonavi
      Вопрос к знающим.
      Если зайти в категорию "1", далее зайти в любой товар в этой категории и после попытаться снова нажать на категорию "1" - назад не выйти, только стрелкой в браузере или в любую другую категорию. Заметил такое на шаблоне Unishop. (Проблема такая же и в демо шаблона)
       
      Вот пример: http://unishop-template.tw1.ru/ipod-classic
      Нельзя снова нажать на категорию "Компьютеры и периферия"
      На любую другую - можно.
       
      Кто знает как решить? 
    • От spectre
      499.00 руб
      Скачать/Купить дополнение


      Скрытие категорий от групп покупателей Hide Categories From Customer Groups 2.1-2.3.x
      Модуль позволяет скрыть категории товаров и товары которые в них находятся от некоторых групп покупателей путем установки галочки напротив группы покупателей в настройках категории (на скриншоте)
       
      Примеры использования: 
      - Оптовые категории и и товары в них и розничные, которые не пересекаются
      - "Временные категории" для обработки прайсов, недооформленных товаров и тп
      - Переучет в какой-либо категории
      - и многое другое
       
       
      Версия для 2.3.x и 2.1.х
       
      Кому нужно - могу дать потрогать демо
       
      Адаптация под версии линейки 2.х - бесплатная после покупки
       
       
      ОЧЕНЬ ВАЖНО!!!
      Модуль использует стандартный функционал и изменяет стандартные модели категории и товара для определения доступа
       
      Если у вас какой-то модуль супермегаменю или суперстена категорий, который использует свои модели, отличающиеся от "родных" - адаптация недорогая но платная
       
      Под популярные шаблоны - >300 покупок на форуме - адаптация бесплатная, под остальные - недорого, пишите в лс
       
      Уточняйте эти моменты ДО покупки!
       
       
      Имеются патчи под шаблоны:
      1. Newstore
      2. To be continued
       
      Лицензия - 1 домен
       
      Какие-то вопросы - пишите в личку, разберемся
       
      Добавил spectre Добавлено 21.06.2018 Категория Модули Системные требования Сайт разработчика https://freelancer.od.ua Старая цена 800 Метод активации Автоматическая активация Ioncube Loader Нет OpenCart 2.3 ocStore 2.3 OpenCart.Pro, ocShop Opencart.pro 2.3  
    • От spectre
      Модуль позволяет скрыть категории товаров и товары которые в них находятся от некоторых групп покупателей путем установки галочки напротив группы покупателей в настройках категории (на скриншоте)
       
      Примеры использования: 
      - Оптовые категории и и товары в них и розничные, которые не пересекаются
      - "Временные категории" для обработки прайсов, недооформленных товаров и тп
      - Переучет в какой-либо категории
      - и многое другое
       
       
      Версия для 2.3.x и 2.1.х
       
      Кому нужно - могу дать потрогать демо
       
      Адаптация под версии линейки 2.х - бесплатная после покупки
       
       
      ОЧЕНЬ ВАЖНО!!!
      Модуль использует стандартный функционал и изменяет стандартные модели категории и товара для определения доступа
       
      Если у вас какой-то модуль супермегаменю или суперстена категорий, который использует свои модели, отличающиеся от "родных" - адаптация недорогая но платная
       
      Под популярные шаблоны - >300 покупок на форуме - адаптация бесплатная, под остальные - недорого, пишите в лс
       
      Уточняйте эти моменты ДО покупки!
       
       
      Имеются патчи под шаблоны:
      1. Newstore
      2. To be continued
       
      Лицензия - 1 домен
       
      Какие-то вопросы - пишите в личку, разберемся
       
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×