Diramxx

[Решено] Проблема с производителями SEO PRO

Рекомендуемые сообщения

Diramxx    28

Может кто то может помочь. После включения Seo Pro возникла проблема при нажатии на производителя выходит страница с надписью что страница не найдена. Если seo url не прописываешь то все работает, но этот вариант не подходит.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
snastik    847

найдите в seo_pro строку

$this->request->get['route'] = 'product/manufacturer/product';

и замените ее на

 

$this->request->get['route'] = 'product/manufacturer/info';

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Diramxx    28

nfv так и прописано, наверное что то другое.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
omenboy    0

Дайте пожалуйста путь к этому файлу у себя проверю. А то такая же проблема

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Diramxx    28

/www/catalog/controller/common/

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Diramxx    28

Спасибо помогло

а мне не помогает!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
nomad86    0

Где взять этот модуль? На 1.5.5.1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ternavsky    0

После включения Seo Pro возникла проблема при нажатии на производителя выходит страница с надписью что страница не найдена.

У меня проблема была в том что у производителя не был выбран магазин (галочка "Основной магазин").

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Zudva    0

 

найдите в seo_pro строку

$this->request->get['route'] = 'product/manufacturer/product';

и замените ее на

$this->request->get['route'] = 'product/manufacturer/info';

Путь к файлу: /www/catalog/controller/common/

 

Мне помогло! Спасибо =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Ketty83    14

товары отображаются но не все... как сделать пагинацию?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
nforced    0

 

найдите в seo_pro строку

$this->request->get['route'] = 'product/manufacturer/product';

и замените ее на

$this->request->get['route'] = 'product/manufacturer/info';

У меня было наоборот. Стояло - info, заменил на product и все стало ок.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Похожий контент

    • От MrNix21
      Добрый день, форумчане! Делаю мультимагазин на ocStore 2.3.0.2.3 на региональных поддоменах и возник такой вопрос - Как создать разные статьи одной тематики но с одинаковыми УРЛ? Допустим, надо сделать страницу "Контакты". Делаю несколько страниц для каждого региона, включаю статьи только в необходимых магазинах, и хочу чтобы у них был одинаковый адрес, не считая поддомена. Т.е. хочу чтобы было - https://msk.site.ru/kontakty, https://spb.site.ru/kontakty и т.д. ЧПУ делаю через SEO Менеджер, ставлю полные пути с поддоменами и протоколом https://, но не работает, выходит "Страница не найдена". Если ставлю обычный протокол http:// то работает. Как быть? Кто с этим уже сталкивался?
    • От eurobike
      Помогите пожалуйста как его нужно настраивать чтобы чпу автоматически выставлялось?
      Если ставлю галочки в админке чпу-да,Включить SEO URLSeo pro-да,выскакивают ошибки Not Found
    • От desking
      Чпу не формируется для категорий 3-го уровня. Стоит модуль Seo Pro версия опенкарт 2.3. Как исправить?
    • От friz
      Здравствуйте, проблема в следующем не появляется в админке seopro модуль и поэтому кажется, что не правильно что то установлено, все запросы прописал для яндекса, но когда смотрю что выходит по запросам там каша, например в поисковике отображается мой сайт но описание нету берется просто список товаров, и вставить в категории описание почему то не получается.  nutscorp.ru


    • От novorom
      Добрый день, Господа!
      вообщем произошла у меня такая штука- не пускает в админку
      выдает -HTTP ERROR 500
      согласно логам
       
      PHP Fatal error: Cannot redeclare ModelCatalogProduct::getProductMainCategoryId() in /var/www/html/system/storage/modification/admin/model/catalog/product.php on line 624, referer: http://tilebox.ru/admin/
       
      а произошло это после попытки включить ЧПУ
      в моей сборке opencart 2 нет встроенного модуля чпу
      1.сначала был загружен модуль ocjazz-seopro-v201-2020.ocmod
      (все загрузки я делаю с помощью модуля Quickfix(с выключенным ftp)
      2.ЧПУ не включалось и я отключил модуль ocjazz-seopro и поставил модуль seopro_230x_1.01beta.ocmod
      чпу опять не заработало
       
      3.я чистил кэш- для этого поставил модуль чистки КЭША
      так же я менял файл ,htaccess
      далее по запарке случайно активировал модуль ocjazz-seopro вместе с в тот момент активным модулем  seopro_230x_
      в следствии чего админка вылетела и больше не пускает.
       
      4.как удалить модуль на хостинге я так и не понял, единственное я переименовал файл .htcacces в .htcacces.php, но все равно ничего не изменилось(
       
      Если кто-то сталкивался с подобным, прошу помочь
      с последнего бэкапа сделано много изменений.
       
       
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу