Перейти к содержанию
Poljot

Переход на 2.x c 1.5 - в чем плюсы ?

Рекомендуемые сообщения

Здравствуйте, пользуюсь opencart 1.5 - скажите, на сколько важен переход на новую версию ? В Joomla например переход на новые версии важен по причинам безопасности, старые версии вскрывают как консервные банки.


 


Как обстоит дело с opencart ? Посоветуйте пожалуйста - в чем плюсы перехода ?


 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нету.

Если Вас все устраивает сейчас - работайте.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

если магазин отлажен и работает на 15х - нет смысла переезжать.

даже, если какой-то функционал хочется заиметь у себя - лучше разработать/заказать аналог под свою версию движка.

основное (существенное) отличие 2хх (на мой взгляд) - адаптивность/ориентированность-на-мобильные-девайсы(планшеты) из-коробки. но это "ваще-не-аргумент" для обновления версии движка.

Изменено пользователем afwollis
но это "ваще-не-аргумент" для обновления версии движка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

основное (существенное) отличие 2хх (на мой взгляд) - адаптивность/ориентированность-на-мобильные-девайсы(планшеты) из-коробки.

Это все решается адаптивным  шаблоном для 1,5

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

добавил "но это "ваще-не-аргумент" для обновления версии движка." в прошлое сообщение, дабы уточнить свою позицию.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сама архитектура изменилась, изменено формирование модулей и расположения в базе, это немного по идее должно добавить в производительности, встроен штатный аналог vqmod - она так же дает + в производительности из-за того что не парсит каждый раз файлы ну и + не нужно морочить себе голову с установкой лишнего. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Лично мне не нравится, что в 2.0 часть админского функционала вынесена в каталог и спрятана через api. В итоге какие-то простые вещи из 1.5 в 2.0 нужно делать хитромудро извернувшись.
 
Еще не упомянули про такую полезную штуку, как эвенты. Вот это действительно полезная штука для модернизаций.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 Еще не упомянули про такую полезную штуку, как эвенты. Вот это действительно полезная штука для модернизаций.

Не упоминал потому что еще сними так и не работал, а так то да, события это хорошо 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ОС2  php7 умеет :-) . Это само по себе может быть критической причиной для обновления.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ОС2  php7 умеет :-) . Это само по себе может быть критической причиной для обновления.

Только нужно переписать немного вывод ошибок

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Лично мне не нравится, что в 2.0 часть админского функционала вынесена в каталог и спрятана через api.

Как раз это хорошо

 

По крайней мере - одно место, а не три.


Вот это действительно полезная штука для модернизаций.

Укажите удобное место..

 

Только если вы работает с данными

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Только нужно переписать немного вывод ошибок

А что там надо переписать?  У меня в 2.1 работает нормально "искаропки", ЧЯНТД?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А что там надо переписать?  У меня в 2.1 работает нормально "искаропки", ЧЯНТД?

http://php.net/manual/ru/language.errors.php7.php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо, когда(если) возникнут проблемы буду знать, куда копать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ОС2 php7 умеет :-) . Это само по себе может быть критической причиной для обновления.

 

с одним важным "но".  заионкубированные модули пока не умеют работать с этой версией php.  не встречал пока ни одного такого модуля,  авторы модулей делают максимум под 5.6.  в будущем, возможно будет...

Не слежу за выпусками ионкуб лоадера под разные ОС, т. к. модулей php 7 нет под ионкубом.

 

Кто-то запускал ионкуб лоадер для php 7?

 

Смотрю, что еще разные версии для Linux есть: 32 бит и 64 бит. 

 

сам php 7 в какой битности бывает для *.nix?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не проверял - не было необходимости, но если верить официальному блогу, лоадер php7 работает с файлами, шифроваными для php5.6

http://blog.ioncube.com/2016/09/15/php-7-ioncube-loaders/

Битность системы только для ионкуба имеет значение, сам php7 "комбинированный"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Смотрю, что еще разные версии для Linux есть: 32 бит и 64 бит. 

 

сам php 7 в какой битности бывает для *.nix?

я не удивил тут такого http://php.net/downloads.php

 

 

 

с одним важным "но".  заионкубированные модули пока не умеют работать с этой версией php.

Работают у них на сайте была бета кажись, но это не столь критично, ну и это все индивидуально 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Укажите удобное место..

 

 

Если вы спрашиваете, где удобны эвенты, то вот задача из реальной практики: уведомлять клиента об изменении его баланса. Так как баланс меняется в разных ситуациях, то уведомление проще всего было вынести в одно место (в эвент).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я так понимаю, если магазин создавать с 0, то лучше сразу ставить 2.0. Верно?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я так понимаю, если магазин создавать с 0, то лучше сразу ставить 2.0. Верно?

Да, но теперь вопрос еще глубже, 2.1, 2.2 или 2.3  :-D

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

2.3 да и все

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Из второй версии до недавнего времени однозначно 2,102 была единственно правильным выбором. Да и сейчас пока остается.

ОС2,3 еще очень сырой, замучаетесь потом пачить. Так что, имхо, если хотите работать, а не тренироваться в настройке магазина - 2,102.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, танцы с бубном хотелось бы в разумных пределах)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я бы посоветовала так, обновиться можно, но острой необходимости в этом нет. Просто будьте готовы к тому, что поддержки модулей под 1.5 с каждым годом будет все меньше и меньше. А так, согласна с постами выше, принципиальных премуществ в 2.х в сравнении с 1.5 нет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.