Перейти к содержанию

Рекомендуемые сообщения

Добрый вечер. Перевел сайт на https протокол. Есть способ проверить перевелся ли сайт на этот проток и корректно ли он на нем работает?

Изменено пользователем Avrel

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
9 минут назад, ArtemPitov сказал:

Пройтись по всех страницах и проверить http://take.ms/TT9UC

Понял спасибо. Так и дела на первый взгляд все хорошо, думал возможно есть сервисы или программы. 

Изменено пользователем Avrel

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

seo frog или xenu

  • +1 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 часов назад, Blade сказал:

seo frog или xenu

Спасибо

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, Dotrox сказал:

Если вы хотите проверить сертификат и настройки SSL, то вот: https://www.ssllabs.com/ssltest/

 

Спасибо. Я сделал тест по вашей ссылке. Если не трудно подскажите результат нормальный?
Vm6d0VaIDX5b5A.png
Q2K0EveI40oq7A.png
KAxjOaYhM6Ebxm.png
zANk8veUBVoy4r.png
BA0RzV6IJNbNBm.png
MAjpKjzI48g8jm.png
RmzzW3YI0dndMm.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, Avrel сказал:

Спасибо

Вы в настройках магазина включили SSL ? Часто замечал  не включают

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, markimax сказал:

Вы в настройках магазина включили SSL ? Часто замечал  не включают

Включен. Вы просто дали совет? или увидели что то не то?

Изменено пользователем Avrel

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 часов назад, Avrel сказал:

Спасибо. Я сделал тест по вашей ссылке. Если не трудно подскажите результат нормальный?

 

Да, всё в полном порядке.

  • +1 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
10 минут назад, Dotrox сказал:

 

Да, всё в полном порядке.

Спасибо большое 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
9 часов назад, markimax сказал:

Вы в настройках магазина включили SSL ? Часто замечал  не включают

А какая разница включен или нет, если разработчики пишут дополнения не думая о том, что есть люди которые юзают ssl.

В результате при включенном SSL пол сайта отображается с протоколом http пока не пропишешь в конфигах HTTP_SERVER с протоколом https, хотя по идеи достаточно прописать адрес с https для HTTPS_SERVER.

Изменено пользователем Denys

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, Denys сказал:

А какая разница включен или нет, если разработчики пишут дополнения не думая о том, что есть люди которые юзают ssl.

 

Это для тех кто правильно пишет ;)
Вон у @Avrel  fast_sitemap  - страницы моего модуля https (так как свой ЧПУ формирователь модуль имеет и всё учтено по SSL), а страницы товаров, категорий http

Вообще @Avrel я бы рекомендовал поставить HTTPS FIX чтобы исправлял чужие ошибки

 

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, Denys сказал:

пока не пропишешь в конфигах HTTP_SERVER с протоколом https

 

Это как раз ещё не самое страшное. Встречаются модули, где только поковыряв код можно заставить их использовать https.

 

А в случае, когда не подхватывается HTTPS_SERVER дело не только и, возможно, не столько в модулях, сколько в особенностях самого ОК. По умолчанию предполагается, что сайт на SSL на самом деле его использует только для страниц с конфиденциальной информацией (регистрация, оформление заказа и т.д.), поэтому даже в родных файлах ОК все ссылки на другие страницы формируются без SSL. За тип протокола отвечает третий параметр в $this->url->link, который в большинстве вызовов этого метода не заполнен и потому используется дефолтное значение установленное при объявлении этого метода в /system/library/url.php, а оно false (в 1.5 там было NONSSL, что имело тот же эффект).

Поэтому простой и правильный вариант заставить по умолчанию все ссылки, которые формируются через $this->url->link использовать https - это исправить в указанном файле дефолтное значение на true.

 

Но, если в каком-то модуле ссылки формируются не через $this->url->link, а вручную и там без каких-либо проверок намертво вбито HTTP_SERVER, то, конечно, эта правка не поможет и надо таки править конфиг.

 

P.S. Сейчас прибежит Марк и начнёт орать, что менять дефолтное значение в /system/library/url.php - это костыль и единственное правильное решение - купить его модуль.

 

  • +1 3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
31 минуту назад, Dotrox сказал:

 

Это как раз ещё не самое страшное. Встречаются модули, где только поковыряв код можно заставить их использовать https.

 

А в случае, когда не подхватывается HTTPS_SERVER дело не только и, возможно, не столько в модулях, сколько в особенностях самого ОК. По умолчанию предполагается, что сайт на SSL на самом деле его использует только для страниц с конфиденциальной информацией (регистрация, оформление заказа и т.д.), поэтому даже в родных файлах ОК все ссылки на другие страницы формируются без SSL. За тип протокола отвечает третий параметр в $this->url->link, который в большинстве вызовов этого метода не заполнен и потому используется дефолтное значение установленное при объявлении этого метода в /system/library/url.php, а оно false (в 1.5 там было NONSSL, что имело тот же эффект).

Поэтому простой и правильный вариант заставить по умолчанию все ссылки, которые формируются через $this->url->link использовать https - это исправить в указанном файле дефолтное значение на true.

 

Но, если в каком-то модуле ссылки формируются не через $this->url->link, а вручную и там без каких-либо проверок намертво вбито HTTP_SERVER, то, конечно, эта правка не поможет и надо таки править конфиг.

 

P.S. Сейчас прибежит Марк и начнёт орать, что менять дефолтное значение в /system/library/url.php - это костыль и единственное правильное решение - купить его модуль.

 

Спасибо за объяснения. Посмотрел  свой файл url.php на OK 1.5 у меня нету таких значений ( $this->url->link, true, fasle. ) есть значения  $this->url но без link
Если интересно представлю свой конфиг.
 

<?php
class Url {
    private $url;
    private $ssl;
    private $rewrite = array();

    public function __construct($url, $ssl = '') {
        if (is_bool($url)) { // opencart 2.2
            $this->url = '';
            $this->ssl = $url;
        } else {
            $this->url = $url;
            $this->ssl = $ssl;
        }
    }

    public function addRewrite($rewrite) {
        $this->rewrite[] = $rewrite;
    }

    public function link($route, $args = '', $connection = '') {
        // SIMPLE START
        global $config;

        if (!empty($config) && method_exists($config, 'get') && $config->get('simple_settings')) {
            $get_route = isset($_GET['route']) ? $_GET['route'] : (isset($_GET['_route_']) ? $_GET['_route_'] : '');

            if ($config->get('simple_replace_cart') && $route == 'checkout/cart' && $get_route != 'checkout/cart') {
                $connection = 'SSL';
                $route = 'checkout/simplecheckout';
            }

            if ($config->get('simple_replace_checkout') && $route == 'checkout/checkout' && $get_route != 'checkout/checkout') {
                $route = 'checkout/simplecheckout';
            }

            if ($config->get('simple_replace_register') && $route == 'account/register' && $get_route != 'account/register') {
                $route = 'account/simpleregister';
            }

            if ($config->get('simple_replace_edit') && $route == 'account/edit' && $get_route != 'account/edit') {
                $route = 'account/simpleedit';
            }

            if ($config->get('simple_replace_address') && $route == 'account/address/update' && $get_route != 'account/address/update') {
                $route = 'account/simpleaddress/update';
            }

            if ($config->get('simple_replace_address') && $route == 'account/address/insert' && $get_route != 'account/address/insert') {
                $route = 'account/simpleaddress/insert';
            }

            if ($config->get('simple_replace_address') && $route == 'account/address/edit' && $get_route != 'account/address/edit') {
                $route = 'account/simpleaddress/update';
            }

            if ($config->get('simple_replace_address') && $route == 'account/address/add' && $get_route != 'account/address/add') {
                $route = 'account/simpleaddress/insert';
            }
        }
        // SIMPLE END

        if (empty($this->url)) {
            if ($this->ssl && $connection) {
                $url = 'https://' . $_SERVER['HTTP_HOST'] . rtrim(dirname($_SERVER['SCRIPT_NAME']), '/.\\') . '/index.php?route=' . $route;
            } else {
                $url = 'http://' . $_SERVER['HTTP_HOST'] . rtrim(dirname($_SERVER['SCRIPT_NAME']), '/.\\') . '/index.php?route=' . $route;
            }
        } else {
            if ($this->ssl && $connection) {
                $url = $this->ssl;
            } else {
                $url = $this->url;
            }

            $url .= 'index.php?route=' . $route;
        }

        if ($args) {
            if (is_array($args)) {
                $url .= '&amp;' . http_build_query($args);
            } else {
                $url .= str_replace('&', '&amp;', '&' . ltrim($args, '&'));
            }
        }

        foreach ($this->rewrite as $rewrite) {
          $url = $rewrite->rewrite($url);
        }

        return $url;
    }
}
?>

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Denys сказал:

А какая разница включен или нет, если разработчики пишут дополнения не думая о том, что есть люди которые юзают ssl.

В результате при включенном SSL пол сайта отображается с протоколом http пока не пропишешь в конфигах HTTP_SERVER с протоколом https, хотя по идеи достаточно прописать адрес с https для HTTPS_SERVER.

По поводу конфигов у меня вроде все прописано 
4f9b6efb08.png

Изменено пользователем Avrel

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
45 минут назад, Dotrox сказал:

 

P.S. Сейчас прибежит Марк и начнёт орать, что менять дефолтное значение в /system/library/url.php - это костыль и единственное правильное решение - купить его модуль.

 

Совершенно верно - потому как многие модули умудряются вообще в тупую ставить http:// ... минуя всё.
Поэтому по опыту, да, лучше ставить HTTPS FIX
И не суть в продажах (есть и бесплатная версия), а так будут исправляться все ошибки формирования ЧПУ.
Я каждый день по 2-3 магазина перевожу на https - поверьте видел не мало рукожопых модулей и костылей
Даже прописанные в config везде https не "спасают" и "костыли" не спасают.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
41 минуту назад, markimax сказал:

Совершенно верно - потому как многие модули умудряются вообще в тупую ставить http:// ... минуя всё.
Поэтому по опыту, да, лучше ставить HTTPS FIX
И не суть в продажах (есть и бесплатная версия), а так будут исправляться все ошибки формирования ЧПУ.
Я каждый день по 2-3 магазина перевожу на https - поверьте видел не мало рукожопых модулей и костылей
Даже прописанные в config везде https не "спасают" и "костыли" не спасают.

Бесплатная версия только ОК 2 ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, Avrel сказал:

Бесплатная версия только ОК 2 ?

Да

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Avrel сказал:

у меня нету таких значений ( $this->url->link, true, fasle. )

$this->url->link - это в контроллерах при формировании ссылки. А в этом файле это просто функция link и её третий параметр ($connection = ''). Просто впишите в эти пустые кавычки - SSL.

Но, если у вас в конфиге уже везде вписаны ссылки с https, а на сайте всё равно где-то остаются ссылки с http, значит у вас есть как раз те кривые модули, которые лечит модуль Марка (либо ручная правка кода этих модулей) и эта правка в link всё равно не поможет.

 

Можете, кстати, написать авторам этих модулей, такое они обязаны исправлять даже, если модуль бесплатный, ибо такого изначально не должно было в модуле быть (в смысле вбивания протокола прямо в код).

 

 

1 час назад, markimax сказал:

Совершенно верно - потому как многие модули умудряются вообще в тупую ставить http:// ... минуя всё.
Поэтому по опыту, да, лучше ставить HTTPS FIX

 

А я говорил совсем не об этом. Я ничего не имею против исправления вашим модулем кривых модулей. Я говорил о вашем былом утверждении, что поправить /system/library/url.php - это костыль и только ваш модуль правильное решение.

Как я уже написал выше, правка сработает только, если ссылка формируется через $this->url->link, так что она ваш хлеб на фиксах кривых модулей не забирает.

 

А заодно эта правка сразу поможет выявить все кривые модули (кривые в контексте формирования ссылок), ибо только они не начнут использовать https. А дальше уж люди могут с полной уверенностью в его необходимости ставить ваш модуль (либо идти ломать руки авторам выявленных модулей) :)

  • +1 2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
35 минут назад, Dotrox сказал:

$this->url->link - это в контроллерах при формировании ссылки. А в этом файле это просто функция link и её третий параметр ($connection = ''). Просто впишите в эти пустые кавычки - SSL.

Но, если у вас в конфиге уже везде вписаны ссылки с https, а на сайте всё равно где-то остаются ссылки с http, значит у вас есть как раз те кривые модули, которые лечит модуль Марка (либо ручная правка кода этих модулей) и эта правка в link всё равно не поможет.

 

Можете, кстати, написать авторам этих модулей, такое они обязаны исправлять даже, если модуль бесплатный, ибо такого изначально не должно было в модуле быть (в смысле вбивания протокола прямо в код).

 

Понял спасибо. Но проблем с сайтом нету все ссылки работают на https, но карты сайта формирую модулями и оба модуля формируют ссылки http а не https первый модуль марка SEO CMS но при общении с марком он оказал тех поддержку и объяснил что его модуль работает правильно. Остается еще один это feed/fast_sitemap модуль он тоже все ссылки в карте формирует как http вот я и не могу понять дело в модуле или в моем сайте ( настройках ) написал автору но врятли дождусь ответа, последний раз он 9 февраля в сети)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
14 минут назад, Avrel сказал:

Остается еще один это feed/fast_sitemap модуль он тоже все ссылки в карте формирует как http вот я и не могу понять дело в модуле или в моем сайте ( настройках )

 

Ну, не считая вот этого для главной страницы:

$output .= '<loc>' . HTTP_SERVER . '</loc>';

ссылки там формируются через $this->url->link, так что, если в конфигах вы везде вписали ссылки с https (как на вашем скрине) проблем быть не должно (и даже с главной).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, Dotrox сказал:

 

Ну, не считая вот этого для главной страницы:


$output .= '<loc>' . HTTP_SERVER . '</loc>';

ссылки там формируются через $this->url->link, так что, если в конфигах вы везде вписали ссылки с https (как на вашем скрине) проблем быть не должно (и даже с главной).

А есть вот проблемы :)
Все ссылки http, кроме моего модуля (у моего все правильно https)
Там надо смотреть что внутри fast_sitemap - может там ссылки как то по дикому формируются для "быстроты"

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
24 минуты назад, markimax сказал:

Там надо смотреть что внутри fast_sitemap - может там ссылки как то по дикому формируются для "быстроты"

 

Так я ж и посмотрел и написал что увидел. Модуль то бесплатный, посмотреть не проблема.

Так что откуда берутся в сайтмапе http - непонятно. Разве что в конфиге HTTP_SERVER без https (хотя на скрине выше - обратное) и тогда всё логично, поскольку модуль третий параметр в $this->url->link не ставит и если оно в /system/library/url.php не поправлено, то вполне логично, что ссылки без https.

 

А вообще, я открыл сайт и как-то совсем не похоже, чтоб там было так:

1 час назад, Avrel сказал:

проблем с сайтом нету все ссылки работают на https

 

Там полная каша с протоколами, но преобладает всё же именно http, так что могу предположить, что и в конфигах HTTP_SERVER без https и в /system/library/url.php правки нет.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Dotrox сказал:

 

Так я ж и посмотрел и написал что увидел. Модуль то бесплатный, посмотреть не проблема.

Так что откуда берутся в сайтмапе http - непонятно. Разве что в конфиге HTTP_SERVER без https (хотя на скрине выше - обратное) и тогда всё логично, поскольку модуль третий параметр в $this->url->link не ставит и если оно в /system/library/url.php не поправлено, то вполне логично, что ссылки без https.

 

А вообще, я открыл сайт и как-то совсем не похоже, чтоб там было так:

 

Там полная каша с протоколами, но преобладает всё же именно http, так что могу предположить, что и в конфигах HTTP_SERVER без https и в /system/library/url.php правки нет.

Вы много уделил времени мне спасибо Вам. И вы были правы дело в конфиге в первом что лежит в корне там пропустил одну строку добавить https.
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.