Перейти к содержанию
danielpolitis

Переход на PHP 7.1 магазина, за или против

Рекомендуемые сообщения

Дорогие друзья, пожлауйста, помогите внести ясность, у кого есть опыт и мнение, отпишитесь)

у меня на хостинге под магазин сделанный на ocStore/Opencart 2.3.0.2 стоит PHP 5.6 но есть возможность перевести на PHP 7.1 

Подскажите пожалуйста кто что знает, стоит переходить на 7.1 или нет ?) и какие аргументы )

Спасибо )

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Почитайте в интернете очень много информации, в чем отличия между 5.6 и 7.1

В двух словах opencart не использует весь потенциал от 5.4, а про 7.1 -  и говорить смысла нет.

Улучшенная производительность - это экономия на спичках. Так как 80% времени генерации страниц в движке занимают запросы в базу.
Также ioncube не поддерживает  php 7  и будут проблемы!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, snastik сказал:

Почитайте в интернете очень много информации, в чем отличия между 5.6 и 7.1

В двух словах opencart не использует весь потенциал от 5.4, а про 7.1 -  и говорить смысла нет.

Улучшенная производительность - это экономия на спичках. Так как 80% времени генерации страниц в движке занимают запросы в базу.
Также ioncube не поддерживает  php 7  и будут проблемы!

Спасибо за ответ, а ioncube же вроде используется отдельными модулями но не самим движком?) если у меня нет модулей использующих ioncube то тогда в чем же разница?)

я попробовал перевести магазин на 7.1, ошибок на первый взгляд нет, но скорость загрузки страниц видна невооруженным глазом. на 7.1 они просто летают, в то время как на 5.6 мерцания при переходах заметны. и этот факт меня очень подталкивает перейти на 7.1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Мерцания при переходах - это не показатель.
Смотрите в консоль хрома время TTFB.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 минут назад, snastik сказал:

Мерцания при переходах - это не показатель.
Смотрите в консоль хрома время TTFB.

понял, спасибо Вам)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

мерцание - заменит браузер или операционку вместе с компом

 

Вы получили html контент, а стили, скрипты еще не подтянулись или не применились, вот вам и мерцание
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, chukcha сказал:

мерцание - заменит браузер или операционку вместе с компом

 

Вы получили html контент, а стили, скрипты еще не подтянулись или не применились, вот вам и мерцание
 

то есть Вы тоже считаете что лучше оставить версию 5.6 ????

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не версия виновата, а шаблон

за гуглоспидом гонялись?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, snastik сказал:

Также ioncube не поддерживает  php 7  и будут проблемы!

ionCube поддерживает php7.

У меня уже несколко сайтов на php7, Разница хоть и маленькая ест.

Некоторие доплнения с ionCube требують новие закодирование файли. (синтаксис для 5.6)

Я уже попросила авторов и они мне сделали такие файли, так что все работает без проблем.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Agatha65 сказал:

ionCube поддерживает php7.

У меня уже несколко сайтов на php7, Разница хоть и маленькая ест.

Некоторие доплнения с ionCube требують новие закодирование файли. (синтаксис для 5.6)

Я уже попросила авторов и они мне сделали такие файли, так что все работает без проблем.

ну что тут сказать, перешел я на 7.1 и хоп, сразу сюрприз )))))

так что видимо останусь ка я пожалуй на 5.6))

спасибо Всем за участие)

2017-01-25_02-54-48.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Agatha65 сказал:

ionCube поддерживает php7.

У меня уже несколко сайтов на php7, Разница хоть и маленькая ест.

Некоторие доплнения с ionCube требують новие закодирование файли. (синтаксис для 5.6)

Я уже попросила авторов и они мне сделали такие файли, так что все работает без проблем.

ну что тут сказать, перешел я на 7.1 и хоп, сразу сюрприз )))))

так что видимо останусь ка я пожалуй на 5.6))

спасибо Всем за участие)

2017-01-25_02-54-48.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 24.01.2017 в 23:08, snastik сказал:

Почитайте в интернете очень много информации, в чем отличия между 5.6 и 7.1

В двух словах opencart не использует весь потенциал от 5.4, а про 7.1 -  и говорить смысла нет.

Улучшенная производительность - это экономия на спичках. Так как 80% времени генерации страниц в движке занимают запросы в базу.
Также ioncube не поддерживает  php 7  и будут проблемы!

Помогите пожалуйста советом... У меня на хосте php 5.4, опены на 2 сайтах работают нормально. Но мне надо перейти на php 5.6? и при переходе сайты вылетают...

Как сделать, чтобы они работали на 5.6 версии?

У меня опенкарты 2.3

Спасибо за помощь

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

если они перестанут вылетать, то будут работать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, inTim сказал:

Помогите пожалуйста советом... У меня на хосте php 5.4, опены на 2 сайтах работают нормально. Но мне надо перейти на php 5.6? и при переходе сайты вылетают...

Как сделать, чтобы они работали на 5.6 версии?

У меня опенкарты 2.3

Спасибо за помощь

Логи... Почему они вылетают как вы говорите?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.