Перейти к содержанию
alinalessioYandex

Не подключаются стили в файле stylesheet.css [РЕШЕНО]

Рекомендуемые сообщения

Привет всем.

Подключил модуль html в котором разместил конструкцию из div-ов с классами. Этим классам присвоены стили. Стили прописал в файле \catalog\view\theme\default\stylesheet\stylesheet.css

Стили не подключаются. Смотрю исходный код, который генерируется браузером. html код показывает как следует, но стилей, которые я к нему добавил в stylesheet.css нет.

Пробовал эти же стили прописать в тегах <style> непосредственно в том же модуле html, выше html кода - стили успешно применяются. Эти же стили пробовал прописывать в файле header.tpl - точно так же прекрасно работают.

Похоже, что стили, которые я добавил в stylesheet.css не принимаются, хотя файл успешно сохраняется.

Впервые такое. Надеюсь на помощь. Может у кого было что-то похожее. Как сделать, чтобы стили работали из файла stylesheet.css

Спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

попробуйте отдельный css-файл именно со свойствами для модуля грузить непосредственно из него.

тема стандартная?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуйте, те классы которые вы прописали поднять выше в .css файле.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуйте, те классы которые вы прописали поднять выше в .css файле.

если быть точным то НИЖЕ

попробуйте Ваши стили написать в самом конце файла чтобы они переопределили существующие

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у вас точно активирована тема DEAFULT по умолчанию?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

[Решено!]

Спасибо за ответы.

Изначально эти стили у меня были размещены в самом низу страницы stylesheet.css, после всех стилей по умолчанию. В этом виде не работало. Переместил почти наверх страницы, после стилей про body и все заработало.

Не могу объяснить причину, но факт остается фактом - стили запустились, только после перемещения кода стилей наверх страницы файла \catalog\view\theme\default\stylesheet\stylesheet.css

Тема стоит DEAFULT по умолчанию. Никаких других тем не установлено.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

удивительно ведь переопределение идет по последней строке

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.