Перейти к содержанию
amor

[Решено] После ssl не могу зайти в админку

Рекомендуемые сообщения

Здравствуйте после того как установил SSL - не могу зайти в админку - логин и пароль после ввода просто пропадают!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, amor сказал:

Здравствуйте после того как установил SSL - не могу зайти в админку - логин и пароль после ввода просто пропадают!

Найди файл конфигурации по пути admin/config.php и поменяй там на https

А также в корне сайта есть config.php

Изменено пользователем Rubynoid

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да это сделал, и в настройке тоже поставил SSL, ну и на хостинге переадресацию на https  - сайт работает без проблем но в админку не заходит - только отключаешь переадресацию с http на https  - работает нормально
Кстати версия 2,2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, amor сказал:

Да это сделал, и в настройке тоже поставил SSL, ну и на хостинге переадресацию на https  - сайт работает без проблем но в админку не заходит - только отключаешь переадресацию с http на https  - работает нормально
Кстати версия 2,2

В конфиге для админки в начале должно быть так:

<?php
// HTTP
define('HTTP_SERVER', 'https://сайт.ком/');

// HTTPS
define('HTTPS_SERVER', 'https://сайт.ком/');

.....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Отпишусь чтоб потом себе настроить на https

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
11 hours ago, Rubynoid said:

В конфиге для админки в начале должно быть так:

<?php
// HTTP
define('HTTP_SERVER', 'https://сайт.ком/');

// HTTPS
define('HTTPS_SERVER', 'https://сайт.ком/');

.....

 

У меня уже так  стоит - не в этом проблема(((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Спасибо кто откликнулся - проблему решил следующим образом:
В файле login.tpl в каталоге www/admin/view/template/common

есть такая строка <form action="<?php echo $action; ?>" method="post" enctype="multipart/form-data">

так вот в в консоле когда я завожу логин и пароль в переменную  $action почeмуто проставляеться адрес http/ - я взял ее удалил и вручную прописал  "https://www____.ua/admin/index.php?route=common/login" - и  все пошло!!!! 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А у меня все проще прошло. Тоже не пускало в админку - вводишь логин и пароль, нажимаешь войти и ничего не происходит (сбрасывалось). На хостинге стояла переадресация на https, сертификат был подключен естественно. В итоге что помогло - это включение ssl в админке Опенкарта (после этого стало без проблем заходить!)

Что на 1.5.6.4 такое было, что помойму и на 2-ой версии Опенкарта. Если допустим снова отключу в админке ОС ssl - то снова перестанет заходить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 часов назад, zhenya2501 сказал:

В итоге что помогло - это включение ssl в админке Опенкарта (после этого стало без проблем заходить!)

Что на 1.5.6.4 такое было, что помойму и на 2-ой версии Опенкарта. Если допустим снова отключу в админке ОС ssl - то снова перестанет заходить.

 

А зачем отключать SSL если хочешь чтобы сайт работал по протоколу https (читай с использованием SSL)? :rolleyes:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
29 минут назад, SiteMix сказал:

 

А зачем отключать SSL если хочешь чтобы сайт работал по протоколу https (читай с использованием SSL)? :rolleyes:

Да я просто когда подключал в первый раз, не заметил и забыл, что нужно в админке Опенкарта галочку ставить. Потом вроде разобрался и нормально все стало. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у меня еще проще

В настройках хостинга, в опции ПЕРНАПРАВЛЯТЬ НА ДОМЕН у меня стояло www.ИМЯ_САЙТА.ru я поменял на ИМЯ_САЙТА.ru и теперь нормально в админку заходит, всё отображается и всё вроде нормально, но почему так происходит и почему первое сработало вместо второго непонятно. 

Изменено пользователем alan24

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 20.07.2017 в 13:52, amor сказал:

Спасибо кто откликнулся - проблему решил следующим образом:
В файле login.tpl в каталоге www/admin/view/template/common

есть такая строка <form action="<?php echo $action; ?>" method="post" enctype="multipart/form-data">

так вот в в консоле когда я завожу логин и пароль в переменную  $action почeмуто проставляеться адрес http/ - я взял ее удалил и вручную прописал  "https://www____.ua/admin/index.php?route=common/login" - и  все пошло!!!! 

Добрый день! проблема обратно-подобная. был домен, работал на https, теперь этот домен привязан к другому сайту и другому хосту и никакого отношения к предыдущему не имеет. посльзовательская часть работает на http, а админка принудительно добавляет букву "s" к любому юрл при каждом переходе. при том что в админку вообще не мог зайти, помог вышеописанный вами способ. руками записать в login.tpl

в конфигах вот так: 

<?php
// HTTP
define('HTTP_SERVER', 'http://site.ru/');

// HTTPS
define('HTTPS_SERVER', 'http://site.ru/');

и админ

 

define('HTTP_SERVER', 'http://site.ru/admin/');
define('HTTP_CATALOG', 'http://site.ru/');

// HTTPS
define('HTTPS_SERVER', 'http://site.ru/admin/');
define('HTTPS_CATALOG', 'http://site.ru/');

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

проверяйте еще в .htaccess, там может быть прописан редирект с http на https

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
8 минут назад, Pascha сказал:

проверяйте еще в .htaccess, там может быть прописан редирект с http на https

Да тут нет ничего. уже порезаный этот htaccess как  незнаю что. и в пользовательском режиме все нормально работает.

только в админке проблема

 

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

# Options +SymLinksIfOwnerMatch

# Prevent Directoy listing
# Options -Indexes

# Prevent Direct Access to files
#<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
# Order deny,allow
# Deny from all
#</FilesMatch>

# SEO URL Settings

# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
#php_flag display_errors on
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В некоторых случаях и в старых версиях OpenCart помимо того, что в конфигах буковку s дописать, надо еще в базе данных кей config_secure поставить со значением "1", так как через админку это не получиться сделать даже если в admin/view/template/common/login.tpl прописать адрес - по той же причине.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 20.07.2017 в 13:52, amor сказал:

Спасибо кто откликнулся - проблему решил следующим образом:
В файле login.tpl в каталоге www/admin/view/template/common

есть такая строка <form action="<?php echo $action; ?>" method="post" enctype="multipart/form-data">

так вот в в консоле когда я завожу логин и пароль в переменную  $action почeмуто проставляеться адрес http/ - я взял ее удалил и вручную прописал  "https://www____.ua/admin/index.php?route=common/login" - и  все пошло!!!! 

У меня такая же история, твой метод помог, интересно это что, баг версии 2.2? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.