Перейти к содержанию
ilj4

Не работает Ajax в корзине!

Рекомендуемые сообщения

При добавлении в корзину похоже не срабатывает Ajax, сразу перекидывает из каталога в корзину что очень не удобно! Стоит ocstore_v0.1.1 чистая, специально поставил чистую... в корзине Ajax включён, пробывал в разных браузерах, не работает! Гуру подскажите что делать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ajax работает на странице описания товара, в каталоге так и должно работать) как переделать можно найти на форуме

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ajax работает на странице описания товара, в каталоге так и должно работать) как переделать можно найти на форуме

Спасибо! точно из описания работает... буду искать... как переделать...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Что то никак не найти... не подскажите?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго времени суток!

С энного времени пользую ocStore, всё время встаёт проблема: при добавлении товара в корзину происходит переход в неё. Удаление товара через AJAX проходит успешно, а добавление - нет. Вопрос: для решения проблемы придётся ковыряться в коде? или это всё настраиваемо через интерфейс?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

дык там обсуждается модуль LiqPay! какое отношение он имеет к этой проблеме??

https://opencartforum.com/topic/73-%d0%ba%d0%bd%d0%be%d0%bf%d0%ba%d0%b0-%d0%ba%d1%83%d0%bf%d0%b8%d1%82%d1%8c-%d0%bf%d1%80%d1%8f%d0%bc%d0%be-%d0%b8%d0%b7-%d0%be%d0%b1%d1%89%d0%b5%d0%b3%d0%be-%d1%81%d0%bf%d0%b8%d1%81%d0%ba%d0%b0-%d1%82%d0%be%d0%b2%d0%b0%d1%80%d0%be%d0%b2/ - правильная ссылка. Это глюки после обновления форума, со временем поправим, надеюсь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго времени суток!

С энного времени пользую ocStore, всё время встаёт проблема: при добавлении товара в корзину происходит переход в неё. Удаление товара через AJAX проходит успешно, а добавление - нет. Вопрос: для решения проблемы придётся ковыряться в коде? или это всё настраиваемо через интерфейс?

Проверьте:

Админ / Расширения -> Модули -> Корзина :: "AJAX Add To Cart" || "Добавить в корзину (AJAX)"
Должно быть "Включено".

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проверьте:

Админ / Расширения -> Модули -> Корзина :: "AJAX Add To Cart" || "Добавить в корзину (AJAX)"
Должно быть "Включено".
Специально проверял - включено.

michael, пасиб, нашёл, благодарю :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Специально проверял - включено.

тогда смотрите в firebug или google_chrome процесс отработки скрипта и возможные ошибки

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.