Jump to content
Sign in to follow this  
Mult

https и переменные

Recommended Posts

Прикручиваем к сайту https, постоянно что то отваливается. То одни данные то другие. Опенкарт знаю не очень хорошо, помогите если не турудно, уже нет сил бороться.
Вроде получилось все завести, но тут попало меню и часть ссылок в футере побилась.
меню пропало целиком. В футере некоторые ссылки криво выдало вот с такой ошибкой Notice: Undefined variable: text_blog in 

 

Подскажите в какую сторону копать...

Share this post


Link to post
Share on other sites

вы творите какую-то непонятную дичь, копаете не в ту сторону. я даже не знаю что подсказать, т.к. будет еще хуже.

 

Share this post


Link to post
Share on other sites
44 минуты назад, Mult сказал:

Прикручиваем к сайту https, постоянно что то отваливается. То одни данные то другие. Опенкарт знаю не очень хорошо, помогите если не турудно, уже нет сил бороться.
Вроде получилось все завести, но тут попало меню и часть ссылок в футере побилась.
меню пропало целиком. В футере некоторые ссылки криво выдало вот с такой ошибкой Notice: Undefined variable: text_blog in 

 

Подскажите в какую сторону копать...

admin/config

config 

скиньте сюда 

 

Share this post


Link to post
Share on other sites
2 минуты назад, nikifalex сказал:

вы творите какую-то непонятную дичь, копаете не в ту сторону. я даже не знаю что подсказать, т.к. будет еще хуже.

 

:D

i?id=e3fb9c0acd0f40e9b59dc01ed2ae377a&n=

Share this post


Link to post
Share on other sites
2 минуты назад, kentkent17 сказал:

admin/config

config 

скиньте сюда 

 

только пароли-логины затрите :D

Share this post


Link to post
Share on other sites
1 час назад, Mult сказал:

Вроде получилось все завести, но тут попало меню и часть ссылок в футере побилась.

 

Проверьте эту строку в файле config.php

define('DIR_LANGUAGE', 'путь/catalog/language/');

Так же, наличие папок локализации /catalog/language/ru-ru

 

Только непонятно, если с указанными местами что-то не так, то почему до https всё работало?

Edited by SiteMix

Share this post


Link to post
Share on other sites

Опытным путем выяснили что проблема не в ssl  а в том что при переезде с одного домена на другой что то пошло не так.. Я совсем в тупике "что за хрень"юю

Share this post


Link to post
Share on other sites

Собственно, проблемы после переезда на другой домен обычно возникают именно из-за ошибок в путях в config.php и admin/config.php

Share this post


Link to post
Share on other sites

хочу тоже переезжать на https в связи с этим хочу поменять абсолютные ссылки на относительные... и случайно выяснил что есть относительные ссылки по домену, а есть относительные по протоколу

вот возник вопрос, на какой тип относительных ссылок делать замену абсолютных?

 

буду признателен за подсказку.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.