Рекомендуемые сообщения

olegbevz    0

Добрый день,

Вопрос наверное банальный, но планируется ли в будущем поддерживать opencart 3.0.0.0 на ocStore с русской локализацией?

Если тема на форуме создана, подозреваю что да...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ArtemPitov    386

Все планируется

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
n3bo    179

Врятли, скорее всего будет поддерживаться 3.1 или 3.2 какая, но не 3.0 точно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
AWARO    587

да, главное не торопится с этим, потом будут все бегать, то не работает это тормозит, ждите норм версию самого опенкарта ну и потом окстор будет

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ibond    176

chto30.png.c26b8b57219fa890ae29b51a10b10b3d.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
multimen    6

отличия от 2,3 большие или нет  ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    932

почитайте соседнюю тему

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
PeterStudio    12

Уже тестю троечку)))

Что-то при первой установке такого не было, а тут поставил ещё одну копию и при заходе в админку (папку install конечно удалил) пишет про необходимость перемещения "/system/storage/" за пределы web-директории (DocumetRoot): "Warning: You must move the storage directory outside of the web root directory!"

Это что-то не так и такую фичу сделали?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Zeppelin    82
On 29.06.2017 at 1:30 AM, PeterStudio said:

пишет про необходимость перемещения "/system/storage/" за пределы web-директории (DocumetRoot): "Warning: You must move the storage directory outside of the web root directory!"

Это что-то не так и такую фичу сделали?

 

это фича, стандартное повышение безопасности. "вниз по лестнице" ходят все, о вот вверх "за пределы web-директории (DocumetRoot)" стандартными средствами ходу нет :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
bindpew123    0

Простите, Выше уже задавался этот вопрос, но я не понял, куда нужно заглянуть: никто не знает, где можно прочитать про отличия 3.0 от 2.3. Подходят ли старые модули?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
PeterStudio    12
4 минуты назад, bindpew123 сказал:

Простите, Выше уже задавался этот вопрос, но я не понял, куда нужно заглянуть: никто не знает, где можно прочитать про отличия 3.0 от 2.3. Подходят ли старые модули?

https://forum.opencart.com/viewtopic.php?f=2&t=185176

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Muvka    0

Здравствуйте. Начал осваиваться 3 дня назад с OC, вроде все ничего, но недавно 3я версия вышла и нигде не могу найти заготовки для модуля с выводом текста из админки. Старые не подходят, да и осваивать старую версию считаю неправильным. Может кто подсказать, есть где нибудь заготовка для модуля для OC 3.x или гайд, пусть на английском?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
jaffagold    139
28 минут назад, Muvka сказал:

и для модуля с выводом текста из админки

Может вам нужен Модуль HTML?

Осваивать на версии 3 еще нечего. Осваивайте 2.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Muvka    0

Мне надо сделать так, чтобы можно было в админке заполнить текстовое поле и значение этого поля вывести на страницу. А какой смысл осваивать 2.3, если он уже устаревает? И разработчики CMS не пишут гайды по своей системе?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 014

Если нужен Iphone 100, то беспорно нужно пыхтеть и пытаться делать на тройке.Которая судя по тенденциям,более менее рабочей станет с версии 3.1.... ближе к зиме я думаю.

Ну а если нужен магазин,а не побаловаться,то самая стабильная это 2.1.0.2.1 и 2.3.0.2.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
AlexDW    822
15 минут назад, Muvka сказал:

А какой смысл осваивать 2.3, если он уже устаревает?

 

движок на 2.3

1) более-менее стабильный

2) будет популярен еще пару лет как минимум, как последний из ветки 2х

3) на него полно дополнений и шаблонов

4) адекватные разработчики как правило обеспечивают поддержку своими дополнениями не только последней версии, но и предыдущих

т.е без поддержки и дополнений не останетесь

 

ситуация с движком на 3.0 на сегодня:

1) движок еще относительно сырой

2) свои дополнения и шаблоны под него авторы только-только начинают адаптировать

т.е. поставив 3.0 сейчас можно столкнутся с тем, что нужных вам шаблонов/дополнений под него еще нет

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
AlexDW    822
24 минуты назад, Muvka сказал:

И разработчики CMS не пишут гайды по своей системе?

 

у разработчиков CMS Opencart писатель гайдов ушел в запой после выхода версии 21х :D

ну - судя по последней версии документации

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Muvka    0

Хорошо. Мне пока магазин не нужен. Я учусь для того, чтобы работать. Впринципе синтаксис 2.3 php вполне стандартен, просто хотелось сразу с новой версии начать... Я так понимаю таких материалов, которые мне нужны еще нет? Я про шаблон модуля.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Muvka    0

Ну уже несколько патчей выкатили. Это по поводу сырости :) Хорошо, уговорили, буду тренироваться на 2.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

есть модуль HTML

его активировать

создать там текст и разместить в макетах

все так же как и в 2,3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
ibond    176
4 минуты назад, Muvka сказал:

Я учусь для того, чтобы работать.

Начните с 1.5. Работы валом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 014

Если вникнуть сразу в 3, то пропустите славную часть с html-tpl и сразу начнёте с твига.... Это как сесть за руль с коробкой автомат и даже не попытаться поездить на механике...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    932
6 минут назад, Tom сказал:

пропустите славную часть с html-tpl и сразу начнёте с твига..

 

Это если шаблонизировать

 

Но есть движки, в которые с самого начала  встроены шаблонизаторы.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Tom    2 014

Всё же лучше пройти весь путь)))) Какие были славные времена Opencart версии 1.4 ))) Потом  не совсем понятная 1,5. Неуместный bootstrap в двойке (который оказался чертовски удобным ) и вот теперь твиг! Когда в следующий раз Дэниел и сотоварищи,в баре Гон-Конга  под пифко,придумает очередное наказание для пользователей Opencart, обсудим и его.

Но всё же для реально рабочего проекта я бы рекомендовал (ИМХО)  Ocstore 2.1.0.2.1.......

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
chukcha    932

2.3 вкуснее

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу