Перейти к содержанию

Рекомендуемые сообщения

Дело в том что перешел на SSL сертификат, все работает нормально, весь сайт на SSL. Но вот только немогу зайти в админку. Так как при авторизации все данные в форме отправляются по http

<form action="http://botam.kz/admin/index.php?route=common/login" method="post" enctype="multipart/form-data">

Я нашел в шаблоне эту строку чтобы заменить на https а там переменный action

<form action="<?php echo $action; ?>" method="post" enctype="multipart/form-data">

Вопрос как это можно сделать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет, Вы ошибаетесь, в эту переменную будет приходить то, что необходимо. Проверьте конфиг админки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Almat, попробуйте для начало в /admin/config.php

 

вручную задать HTTPS :

 

// HTTP
define('HTTP_SERVER', 'https://MYSITE/admin/');
define('HTTP_CATALOG', 'https://MYSITE/');

// HTTPS
define('HTTPS_SERVER', 'https://MYSITE/admin/');
define('HTTPS_CATALOG', 'https://MYSITE/');

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
52 минуты назад, nexus сказал:

Нет, Вы ошибаетесь, в эту переменную будет приходить то, что необходимо. Проверьте конфиг админки.

 

22 минуты назад, Eldaeron сказал:

Almat, попробуйте для начало в /admin/config.php

 

вручную задать HTTPS :

 


// HTTP
define('HTTP_SERVER', 'https://MYSITE/admin/');
define('HTTP_CATALOG', 'https://MYSITE/');

// HTTPS
define('HTTPS_SERVER', 'https://MYSITE/admin/');
define('HTTPS_CATALOG', 'https://MYSITE/');

 

Все настройки сделал в конфиге админки и в конфиге сайта

В конфиге админке

// HTTP
define('HTTP_SERVER', 'https://botam.kz/admin/');
define('HTTP_CATALOG', 'https://botam.kz/');

// HTTPS
define('HTTPS_SERVER', 'https://botam.kz/admin/');
define('HTTPS_CATALOG', 'https://botam.kz/');

 

Изменено пользователем Almat
Забыл вставить код

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если я в этой форме

<form action="http://botam.kz/admin/index.php?route=common/login" method="post" enctype="multipart/form-data">

когда http изменяю на https в браузере мозила, через инспектор элемента то в админку заходит

http://joxi.ru/vAWDQ0NS1a9Wbr

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, Almat сказал:

Если я в этой форме


<form action="http://botam.kz/admin/index.php?route=common/login" method="post" enctype="multipart/form-data">

когда http изменяю на https в браузере мозила, через инспектор элемента то в админку заходит

http://joxi.ru/vAWDQ0NS1a9Wbr

В самой админке Вы включили SSL? В переменные лезть не нужно..

Изменено пользователем nexus

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, nexus сказал:

В самой админке Вы включили SSL? В переменные лезть не нужно..

Да включил

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У вас и на сайте все формы через хттп. (т.е. не работает авторизация, регистрация и иже с ими.)

В настройках сайта:

http://joxi.ru/Y2LQZq1ik9zwA6

 

Изменено пользователем lakbor

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, lakbor сказал:

У вас и на сайте все формы через хттп. (т.е. не работает авторизация, регистрация и иже с ими.)

В настройках сайта:

http://joxi.ru/Y2LQZq1ik9zwA6

 

я ее включил в первую очередь, все равно не работает

http://joxi.ru/Q2Kn8Eah43Y5Xm

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, конфиг отрабатывает. Можно посмотреть на Ваш .htaccess

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

хтаксесс тут ни при чём, за формирование урла отвечает контролер.

проверьте в БД, таблица setting http://joxi.ru/8AnbP01cZjvkAO

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, lakbor сказал:

хтаксесс тут ни при чём, за формирование урла отвечает контролер.

проверьте в БД, таблица setting http://joxi.ru/8AnbP01cZjvkAO

Да ладно? именно в .htaccess можно указать как и куда переходить. Так что давайте не будем торопить коней, а взглянем на .htaccess. Мало ли что там написано..

Изменено пользователем nexus

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

переходить - да, но этот файл не имеет никакого отношения к формированию урлов на сайте

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вот .htaccess

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch «(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))»>
Require all denied
## For apache 2.2 and older, replace «Require all denied» with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an «Internal Server Error 500» after enabling any of the following settings, restore the # as this means your host doesn’t allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сколько магазинов?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, chukcha сказал:

Сколько магазинов?

Один

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
<a itemprop="url" href="http://

 

Значит у вас модифицированный seo преобразователь

 

Отключите все модификаторы - проверьте

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если я удаляю или переименоваю файл htaccess то все работает нормально, но без SSL

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Очистить модификаторы  (сбросить все в изначальное состояние) и проверить

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
9 минут назад, chukcha сказал:

Очистить модификаторы  (сбросить все в изначальное состояние) и проверить

Это все не помогает

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Значит вы что-то делаете не так!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если у вас действительно в конфиге админки все ссылки с https, но в форме входа http - вариантов только два: либо косячит какой-то модуль (или сборка экзотическая и накосячил её автор), либо вы ошибаетесь на счёт конфига!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
59 минут назад, Dotrox сказал:

Если у вас действительно в конфиге админки все ссылки с https, но в форме входа http - вариантов только два: либо косячит какой-то модуль (или сборка экзотическая и накосячил её автор), либо вы ошибаетесь на счёт конфига!

Как может косячит модуль, можете объяснить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Столько вопросов - открывайте, и смотрит екод

Если в конфигах стоит везде https, то больше нигде не взять http, если у вас только  один магазин.

 

Все остальное у вас от лукавого..

Вы же не слышите, что вам говорят. и советуют. И, я  боюсь, что вы даже не проверяете и не пробуете, то что вам говорят.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.