SeNeS

После обновления такая проблема!

Рекомендуемые сообщения

SeNeS    0

Сам виноват случайно в админке в локации языков криво прописал русский язык . только нажал сохранить и получил вот это

перед этим обновлял 1.4.9 версию opencart на последнюю v1.5.1.3 September 29, 2011

Теперь вот такая проблема не могу понять как исправить язык на правильный тоесть где в файле index.php

ошибка вот такая .

Notice: Use of undefined constant HTTP_SERVER - assumed 'HTTP_SERVER' in /home/сайт/public_html/index.php on line 66

Notice: Use of undefined constant HTTPS_SERVER - assumed 'HTTPS_SERVER' in /home/сайт/public_html/index.php on line 67

Notice: Undefined index: ru in /home/сайт/public_html/index.php on line 178Notice: Undefined index: ru in /home/сайт/public_html/index.php on line 179Notice: Undefined index: ru in/home/сайт/public_html/index.php on line 182Notice: Undefined index: ru in /home/сайт/public_html/index.php on line 183Notice: Error: Could not load language ! in/home/сайт/public_html/system/library/language.php on line 26

при заходе на админку вот это

Notice: Undefined index: ru in /home/сайт/public_html/admin/index.php on line 118Notice: Undefined index: ru in /home/сайт/public_html/admin/index.php on line 121Notice: Undefined index: ru in/home/сайт/public_html/admin/index.php on line 122Notice: Error: Could not load language ! in /home/сайт/public_html/system/library/language.php on line 26

ПАМАЖИЦЕ ХТО ЧЫМ МОЖА )))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yesvik    485

Похоже у тебя конфиги остались от версии 1.4.9...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SeNeS    0

ну в принципе перезалить попробовать на 1.4.9 версию могу благо бекап есть сейчас попробую

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yesvik    485

Конфиги от 1.4.9 не подходят для 1.5.1.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SeNeS    0

так и что делать сбрасывать все модули? ставить наново все?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Yesvik    485

Файлы config.php и admin/config.php от версии 1.4.9 не подходят к версии 1.5.1.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
magsilver    22

Я тоже промучился с переходом с 1.4.9 на 1.5.1.3 , потом плюнул и сделал финт ушами:

- так как папки изображений в обоих релизах сидят одинаково

- так как в старом релизе было много модов и дополнений самостоятельно поставленных и вычистить весь этот хлам весьма проблематично

- файл CSV подходит к обоим релизам (прописано одинаково)

сделал так :

- сделал экспорт CSV

- скопировал все файлы относящиеся к SEO

-удалил с сервера весь скрипт за исключением папки image

- залил на сервер новый релиз

- сделал установку скрипта по новой

- установил модуль импортэкспорт

- очистил магазин от демо картинок и описаний

- сделал импорт CSV

Все.

Магазин снова рабочий

Осталось под настроить под себя вид магазина (шаблон новый например), установить доп.модули которые необходимо. Заново поставить файлы SEO, внести коды верификации в скрипт, поставить заново сохраненные коды счетчиков и др.

Разобраться в новой структуре конфигурации магазина .

Разобраться тяжело, если обновляешься.

Поэтому не спеши удалять демо и делать импорт CSV, внимательно посмотри что где и как установлено в демке, какие модули и за какие схемы отвечают и выводятся где.

После этого будет понятно как выводить модули и что такое схема.

Только после этого удаляй демо материал и импортируй свой CSV файл.

Ну а если знаешь - можно удалять сразу.

И весь процесс проходит быстрее , чем обновление

Я на первое обновление затратил 2 дня с переустановками, попыткой понять, писанием тем в форуме (иногда не лицеприятных) и все неудачно и с заморочками (мешали модули для 1.4.9 которые конфликтовали с новым релизом).

А установка с нуля и настройка магазина заняла (с учетом скорости соединения) около 30-40 минут.

Вот и решай что лучше - писать крики о помощи, или установить с нуля.

В принципе это можно сделать как руководство для перехода с 1.4.9 на 1.5.1.3 для простых юзеров.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SeNeS    0

все таки поставил новую версию покрутил повертел и понял что она реально хороша , раз у меня еще не такой огромный магазин понял что разбирать траблы уйдет времени уйма и проще передобавить товар .

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу