TehSur

Не заходит на внутренние страницы

Рекомендуемые сообщения

TehSur    0

Всем здравствовать.

В общем началось мое знакомство с созданием ИМ на ocStore. Версия 2.3. Развернул на OpenServer. Вроде ничего так, шустренько работает, нравится. Полез первым делом в настройки. Для начал изменил htaccess.txt на .htaccess. Поставил ЧПУ через SeoPro. Захожу на сайт, все нормально, но при переходе на любую страницу выдает стандартную стартовую страницу OpenServer.

 

Что я сделал не так? В файлы не лез, сделал:

"Да" на Включить SEO URL

Тип ЧПУ - SeoPro

"Да" на ЧПУ товаров с категориями

Вроде больше ничего не трогал. Никаких плагинов и шаблонов пока не ставил, но представляю каково оно будет)) Помогите, люди добрые, как решить сию проблему? Гуглить пробовал, но как-то не нашел ответа.

Снимок.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SiteMix    145

Попробуй системный кэш Опенкарта очистить в админке: Система - Инструменты - OC Team

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0
12 минут назад, SiteMix сказал:

Попробуй системный кэш Опенкарта очистить в админке: Система - Инструменты - OC Team

Не помогает, также почистил кэш браузера заодно. Тоже самое выдает. На всякий случай настройки серва:

 

Снимок.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0

Пробовал отдельно подключать:

Цитата

 

"Да" на Включить SEO URL

Тип ЧПУ - SeoPro

"Да" на ЧПУ товаров с категориями

 

Проблема возникает только с Включить SEO URL

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SiteMix    145

У ссылок по которым собираешься перейти SEO_URL прописаны?

Кстати, а если включить SEO URL и выбрать тип ЧПУ Default, та же история? И пока попробуй без категорий, потому как у категорий могут быть не прописаны SEO_URL.

PS: А тема дефолтная?

Изменено пользователем SiteMix

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0
30 минут назад, SiteMix сказал:

У ссылок по которым собираешься перейти SEO_URL прописаны?

Кстати, а если включить SEO URL и выбрать тип ЧПУ Default, та же история? И пока попробуй без категорий, потому как у категорий могут быть не прописаны SEO_URL.

PS: А тема дефолтная?

Спасибо за помощь. Дома гляну, сейчас на работе. Тема дефолтная, вообще ничего не делал с сайтом. Только развернул на сервере, и сразу пошел ЧПУ делать. Пробовал без категорий.

Цитата

Проблема возникает только с Включить SEO URL

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0
Цитата

Кстати, а если включить SEO URL и выбрать тип ЧПУ Default, та же история?

Такая же беда. Может проблема с сервером? Попробую сейчас еще на денвере развернуть тот же дистрибутив.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0

В общем развернул на денвере. Столкнулся с тем, что нынешняя версия поддерживает только 5.3 php. Нашел как обновиться до 5.6. Тоже ошибку выдает при включении Включить SEO URL

Что я делаю не так? Или на виртуальном сервере не поднять ocStore с ЧПУ?

Снимок.PNG

Upd: забыл htaccess переименовать. После смены на нормальное имя .htaccess выдает не 404, а кидает на главную денвера. Собственно, как и с OpenServer.

 

Снимок.PNG

Изменено пользователем TehSur

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SiteMix    145

 

6 часов назад, TehSur сказал:

Или на виртуальном сервере не поднять ocStore с ЧПУ?

У меня на Денвере всё нормально. Опенсервером не пользуюсь.

Обратил внимание на url на твоих скриншотах. В обоих случаях у тебя они начинаются с локалхоста. У меня хоть с переименованным .htaccess, хоть нет, в любом случае site.ru/desktops, только в одном случае сайт открывается, а в другом – "страница не найдена".

Может быть ты не в ту папку файлы положил? Нужно файлы помещать туда C:\WebServers\home\site.ru\www\ (если Denwer на диск C: установлен)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
TehSur    0
5 часов назад, SiteMix сказал:

 

У меня на Денвере всё нормально. Опенсервером не пользуюсь.

Обратил внимание на url на твоих скриншотах. В обоих случаях у тебя они начинаются с локалхоста. У меня хоть с переименованным .htaccess, хоть нет, в любом случае site.ru/desktops, только в одном случае сайт открывается, а в другом – "страница не найдена".

Может быть ты не в ту папку файлы положил? Нужно файлы помещать туда C:\WebServers\home\site.ru\www\ (если Denwer на диск C: установлен)

Да, ты прав, спасибо, это помогло :) Сейчас открывается нормально. Но почему то os.ru браузер открывал реальный сайт, хотя в файле hosts было правило, которое указывало на локалхост, но не срабатывало почему-то. Поэтому переименовав папку таки открыл свой магазин и таки перешел на товар))

P.s. Еще раз спасибо за помощь :)

 

Снимок.PNG

Изменено пользователем TehSur

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SiteMix    145
7 часов назад, TehSur сказал:

Но почему то os.ru браузер открывал реальный сайт

Чтобы не путаться и не лазить в hosts можно просто вместо site.ru использовать site.local
А когда будешь переносить на хостинг, в config.php и admin/config.php исправишь .local на .ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу