Phetsor

Белый экран после переноса с денвера на timeweb

Рекомендуемые сообщения

Phetsor    0

Вобщем вопрос у меня ребят следующий. Помогите сил нет.

 

Вкратце - залил файлы сайта с локального сервера на хостинг таймвэб. На локальном все работает отлично.

 

Скачал нужную БД из пхпмайадмин, импортировал её на таймвеб все встало хорошо. (кстати БД из бэкапа из админки магазина, почемуто не принимает поэтому скачал напрямую из майадмина).

 

 

Дальше начинается абракадабра.

С общем поправил конфиг файлы, в бд заменил локальные адреса на домен, вообщем уже раз 10 так делал, все было нормально.

 

Получил белый экран, и на админку тоже.

Вообщем пробовал все перезаливать, файлы сайта и бд. Делал так 3 раза. не помогло=)

 

Потом начал шаманить с конфиг файлом и вот что получил (в скринах), когда убираю ДБ-порт в конфиг.пхп, выходит "ломаная" страница сайта, но хотя бы выходит. 

скрин 11 показывает ошибки ( в хтаксес включил эррорвью ) при ДБ-порте 3306.

 

 

 

ПС с админкой таже абсолютно фигня, когда убираешь в конфиге ДБ-порт, начинает работать вместо белого экрана, но в админку под логином и паролем все-равно не пускает.

 

Вообщем не могу понять что сделал не так, тупняк уже просто дикий. Помогите пожалуйста разобраться!

post-720837-0-54617600-1480868878_thumb.png

post-720837-0-47950900-1480868885_thumb.png

post-720837-0-69753500-1480868894_thumb.png

post-720837-0-42427300-1480868904_thumb.png

Изменено пользователем Phetsor

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
shalan    36

Hostname странный. Обычно localhost или поддомен хостинга

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Phetsor    0

Это пробовал уже танцы с бубном, а так локалхост и стоит =(((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Dotrox    314

Это пробовал уже танцы с бубном, а так локалхост и стоит =(((

Какие ошибки пишет, когда стоит локалхост? На скринах у вас ошибки связанные с неправильным хостом.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
druzhkov    22

Это пробовал уже танцы с бубном, а так локалхост и стоит =(((

 

Попробуйте драйвер mysql (без "i"). Еще я посмотрел другой конфиг, тоже на таймвебе, там стоит драйвер mysqliz.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Phetsor    0

Попробуйте драйвер mysql (без "i"). Еще я посмотрел другой конфиг, тоже на таймвебе, там стоит драйвер mysqliz.

dc5b16542398.png
 это ответ на mysqliz
 
80453508eff3.png
а это mysql без i

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
thentru    171

У вас пароль указан от БД?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Phetsor    0

Прошу прощенья. Видимо совсем мозги скисли за последнюю неделю-(((

 

define('DB_DRIVER', 'mysqli');
define('DB_HOSTNAME', 'localhost');
define('DB_USERNAME', 'cy30642_roman');
define('DB_PASSWORD', 'roman');
define('DB_DATABASE', 'cy30642_roman');
define('DB_PORT', '3306');
define('DB_PREFIX', 'oc_');
 
Решило проблемы, причем странно что до этого такой вариант я ставил. но проблему не решало....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
druzhkov    22

это ответ на mysqliz

Для mysqliz нужны дополнительные скрипты, "из коробки" он не идет. Это так, на будущее.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу