Перейти к содержанию

Рекомендуемые сообщения

Добрый день.

Такая ситуация. хотел обновить до новой версии ocStore 2.1.0.2.1  с  ocStore  1.5.5.1.2

свои два ИМ. но не получаеться. делаю всю по инструкции. что то видимо изменилось раньше

уже обновлялся.

 

Так вот хотелбы купить подробную инструкцию по шагам по обновлению.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так вот хотелбы купить подробную инструкцию по шагам по обновлению.

 

не думаю, что  бывают такие инструкции.

или у вас чисто дефолтная версия магазина, и не установлено ни одного стороннего модуля? как то слабо в это верится.

 

Вы не готовы заплатить за перенос? думаете, что научить вас вам выйдет дешевле?

может быть лучше пригласить музыканта, чем писать инструкцию по игре на муз. инструменте?

 

делаю всю по инструкции

 

 

что за инструкция? откуда?

 

Если желаете, то сделаю качественный перенос. пишите в личку.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не думаю, что  бывают такие инструкции.

или у вас чисто дефолтная версия магазина, и не установлено ни одного стороннего модуля? как то слабо в это верится.

 

Вы не готовы заплатить за перенос? думаете, что научить вас вам выйдет дешевле?

может быть лучше пригласить музыканта, чем писать инструкцию по игре на муз. инструменте?

 

 

что за инструкция? откуда?

 

Если желаете, то сделаю качественный перенос. пишите в личку.

инструкци то не бывают. но описать по шагам текстовом редакторе несложно я думаю

у меня не получаеться обновиться  для меня это принципиально 

разве сделать обновление такая сложная работа. по этому хочу понять где я ошибаюсь или в чем проблема.

обновление делать я умею все таки обновлялся досехпор до версии  1. 5.5.1.2

 

модули установлены шаблон деволтный. но все равно нужны будут новые модули под новую версию а старые не совместимы будут

переносить там не чего не нада кроме категории и товара и то там 50 товаров с картинками и описан не больше. сайты не раскрученные и ценность их не велика чтобы платить за перенос

существенную сумму. лекче снисти и установить все с нуля. 

 

музыканта приглашать тоже ненужна. для меня это принципиально найти причину. и научиться самому обновлять переносить данные и т б .

 

вы ведь тоже не сразу музыкантам родились. а учитель методом проб и ошибок.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

разве сделать обновление такая сложная работа

потому и минус в репу?

 

вы не видите разницы в обновлении одной ветки, хоть и разных версий,  и в обновлении с одной ветки до другой?

 

аучиться самому обновлять переносить

 

учитесь, кто же вам мешает?

 

Открываете две БД разных движков (1.5 и 2.1 к примеру).  в phpmyadmin, например.  И изучаете структуру всех таблиц. Их там немного, 110 всего или больше (когда есть сторонние модули).

 

Многие таблицы имеют одинаковое название. Во многих из них количество полей также совпадает. тщательно изучаете структуру всех таблиц. и на основе этого анализа делаете вывод что и как из таблиц одного движка перенести в таблицы другого движка.

 

некоторые таблицы можно целиком или почти целиком переносить.

 

это если нужно все данные перенести.  Если нужно выборочно, то смотрите только нужные таблицы.  Это долго и довольно сложно.

 

если только товары и при этом вас не волнуют адреса (url) товаров в новом магазине, то может помочь экспорт и импорт.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

вы не видите разницы в обновлении одной ветки, хоть и разных версий,  и в обновлении с одной ветки до другой?

вот в этой ветке описывают как обновиться

https://opencartforum.com/topic/59256-решено-как-обновить-ocstore-2102-до-21021/?do=findComment&comment=529766

 

Копируете в корень своего сайта все файлы и 'папки' из этого архива, затем из дистрибутива предыдущей версии копируете 'папку' install и заменяете файлы в install с архива с измененными файлами.

Можно поступить несколько проще, взять install целиком из дистрибутива ocStore 2.1.0.1.2

Обязательно запустить mysite.ru/install (где mysite.ru - это ваш сайт) и пройти процедуру обновления для добавления в БД новых полей и синхронизации настроек системы.

После этого удалить директорию install с сервера.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

потому и минус в репу?

 

 

 

Открываете две БД разных движков (1.5 и 2.1 к примеру).  в phpmyadmin, например.  И изучаете структуру всех таблиц. Их там немного, 110 всего или больше (когда есть сторонние модули).

 

Многие таблицы имеют одинаковое название. Во многих из них количество полей также совпадает. тщательно изучаете структуру всех таблиц. и на основе этого анализа делаете вывод что и как из таблиц одного движка перенести в таблицы другого движка.

 

некоторые таблицы можно целиком или почти целиком переносить.

 

это если нужно все данные перенести.  Если нужно выборочно, то смотрите только нужные таблицы.  Это долго и довольно сложно.

 

получаеться что с версии 1.5 не обновиться на 2.1 даже промежутками версии (Заливаем файлы поверх старых.Жмём сайт/install.Проходим процесс обновления по всем промежуточным версиям.Начиная от 1.5, потом 1.6 итд.... обычным обновлением ) 

 

только переносом данных.

нужно устанавливать новую версию 2.1 на поддомен и новую базу phpmyadmin

и через админ сайта  загрузить базу из бекапа или phpmyadmin (востановить данные бэкап)

сделаную зарание бэкап (только так чтоли а через инстел не как)

 

 

 

 

 

если только товары и при этом вас не волнуют адреса (url) товаров в новом магазине, то может помочь экспорт и импорт.

волнует.

а ссылки и картинки как во становить через phpmyadmin?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вот в этой ветке описывают как обновиться

 

вы внимательно читали?

 

КАК ОБНОВИТЬ ocStore 2.1.0.2 до 2.1.0.2.1

 

 

какое отношение имеет эта тема к нашей теме разговора?

 

вы же сами озвучили версии:

 

до ocStore 2.1.0.2.1  с  ocStore  1.5.5.1.2

 

 

получаеться что с версии 1.5 не обновиться на 2.1 даже

 

даже с помощью инструкции не обновиться, ибо нет такой инструкции.  я вам об этом сразу сказал, но вы обиделись.

 

и через админ сайта загрузить базу из бекапа или phpmyadmin (востановить данные бэкап) сделаную зарание бэкап (только так чтоли а через инстел не как)

 

ваши предположения не имеют ничего общего с действительно необходимыми шагами.

а ваш уровень подготовки, видимо, недостаточен для того чтобы суметь понять ту информацию, которую я вам выше предоставил.

 

Попробуйте найти для начала подходящие книжки вроде "как стать программистом за 21 день" или "программирование для чайника".  Возможно, что вам тогда и инструкция не понадобится.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

ваши предположения не имеют ничего общего с действительно необходимыми шагами.

а ваш уровень подготовки, видимо, недостаточен для того чтобы суметь понять ту информацию, которую я вам выше предоставил.

 

Попробуйте найти для начала подходящие книжки вроде "как стать программистом за 21 день" или "программирование для чайника".  Возможно, что вам тогда и инструкция не понадобится.

до вашего уровня программирование мне далеко. я всего лишь познаю. для чего тогда нужен этот форум?

когда кто то обращается за помощью в том или ином вопросе. 

 

я заметил что на этом форуме когда какой-нибудь чайник вроде меня задает глупый вопрос, с точки зрения опытных

форумчат, сразу закидывают помидорами и отправляют читать книжки или  гугл в помощь. поэтому многие пишут сразу не закидывайте помидорами

 

а просто подсказать на простом и понятном языке для чайника, разве так сложно. чтобы чайник не переспрашивал и не выглядел глупа. вот вы то книжки отправляте читать то музыкантов вызываете. такое  высокомерие и сарказм, нехорошая черта у людей, и хочу вам посоветовать избавится от нее. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1 - адаптировать базу

2 - написать скрипт для миграции всех нужных данных

3 - перезалить все новые файлы, удалив ненужное, сделав миграции нестандартных кусков кода

4 - адаптировать шаблон

5 - адаптировать\обновить все модули 

как-то так )

Изменено пользователем timedontwait

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Попробуйте модуль A-migration

Как раз под ваши задачи и хотелки.

Я пользовался - все отлично работает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.