SoundSurfer

[Решено] Проблема с кешированием

Рекомендуемые сообщения

SoundSurfer    1

Выставляя изображение в категорию, всё якобы выставилось, но подгружает из кеша изображение.
При этом его нету, так как адрес для него выводится видом
image/cache/data/kategorii/0.157922001412509187-x.jpg
А кашированная версия зовется
image/cache/data/kategorii/0.157922001412509187-100x100.jpg
Куда теряются из адреса 100х100, "нипанятно".
Лог никаких ошибок не выдает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Exploits    146

это на всех фото такое?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SoundSurfer    1

это на всех фото такое?

Нет, именно сабкатегории. 

При этом, не отображается только когда заходишь в категорию

eC2Hhd6.png

 

Далее, если зайти уже в саму подкатегорию, изображение там есть.

Изменено пользователем SoundSurfer

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
AlexDW    818

убедитесь что у вас в настройках магазина задан размер для изображений категорий

если задан - копайте контроллер catalog\controller\product\category.php, там где формируется изображение

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
SoundSurfer    1

Разобрался, проблему вызывает кэшменеджер.. пойду пилить разраба. Спс =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу