Перейти к содержанию
ArtemPitov

OC ver. 1.5.x.x vs OC ver. 2.x.x | или как дальше жить

Рекомендуемые сообщения

Поделитесь размышлениями, как все понимают Даниэлю  :ph34r:  скучно, и он начинает все новое и новое придумывать

 

Вот хочу написать модуль, стоит ли писать под ветку 1,5хх (правда уже админка написана :-D ) или сразу под 2хх ?

Но блин во второй ветке не все гладко, есть 2.1.x есть 2.2.x, как быть, посоветуйте или хотя бы подкинет мыслишек ))  

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Пишите, сами поймете.

 

 

Но блин во второй ветке не все гладко, есть 2.1.x есть 2.2.x,

Что вы там нашли негладкого?

Ну да есть отличия.. И вы на них наткнулись в своем первом модуле?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Пишите, сами поймете.

 

Что вы там нашли негладкого?

Ну да есть отличия.. И вы на них наткнулись в своем первом модуле?

пока нет, не наткнулся, только размышления по поводу под какую ветку пилить или сразу под две   

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

пилите

Но... тут такая штука..

 

Вроде запилил под 1.5,

переходишь на пилку 2

Но вовремя пилки 2 появились новые идеи, внедряешь, а на 1.5 их нет

Начинаешь допиливать 1.5 и опять новые идеи

И по кругу.. И так хочется отказаться от какой-то вресии

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

пилите

Но... тут такая штука..

 

Вроде запилил под 1.5,

переходишь на пилку 2

Но вовремя пилки 2 появились новые идеи, внедряешь, а на 1.5 их нет

Начинаешь допиливать 1.5 и опять новые идеи

И по кругу.. И так хочется отказаться от какой-то вресии

 

Это прям как 

<? for(;;;) {} ?> 

:-D

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я новый модуль пишу только под 2.x

Но один фиг все равно получается два: один для всех 2.x до 2.2, второй для 2.2 only. Куда фантазия этого чувака приведёт я хз, понятия обратная совместимость для него не существует даже в рамках минорных версий

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я новый модуль пишу только под 2.x

Но один фиг все равно получается два: один для всех 2.x до 2.2, второй для 2.2 only. Куда фантазия этого чувака приведёт я хз, понятия обратная совместимость для него не существует даже в рамках минорных версий

вот это и смущает, правда я еще не посмотрел что там он кардинального во 2.2 сделал 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Я новый модуль пишу только под 2.x

Но один фиг все равно получается два: один для всех 2.x до 2.2, второй для 2.2 only. Куда фантазия этого чувака приведёт я хз, понятия обратная совместимость для него не существует даже в рамках минорных версий

 

проблемы негров шерифа не @бут! (с) :-D

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Даже не знаю что посоветовать в таком "деле"
Я сам под "впечатлением" от "резвости" и крутых виражей  Даниэля.

И как писать модули и в какую сторону "двигаться" хрен его знает

Понял только одно - никаких ocmod и vqmod, "привязки" и логика  меняются от версии к версии (еще и  настолько быстро). причем настолько радикально, что все vqmod / ocmod для предыдущей версии можно выкидывать в мусорку, легче заново сделать

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Даже не знаю что посоветовать в таком "деле"

Я сам под "впечатлением" от "резвости" и крутых виражей  Даниэля.

И как писать модули и в какую сторону "двигаться" хрен его знает

Понял только одно - никаких ocmod и vqmod, "привязки" и логика  меняются от версии к версии (еще и  настолько быстро). причем настолько радикально, что все vqmod / ocmod для предыдущей версии можно выкидывать в мусорку, легче заново сделать

придется ждать 2.3 тогда, ну и писать тогда все параллельно системе, вот тут будет над чем по мозговать (а для меня еще и что то нового научиться) 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а под какие ж версии тогда новые шаблоны творить?

 

получается, что для  2-й ветки (все, что до 2.1.*) еще и модулей всяких и нужных наделать/переделать не успели, а она уже безнадежно устарела?

Начинай все по новой делать для 2.2? 

 

Что-то уж больно "крутые виражи" выходят...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

а под какие ж версии тогда новые шаблоны творить?

 

...

CSS только :)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.