Jump to content
Sign in to follow this  
EgorKus

Проблема при восстановлении дампа БД

Recommended Posts

Всем привет!

В 2012г у меня был домен и сайт на OpeCart 1.5.2.

Сейчас возникло желание его восстановить.

Нашел бэкап сайта и отдельно бэкап БД.

Бэкап сайта накатил и картинками товаров - все Ок.

Осталось восстановить БД из дампа.

При попытке импорта backup.sql выдает ошибку:

"SQL-запрос:
TRUNCATE TABLE `openc_address` ;
Ответ MySQL:
#1146 - Table 'sites_ocart.openc_address' doesn't exist"

Где и в чем проблема?

Share this post


Link to post
Share on other sites

В магазине присутствует модуль,таблицы которого не возможно восстановить таким образом.Поэтому и пишет ошибку,что не существует такой таблицы

#1146 - Table 'sites_ocart.openc_address' doesn't exist"

Share this post


Link to post
Share on other sites

Tom, похоже Вы правы.

Не могу понять чем был создан этот дамп, если этот файл начинается с:

"TRUNCATE TABLE `openc_address`;"

Не помню, чем его создавал.

3 модуля помню: 

1.экспорт-импорт в Exel (фришный) - сейчас установлю.

2.модуль статистики посещения сайта (сейчас ставить не планирую).

3.Модуль "Категории на главной" (покупной) попробую найти инсталляцию.

Т.е. нужно либо "восстановить" структуру БД и в неё залить sql.

Не могу вспомнить чем и как я создал такой странній дамп...

Как ещё можно поправить ситуацию?

Share this post


Link to post
Share on other sites

как минимум можно просто закоментироваь в sql TRUNCATE TABLE `openc_address`;"

и все. А на будущее, делайте бекап через phpmyadmin, а не через админку.

Share this post


Link to post
Share on other sites

Можно так же установить те модули что были в прежнем магазине,установить их и потом бэкапом восстановить магазин.

Share this post


Link to post
Share on other sites

Здравстсвуйте!

Простите за такой идиотизм, конечно. Я удалила базу данных, бэкап есть, не ставится, делала через админку. Собираюсь попробовать поставить модули на сайт и восстановить. Скажите, пожалуйста, у меня не работает админка, хотя базу данных создала с прежним паролем. Плохо проверила пароль, или есть ещё и другие причины, почему она может не работать?
Спасибо!

Share this post


Link to post
Share on other sites

Подробней опишите порядок действий.Поможем.

  • +1 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.