alex777

[Решено] Мой первый сайт вышел в свет ... и снова пришли проблемы ...

Рекомендуемые сообщения

alex777    2

Вот запустил свой первый сайт http://virtmag.com/

После определенных танцев с бубном стал корректно отображаться. Но возникли новые вопросы:

1. При загрузке сайта изображения из слайд-шоу вываливаются в столбик, при обновлении страницы - таже ситуация ... - можно как-то это подправить?

2. Облако тегов ведет себя не корректно. в Опере нет ни одного, в Експлорере только 3 шт. Может установить другое или вообще убрать?

3. при проверке сайта говорит что у меня 9 внешних ссылок (http://seorank.com.ua/analiz.php?url=virtmag.com%2F)Но я чего-то не могу врубиться почему их за внешние принимает, это плохо?

4. SEO-url не подключается (выдает 404 ошибку), может что на хосте нужно настроить? В саппорте говорят что ищите у себя ошибку они поддерживают SEO-url.

\admin\view\javascript\ckeditor.htaccess содержит такое:

#
# Copyright (c) 2003-2009, CKSource - Frederico Knabben. All rights reserved.
# For licensing, see LICENSE.html or http://ckeditor.com/license
#

#
# On some specific Linux installations you could face problems with Firefox.
# It could give you errors when loading the editor saying that some illegal
# characters were found (three strange chars in the beginning of the file).
# This could happen if you map the .js or .css files to PHP, for example.
#
# Those characters are the Byte Order Mask (BOM) of the Unicode encoded files.
# All FCKeditor files are Unicode encoded.
#

AddType application/x-javascript .js
AddType text/css .css

#
# If PHP is mapped to handle XML files, you could have some issues. The
# following will disable it.
#

AddType text/xml .xml

# SEO URL Settings
RewriteEngine On
RewriteBase /zoo3/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
senty    15

4. SEO-url не подключается (выдает 404 ошибку), может что на хосте нужно настроить? В саппорте говорят что ищите у себя ошибку они поддерживают SEO-url.

\admin\view\javascript\ckeditor.htaccess содержит такое:

.htaccess должен лежать в корне сайта, а не в директории с визуальным редактором.

к примеру, у меня сайт лежит в

/site.mestodetok.net/public_html/

т.е. htaccess должен быть так:

/site.mestodetok.net/public_html/.htaccess

Возможно у Вас лежит

htaccess.txt

переименуйте его в

.htaccess

3. при проверке сайта говорит что у меня 9 внешних ссылок (http://seorank.com.u...=virtmag.com%2F)Но я чего-то не могу врубиться почему их за внешние принимает, это плохо?

Внешние ссылки, да еще и с главной страницы - это плохо.

С чего Вы взяли, что у Вас внешние ссылки есть?

Изображение

2. Облако тегов ведет себя не корректно. в Опере нет ни одного, в Експлорере только 3 шт. Может установить другое или вообще убрать?

Считаю их бесполезными.

Сайт грузится достаточно долго...

ps Моё мнение может отличаться от мнения других.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alex777    2

С SEO спасибо. Действительно он у меня был не в корневой папке. Но теперь при переходе например в раздел Планшетники в строке отображает адрес http://www.virtmag.com/tablet_pc а на самом деле находится на главной. Так с любой ссылкой ...

А что по поводу первого вопроса? Это нормальное поведение слайд-бара? Или можно что-то исправить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alex777    2

Конкретизирую вопросы ...

Осталось 2 вопроса:

1. Теперь при переходе например в раздел Планшетники в строке отображает адрес http://www.virtmag.com/tablet_pc но на самом деле находится на главной. Так с любой ссылкой ... как исправить?

2. Слайд-бар (nivoslider) при загрузке\обновлении страницы вываливает все изображения в столбик пока страница полностью не загрузится (рис1). Очень не красиво ... На оф. сайте и в примерах сайтов такого не наблюдается. Можно ли что-то сделать

+ один новый вопрос - прошли сутки и Гугл Аналитикс выдал первый результат (рис2): Показатель отказов - 31,82% Я не очень представляю что это такое, но чутье подсказывает что это есть не хорошо...

post-4082-0-97828200-1298123660_thumb.jpg

post-4082-0-03199700-1298165420_thumb.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alex777    2

Подскажите ПОЖАЛУЙСТА!!! Вопросы актуальные! Что с ЧПУ? Как слайдбар настроить чтобы например эта область была пустой пока не подгрузит все изображения? Использую nivoslider (http://nivo.dev7studios.com/)

По поводу "Показателей отказов" разобрался, пока на это не стоит обращать внимания.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis    1 099

https://opencartforum.com/topic/1693-seo-url/page__view__findpost__p__10292

# Подробнее на https://myopencart.com

Options +FollowSymlinks

# Запретить листинг директорий 
Options -Indexes

# Закрыть доступ к файлам шаблонов
<FilesMatch "\.tpl">
Order deny,allow
Deny from all
</FilesMatch>

# Необходимо для ЧПУ.
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

ПУСТАЯ СТРОКА В КОНЦЕ ФАЙЛА ОБЯЗАТЕЛЬНА

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alex777    2

https://opencartforum.com/topic/1693-seo-url/page__view__findpost__p__10292

# Подробнее на https://myopencart.com
...
ПУСТАЯ СТРОКА В КОНЦЕ ФАЙЛА ОБЯЗАТЕЛЬНА
1. C .htaccess разобрался вместе с тех. поддержкой хостинга (там какой-то запрещенный символ у меня был - они сами его удалили).

2. Кто-то устанавливал Nivoslider (http://nivo.dev7studios.com/)? У меня при загрузке изображения вываливаются за пределы области "слайдбара" На их демонстрационных страницах такое не наблюдается (там пока все изображения не подгрузятся - пусто и только колесик крутится (типа идет загрузка)). Я понимаю что что-то не так там прописал, а вот что именно ... Может вынести этот вопрос в отдельную тему?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
afwollis    1 099

...там какой-то запрещенный символ у меня был - они сами его удалили..

сколько было сказано про кодировку и виндовый BOM... https://opencartforum.com/public/style_emoticons/default/dry.gif

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
alex777    2

сколько было сказано про кодировку и виндовый BOM... https://opencartforum.com/public/style_emoticons/default/dry.gif

Вот тут готов поспорить и сослаться на мистику :) Я пользуюсь ноутпадом+++ .htaccess как создавал сам, так закачивал из сборки. Вобщем что-то не совсем понятное для меня. Как бы там ни было этот вопрос закрыт. С разрешения модераторов вопрос по Nivoslider выведу в отдельную тему

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу