Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Помогите настроить модификатор


Recommended Posts

Добрый вечер! Не получается запустить модификатор

<?xml version="1.0" encoding="UTF-8"?>
<modification>
 <name>MyMod</name>
  <code>MyMod</code>
  <version>1.4</version>
  <author>MyMod</author>
  <link></link>
    <file path="test/catalog/view/theme/$$/template/common/footer.twig">
        <operation>
            <search><![CDATA[
            <div class="col-xs-12 col-sm-12">
            ]]></search>
            <add position="replace"><![CDATA[
            <div class="col-xs-12 col-sm-12" style="display:none">]]></add>
        </operation>
    </file>  
</modification>

Строка с файла:  <div class="col-xs-12 col-sm-12">

 

Подскажите в чем может быть проблема

Link to post
Share on other sites

а так?

<search><![CDATA[<div class="col-xs-12 col-sm-12">]]></search>

(лишнюю табуляцию и пробелы убрать)

  • +1 1
Link to post
Share on other sites

5 минут назад, SGrWr_34 сказал:

а так?

<search><![CDATA[<div class="col-xs-12 col-sm-12">]]></search>

(лишнюю табуляцию и пробелы убрать)

Не работает

Link to post
Share on other sites

а что за ошибка-то? Там где-то показывается, в чем проблема.. можете скрин скинуть?

Edited by Prooksius
  • +1 1
Link to post
Share on other sites

Вместо этого:

<file path="test/catalog/view/theme/$$/template/common/footer.twig">

Надо написать это:
 

<file path="catalog/view/theme/*/template/common/footer.twig">

Откуда вообще такое "$$" взяли?

И что за "test" в начале пути?

 

Ну и надо потом ещё очистить кэш twig.

И проверить чтобы шаблоны не были отредактированы в админке. Т.к. к ним тогда не будут применяться модификаторы. 

  • +1 2
Link to post
Share on other sites
2 минуты назад, Prooksius сказал:

а что за ошибка-то? Там где-то показывается, в чем проблема.. можете скрин скинуть?

Ошибок никаких нету, просто не получается сделать модификатор чтоб скрыть часть кода 

В консоле прописываю display:none, элемент скрывается

В footer прописываю, тоже скрывается, но вот через модификатор, вообще результата нету. Думаю может в нем проблема

 

Link to post
Share on other sites

1 минуту назад, mpn2005 сказал:

Вместо этого:

<file path="test/catalog/view/theme/$$/template/common/footer.twig">

Надо написать это:
 

<file path="catalog/view/theme/*/template/common/footer.twig">

Откуда вообще такое "$$" взяли?

И что за "test" в начале пути?

 

Ну и надо потом ещё очистить кэш twig.

И проверить чтобы шаблоны не были отредактированы в админке. Т.к. к ним тогда не будут применяться модификаторы. 

Спасибо, ошибка была в пути . Работает

test - это папка тестового сайта

 

Link to post
Share on other sites

Только что, Ch0oJoy сказал:

test - это папка тестового сайта

В модификаторе это не надо указывать. Все пути только от корня.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.