Перейти к содержанию
spambot

Проблема с кодировкой в бурж шаблонах

Рекомендуемые сообщения

ребят подскажите пожалуйста где что нужно поменять чтоб избавится от ромбиков с вопросиками именно в категории товара. Я преконвертил в UTF-8 без бом и шаблон и контроллер и модель все фаилы короче что отвечали за вывод в категории и модулях и все равно картина такая причем не везде вообщем прилагаю скрин надеюсь на помощь сообщества.

post-16727-0-90345000-1354201606_thumb.png

post-16727-0-25753700-1354201629_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Похожий контент

    • От mawgan
      Всем привет!
      После настроек редиректа появилась следующая проблема. При переходе на 2 страницу результатов поиска по сайту слетает кодировка. Например, вместо "Крышки" появляется "%D0%BA%D1%80%D1%8B%D1%88%D0%BA%D0%B8%20" 
       
      Файл .htaccess выглядит так
       
      RewriteEngine On RewriteCond %{HTTP:HTTPS} !=on [NC] RewriteRule ^(.*)$ https://www.site.ru/$1 [R=301,L] SetEnvIf X-Forwarded-Proto https HTTPS=on RewriteCond %{HTTP_HOST} ^site\.ru$ [NC] RewriteRule ^(.*)$ https://www.site.ru/$1 [R=301,L] RewriteCond %{HTTPS_HOST} ^site\.ru$ [NC] RewriteRule ^(.*)$ https://www.site.ru/$1 [R=301,L]  
      Если убрать строки:
      RewriteCond %{HTTP:HTTPS} !=on [NC] RewriteRule ^(.*)$ https://www.site.ru/$1 [R=301,L] SetEnvIf X-Forwarded-Proto https HTTPS=on  
      То проблема исчезает. Кто-нибудь сталкивался с подобным? Как это исправить?
       
       
    • От Alexodiy
      Всем привет. В общем ситуация... мигрировал магазин с движка 1.5 на 2.1 с помощью модуля A-migration. Все перенеслось хорошо, за исключением картинок и тогда я перенес изображения вручную, загрузил папку data в image. Сначала CMS просто не видела изображений хотя они присутствовали в БД, после чего я переименовал папку data в catalog и картинки появились на сайте в директории image/catalog, но битые (прикрепил скрин). Так же, на страницах слетела кодировка.

      Менял права на папку image - 777 не помогло. К теме прикрепляю файл лога... Ребята, пожалуйста помогите разобраться в чем проблема
      error.txt


    • От Krealit
      Добавляю дополнительный язык для ocStore 2.1, но не знаю где посмотреть параметры для устанавливаемого языка. Интересующие параметры на скриншоте. Может кто знает где можно их посмотреть (справочник или что-то ещё) для корректного их внесения? В нете нашёл только двубуквенный код по ISO 639-1, но не знаю или этот стандарт использует OpenCart.
      P.S. Для устанавливаемого языка пакетов НЕТ, поэтому переписываю англоязычный пакет.

    • От fedott
      Здравствуйте, помогите разобраться с проблемой. 
      В выдаче результата поиска, первая страница нормальная, но если страниц больше, при переходе на следующую в адресной строке тег меняется на кракозябры.
      первая страница выглядит так - /search?search=головка
      вторая должна выглядеть соответственно - /search?search=головка&page=2
      но вместо этого получается  - /search?search=%25D0%25B3%25D0%25BE%25D0%25BB%25D0%25BE%25D0%25B2%25D0%25BA%25D0%25B0&page=2
      Дело в том, что на одном сервере есть два идентичных сайта на разных доменах, у одного нет проблем, у второго есть.
      Пробовал с нормального подставить базу данных и весь архив корневой директории - без результата.
      По сути, сам домен (точнее его расширение) вызывает проблему.
      Один домен - mysite.ru, второй - mysite.tk
      Такое ощущение, что проблемы в зоне .tk
      Оба сайта DNS у Яндекса.
      Уже все прочитал, что нашел и все перепробовал, прогонял bomdel.php, но так и не могу найти в чем причина.
      Может кто то сталкивался с подобной проблемой?
      Сборка: Русская сборка OpenCart - Version 2.3.0.2 (rs.4)
    • От BAliar
      у меня кодировка у меня header ut 8 a footer w 1251 это норм ?
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.