Jump to content
mFrance

При попытке открыть сайт - index.php?route=common/home - всё время перезагружается и белая страница

Recommended Posts

При попытке открыть сайт любой адрес сайта перенаправляется на index.php?route=common/home - всё время перезагружается и на экране белая страница.

 

В логах ошибок PHP нет, кэш включали и выключали, папку storage переименовывали и создавали новую.

 

От чего это происходит и как исправить?

 

Спасибо!

 

(Действия перед этой ошибкой: в Редакторе шаблона файл common/header.twig изменили, но всё вернули обратно.)

Edited by mFrance

Share this post


Link to post
Share on other sites

насколько я понимаю, это как раз не очень корректное обращение к главной странице: 

index.php?route=common/home

как раз нужно, чтобы этого не было...

Share this post


Link to post
Share on other sites

Переименование файла .htaccess ничего не дало.

 

Это странное поведение на сайте: https://maxtkd.ru

 

Ну хоть примерно: с чем это может быть связано? :-)

Edited by mFrance

Share this post


Link to post
Share on other sites

ну как минимум, у вас не правильно установлен сертификат https.

судя по всему, в этом проблема

 

Share this post


Link to post
Share on other sites

Ошибки в журнале ошибок появились, но вроде только Warning 

 

2019-02-11 15:54:39 - PHP Warning:  imagefilledrectangle() expects parameter 1 to be resource, boolean given in /var/www/www-root/data/www/maxtkd.ru/system/library/image.php on line 180
2019-02-11 15:54:39 - PHP Warning:  imagecopyresampled() expects parameter 1 to be resource, boolean given in /var/www/www-root/data/www/maxtkd.ru/system/library/image.php on line 182
2019-02-11 15:54:39 - PHP Warning:  constant(): Couldn't find constant JOURNAL3_VERSION in /var/www/www-root/data/www/maxtkd.ru/system/library/template/Twig/Extension/Core.php on line 1515
2019-02-11 16:23:16 - PHP Warning:  unlink(/var/www/www-root/data/www/storage/cache/cache.catalog.language.1549905796): No such file or directory in /var/www/www-root/data/www/maxtkd.ru/system/library/cache/file.php on line 68
2019-02-11 16:29:35 - PHP Warning:  unlink(/var/www/www-root/data/www/storage/cache/cache.catalog.language.1549906175): No such file or directory in /var/www/www-root/data/www/maxtkd.ru/system/library/cache/file.php on line 68
2019-02-11 16:29:40 - PHP Warning:  unlink(/var/www/www-root/data/www/storage/cache/cache.catalog.language.1549906180): No such file or directory in /var/www/www-root/data/www/maxtkd.ru/system/library/cache/file.php on line 68
 

Share this post


Link to post
Share on other sites
8 минут назад, anboza сказал:

ну как минимум, у вас не правильно установлен сертификат https.

судя по всему, в этом проблема

 

Извините, пожалуйста, уточнение: "у вас" - это в браузере на компьютере? Просто сайт не могут открыть люди из разных городов...

Тогда "у вас" - это, наверно, в админ. панели Opencart? Правильно?

Edited by mFrance

Share this post


Link to post
Share on other sites
4 минуты назад, mFrance сказал:

Тогда "у вас" - это, наверно, в админ. панели Opencart? Правильно?

у вас - это на хостинге, где заливается собственно файлы сертификата + в системе управления сайтом

судя по всему, у вас проблема в настройках самой системы управления, ибо сертификат установлен корректно:

ссыль

Edited by anboza

Share this post


Link to post
Share on other sites

Спасибо большое за ответ! 

Сегодня на многих сайтах проблемы с https - Google Chrome на половину сайтов не заходит, пишет или "Часы спешат" или "Ваше подключение не защищено".

Share this post


Link to post
Share on other sites

я бы начал с контроля .htaccess

проверил бы настройки, необходимые для хостинга.

обычно в FAQ есть раздел. Но лучше всего, найдите исполнителя и пусть он все проверит.

Share this post


Link to post
Share on other sites
1 минуту назад, mFrance сказал:

Сегодня на многих сайтах проблемы с https - Google Chrome на половину сайтов не заходит, пишет или "Часы спешат" или "Ваше подключение не защищено".

не наблюдаю такого, сайтов много на мониторинге. Может что-то географически - локальное.

Всяко бывает ))

Share this post


Link to post
Share on other sites

.htaccess исходный - из установочного архива

Спойлер

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 99M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

 

Edited by mFrance

Share this post


Link to post
Share on other sites

1. такое под спойлер нужно засовывать ;)

2. проверьте требования к настройкам в разделе FAQ провайдера.

там есть параметры, которые нужно учесть

Share this post


Link to post
Share on other sites

В разделе "Настройки - Магазины - Настройки" на вкладке Server отключили галочку "Использовать SSL".

Очистили и отключили кэш.

Не помогло.

Edited by mFrance

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.