Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[Решено] Статус наличия товара в категории.


 Share

Recommended Posts

Добрый день. Помогите вывести статус товара в категории. Варианты, которые находил в сети, не работают на OCStore 2.3.0.2.

Я себе это представляю так:

Если остаток > 5 тогда
 статус = "В наличии"
  Если  остаток < 5 тогда
     статус = "Заканчивается"
        Если остаток = 0 тогда
             статус = "Нет в наличии"
        КонецЕсли
  КонецЕсли 
КонецЕсли

Как это реализовать в контроллере?

Link to comment
Share on other sites

//можно и не в контроллере


<script type="text/javascript">
var a=<?php echo $stock; ?>;
var messages = document.querySelector('#messages');

if (a > 5) {
 messages.textContent += 'В наличии ' ;
 
} elseif (a<= 5){

messages.textContent += 'Заканчивается' ;
  
} elseif (a= 0){

messages.textContent += 'Нет в наличии' ;
  
}

</script>

 

Edited by anboza
  • +1 1
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.