Перейти к содержанию

mario512

Пользователи
  • Публикаций

    149
  • Зарегистрирован

  • Посещение

Репутация

5 Обычный

Информация о mario512

  • Звание
    Продвинутый пользователь

Информация

  • Пол
    Мужчина
  • Город:
    Одесса

Посетители профиля

498 просмотров профиля
  1. Задам вопрос в этой теме, не хочу плодить. Подскажите пожалуйста, как разметить категории на главной, что бы получить снипет как на скрине?
  2. mario512

    Модуль обмена с 1С. Новый.

    Для версии 7.7 могу помоч. Есть рабочий вариант, писал для себя. Работает напрямую с базой данных магазина, на сайте ничего менять не надо.
  3. Скачать/Купить дополнение Обмен 1C v7.7 с Open Cart 2.3.0.2 Мой вариант обмена Open Cart 2.3.0.2 c 1С v7.7 Пришлось решать задачу для связки 1с с Open Cart без изменений самого сайта. Обработка создавалась для доработанной, не типовой конфигурации. Выкладываю как есть, для ознакомления. В процессе работы над ней пришлось решать много задач самостоятельно т.к. информации в сети не много. Используйте как пример. Код без комментариев. Если у вас возникнут вопросы, пишите, постараюсь разъяснить. Описание. В архиве файл конфигурации, который содержит в себе справочники "Дополнительные реквизиты" и "Задачи", обработку "ОбменМагазин". Для работы необходим доступ к SQL базе магазина. Для работы необходим MySQL Connector Никаких изменений в магазин вносить не надо! Что умеет: 1. Обновлять цены и остатки. 2. Вытягивает продажи с магазина и формирует накладные. 3. Выгружает Номенклатуру на сайт. 4. Формировать теги и ЧПУ. 5. Работать с опциями и фильтрами товара. 6. Переводить описание на несколько языков, используя API Яндекс. 7. Выгружать фото товара на сайт, посредством встроенного FTP клиента Windows. 8. Работать с множеством шаблонов описания товара, HTML-тег Title, Мета-тег Description и т.д. Пример работы: Видео По вопросам адаптации под вашу конфигурации пишите в личку. Работа над обработкой продолжается. Если будет актуально, буду обновлять. Добавил mario512 Добавлено 15.05.2018 Категория Обмен данными Системные требования Сайт разработчика https://www.caseroom.in.ua/ Старая цена Метод активации Без активации Ioncube Loader Нет OpenCart 2.3 ocStore 2.3 OpenCart.Pro, ocShop OcShop 2.0.3.х  
  4. Добрый день. Помогите вывести статус товара в категории. Варианты, которые находил в сети, не работают на OCStore 2.3.0.2. Я себе это представляю так: Если остаток > 5 тогда статус = "В наличии" Если остаток < 5 тогда статус = "Заканчивается" Если остаток = 0 тогда статус = "Нет в наличии" КонецЕсли КонецЕсли КонецЕсли Как это реализовать в контроллере?
  5. Интересно, откуда у этой страницы 9000 символов?
  6. @Dotrox Спасибо, уже цифры меняются, но не соответствуют реальному кол-ву символов.
  7. Добрый день. https://sitechecker.pro показывает одинаковое количество контента для разных страниц на сайте. Менял описание товара, не помогает. Сайт Что я делаю не так?
  8. Обновите кеш модификаторов
  9. В footer.tpl вставьте <script> var h1 = document.getElementsByTagName('h1'); if (h1.length == '0') { var inh1 = document.createElement('h1'); inh1.innerHTML = "ВАШ ЗАГОЛОВОК H1"; document.head.appendChild(inh1); } </script>
  10. @Pascha Огромное спасибо, так и сделал. @prived подсказал где искать)))
  11. @prived Спасибо, все работает. Хорошего Вам дня!
  12. Добрый день. При просмотре сайта с мобильного, длинное название товара в хлебных крошка выходит за область просмотра. Пробовал text-overflow и аналогичные решения. Результат отсутствует. Прошу помощи.
×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.