Перейти к содержанию

Рекомендуемые сообщения

Всем привет!

Opencart 1.5.6  установлен на PHP 5.3.29

Хочу обновить на более новую версию.

Сайт даёт ошибки при переключении версии.
Как правильно сменить версию PHP? 5.6 или 7?

Изменено пользователем AlexN

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вам к хостеру, напишите пускай сменит или сами в панели управления сайта попробуйте найти пункт настройка php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

меняете вы правильно. вам надо смотреть что за ошибки и уже реагировать на ошибки.

Что за ошибки то?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Перенёс на локалку

До 5.3 - всё нормально

5.6 - вот что получается

https://c2n.me/3TlrbBh

dbe9d-clip-74kb[1].png

Изменено пользователем AlexN

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

7.1 вообще не зашёл. но то не критично

На хостинге надо ещё сайты размещать, а настройки РНР для всех одни.

Надо 5.6 чтобы работала нормально

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.