Перейти к содержанию

Рекомендуемые сообщения

опенкарт 1.5.6.4

подскажите пожалуйста код и куда прописать его, нужен title и description для производителей.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

vqmod:

<file name="catalog/controller/product/manufacturer.php">
        <operation error="skip">
            <search position="replace"><![CDATA[
                $this->document->setTitle($manufacturer_info['name']);
            ]]></search>
            <add><![CDATA[
                $this->document->setTitle("");
                $this->document->setDescription("");
                $this->document->setKeywords("");
            ]]></add>
        </operation>
</file>

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

500 ошибку выдает и админка и сам сайт

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, axor сказал:

500 ошибку выдает и админка и сам сайт

я вам кусок vqmod дал. сделайте полноценный или внесите правки в оригинальный catalog/controller/product/manufacturer.php

 

Вот так:

<?xml version="1.0" encoding="UTF-8"?>
<modification>
    <id>Seo Bond Modification</id>
    <version>1.0</version>
    <vqmver>2.6.0</vqmver>
    <author>ibond</author>
	
	<file name="catalog/controller/product/manufacturer.php">
		<operation error="skip">
      		<search position="replace"><![CDATA[
				$this->document->setTitle($manufacturer_info['name']);
			]]></search>
			<add><![CDATA[
				$this->document->setTitle("Титул");
				$this->document->setDescription("Описание");
				$this->document->setKeywords("Слово, слово, слово");
			]]></add>
    	</operation>
  	</file>
  
</modification>

 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, ibond сказал:

<vqmver>2.6.0</vqmver>

в целях совместимости со старыми версиями vqmod лучше указывать

<vqmver>2.1.5</vqmver>

 

иначе при версиях ниже указанной работать не будет ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

для заполнения мета-тегов и описания производителей есть такой модуль

 

(только для оригинального opencart, в ocStore/OCSHOP такое уже есть "из коробки")

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 часа назад, AlexDW сказал:

иначе при версиях ниже указанной работать не будет ;)

Здесь уже копи-паст и голова.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.