Перейти к содержанию
Lifeamove

Ошибка - отзывы (не переключает страницу)

Рекомендуемые сообщения

Версия ocStore 2.3.0.2.1

Шаблон - default

 

В карточке товара в закладке отзывы - если отзывов много, они не помещаются в страницу и появляется 2 > >l

При нажатии на "2" или ">" или ">l" , страница становится прозрачной потом опять появляется но переход на 2ую не совершается.

После нажатия... в браузере появляется ярлык:

5bdd5ac03d3b369708f35d0a2a0e00e8-prev.jp

В файлах нечего не трогал...

 

Это может быть из за отсутствие popup.js?

Вот ссылка на обсуждение темы popup.js

Изменено пользователем Lifeamove

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Плюс при нажатии на переключение страницы на №2 выдает ошибки в Ctrl+Shift+I :

 

Failed to load resource: the server responded with a status of 404 (Not Found)   popup.js
pro-9-128gb-wifi-gold:867 100
jquery-2.1.1.min.js:4 Mixed Content: The page at 'https://site.ru/apple-ipad/pro-9-128gb-wifi-gold' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://site.ru/index.php?route=product/product/review&product_id=182&page=2'. This request has been blocked; the content must be served over HTTPS.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нет, с popup.js это никак не связано, проблема в том, что у вас в ссылке на отзывы http, а сайт на https - поэтому браузер блокирует загрузку.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@Dotrox

3 минуты назад, Dotrox сказал:

Нет, с popup.js это никак не связано, проблема в том, что у вас в ссылке на отзывы http, а сайт на https - поэтому браузер блокирует загрузку.

 

А как его направить на https:// ...?

 

Это как то связано с файлом site/config.php  ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

У вас стандартная ситуация в ОК при переходе на https. Если вы откроете исходный код страницы сайта в браузере, то увидите, что у вас большинство ссылок с http.

 

Вот объяснение причин и решение:

 

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@Dotrox

6 минут назад, Dotrox сказал:

 

У вас стандартная ситуация в ОК при переходе на https. Если вы откроете исходный код страницы сайта в браузере, то увидите, что у вас большинство ссылок с http.

 

 

Ага вижу. Сейчас буду разбираться. Спасибо)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема решена, если кому понадобится:

 

В файле /system/library/url.php есть строка:

   public function link($route, $args = '', $secure = false) {

 

Нужно поменять false на true что бы получилось вот так:

   public function link($route, $args = '', $secure = true) {

Изменено пользователем Lifeamove

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.