Перейти к содержанию
Coba2

Opencart 1.5.6 обновление jquery

Рекомендуемые сообщения

Доброго дня.

Решил обновить jquery c 1.71. на 1.9.1. скачал файл и подложил в директорию javascript от сюда https://code.jquery.com/jquery-1.9.1.min.js

в файлах видел что идёт подключение щё оного файлов,

 
        $helper->addScript( 'catalog/view/javascript/jquery/jquery-1.9.1.min.js' );
 
        $helper->addScript( 'catalog/view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js' );
        $helper->addScript( 'catalog/view/javascript/jquery/ui/external/jquery.cookie.js' );
 
их тоже нужно обновить?
 
В любом случае я пошёл дальше и попался на такую ошибку
Не удалось получить свойство "msie" ссылки, значение которой не определено или является NULL
 
код
// IE6 & IE7 Fixes
if ($.browser.msie) {
if ($.browser.version <= 6) {
 
что я делаю не так?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Доброго дня.

Решил обновить jquery c 1.71. на 1.9.1. скачал файл и подложил в директорию javascript от сюда https://code.jquery.com/jquery-1.9.1.min.js

в файлах видел что идёт подключение щё оного файлов,

 
        $helper->addScript( 'catalog/view/javascript/jquery/jquery-1.9.1.min.js' );
 
        $helper->addScript( 'catalog/view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js' );
        $helper->addScript( 'catalog/view/javascript/jquery/ui/external/jquery.cookie.js' );
 
их тоже нужно обновить?
 
В любом случае я пошёл дальше и попался на такую ошибку
Не удалось получить свойство "msie" ссылки, значение которой не определено или является NULL
 
код
// IE6 & IE7 Fixes
if ($.browser.msie) {
if ($.browser.version <= 6) {
 
что я делаю не так?

 

Любые подключенные ранние библиотеки должны быть так же обновлены 

 

http://stackoverflow.com/questions/14892095/browser-msie-error-after-update-to-jquery-1-9-1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Решил обновить jquery c 1.71. на 1.9.1. скачал файл и подложил в директорию javascript от сюда https://code.jquery....ry-1.9.1.min.js

 


что я делаю не так?

 

Довольно геморройное это занятие. И, похоже, что у вас крайне мало знаний в jquery.

 

Цель то хоть какая? Ради чего все это?

 

Ведь это все скрипты движка нужно переделывать, а не только новые библиотеки ставить.

Очень много в скриптах используется live, а это новые версии не поддерживают.

 

рекомендую вам бросить это занятие или объясните цель его, возможно, что подскажу другое решение.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все эти подключаемые файлы "Migrate"  проходили.

 

На версии opencart 1.5.5.1 возникают проблемы.  Если в FireFox, например, было гладко, то в Хроме были обнаружены местами серьезные проблемы.

Migrate - это по сути костыль, который не гарантирует 100% нормальную работу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@sitecreator, есть 2 версии

- костыль для того чтоб работало

- для вывода в консоль несовместимости версий для отладки

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Требует уточнения, но мне кажется что $.browser тоже похерили в новой версии.
 
P.S.: Уточнил:

jQuery.browser

deprecated: 1.3, removed: 1.9

Изменено пользователем mpn2005

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Любые подключенные ранние библиотеки должны быть так же обновлены 

 

http://stackoverflow.com/questions/14892095/browser-msie-error-after-update-to-jquery-1-9-1

по это ссылке не понял что нужно делать. понял что только deprecated: 1.3, removed: 1.9

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Довольно геморройное это занятие. И, похоже, что у вас крайне мало знаний в jquery.

 

Цель то хоть какая? Ради чего все это?

 

Ведь это все скрипты движка нужно переделывать, а не только новые библиотеки ставить.

Очень много в скриптах используется live, а это новые версии не поддерживают.

 

рекомендую вам бросить это занятие или объясните цель его, возможно, что подскажу другое решение.

 

использую ocfilter он требует jquery 1.9.1 для нормальной работы. Вцелом он работает но есть бага, в виде отобрадений нескольких кнопок при мультивыборе фильтра. Автор пояснил что нуждно обновить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

код // IE6 & IE7 Fixes if ($.browser.msie) { if ($.browser.version <= 6) { что я делаю не так?

 

уберите поддержку зомби-браузеров образца 2001 года. 

 

использую ocfilter он требует jquery 1.9.1 для нормальной работы.

 

 

если не желаете иметь много геморроя, то и подключите jquery 1.9.1  только для этого модуля.  А все остальное будет работать со старой версией.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

если не желаете иметь много геморроя, то и подключите jquery 1.9.1  только для этого модуля.  А все остальное будет работать со старой версией.

 

Ну это тоже не идеальный варианта

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну это тоже не идеальный варианта

 

идеального ничего нет в мире.

есть понятие целесообразности.

 

иногда целесообразнее отказаться от одного модуля в пользу другого чем пытаться всеми мыслимыми способами подружить его с магазином. Особенно если нет ни опыта, ни денег для организации такой дружбы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

sitecreator, ну иди переписать фильтр

 

не, переписывать не пойду! :ugeek:

 

Мне непонятно откуда требование про 1.9 версию взялось? Как то сомнительно это. Думаю, что ТС в чем-то не разобрался.

 

7a5ea64d61.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

не, переписывать не пойду! :ugeek:

 

Мне непонятно откуда требование про 1.9 версию взялось? Как то сомнительно это. Думаю, что ТС в чем-то не разобрался.

 

7a5ea64d61.jpg

 

Требует. Для некоторых элементов UI был собран BS, (popover, tooltip, collapse..), который жить не может без >= 1.9.1.

В будущем, конечно, пересмотрю это требование и использование BS. Не знал, что все с 1.5 сидят на Jq 1.7

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Думаю, что либо топикстартеру стоить заплатить денежку исполнителю, и все будет сделано грамотно.

Либо, может быть, разработчик модуля сделает, например, vqmod к своему модулю, который решит данный вопрос.

 

При наличии у себя свободного времени, а у заказчика некоторого вознаграждения, могу посмотреть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как же я не люблю эту UI  :ph34r:

Предпочитаю собирать плагины отдельно, так получается гибче 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Как же я не люблю эту UI  :ph34r:

Предпочитаю собирать плагины отдельно, так получается гибче 

 

Лучше когда на сайте 150 разных стилей/эффектов/повторных использований/подключений и т.д.? Да вы что..

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кто может подсказать что нужно делать примерно по шагам, я пока непойму как этот миграшион плагин надо запустить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

я пока непойму как этот миграшион плагин надо запустить

 

в документации все тщательно описано, и даже с примерами.

 

Кто может подсказать что нужно делать примерно по шагам

 

абсолютно все есть в документации. Переведите с английского гуглом если не владеете языком. такого перевода достаточно.

 

Перевожу за вас Гуглом.

Что то еще осталось непонятное?

 

In your web page, load this plugin after the script for jQuery:

 

В вашей веб-странице, загрузить этот плагин после того, как сценарий для JQuery:

 

 

собственно пример (код) из документации:

 

<script src="http://code.jquery.com/jquery-1.11.3.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.4.1.js"></script>

Всего две строки кода.  Раньше была 1.7.* , а теперь стала 1.11.3.  Не нравится 1.11.3? Ну так подключите 1.9 если есть желание.

Знаете ведь куда скопировать эти строки?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Лучше когда на сайте 150 разных стилей/эффектов/повторных использований/подключений и т.д.? Да вы что..

UI такой же костыль, да и 150 стилей аффектов как таковых грузить и не нужно 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

в документации все тщательно описано, и даже с примерами.

абсолютно все есть в документации. Переведите с английского гуглом если не владеете языком. такого перевода достаточно.

Перевожу за вас Гуглом.

Что то еще осталось непонятное?

собственно пример (код) из документации:

<script src="http://code.jquery.com/jquery-1.11.3.js"></script><script src="http://code.jquery.com/jquery-migrate-1.4.1.js"></script> 
Всего две строки кода. Раньше была 1.7.* , а теперь стала 1.11.3. Не нравится 1.11.3? Ну так подключите 1.9 если есть желание.

Знаете ведь куда скопировать эти строки?

В этом гайде нет точного описания что делать.

А эти две строчки прописал, в консоли пишет

JQMIGRATE: Migrate is installed, version 1.4.1

тыкаю по страницам ничего нового не пишет, и что дальше делать?

Вот если подкидываю файлик с новой версией jquery так сразу ошибки и т.д

Изменено пользователем Coba2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.