Vadim1

[Решено] OpenCart 2.2.0.0 - ошибка, изображения не грузятся

Рекомендуемые сообщения

Vadim1    0

Привет Ребята! Обновил с версии 2.1 до версии OpenCart 2.2.0.0

 

Потом смотрю сайт, а там изображения не грузятся, а сверху страницы пишет такие ошибки:

Warning: imagecreatetruecolor(): Invalid image dimensions in /shop/system/library/image.php on line 105
Warning: imagecolorallocate() expects parameter 1 to be resource, boolean given in /shop/system/library/image.php on line 113
Warning: imagefilledrectangle() expects parameter 1 to be resource, boolean given in /shop/system/library/image.php on line 116
Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in /shop/system/library/image.php on line118

Нашел подобную тему, но она закрыта поэтому создал тут новую

https://opencartforum.com/topic/18710-resheno-oshibka-izobrazheniia-ne-gruziatsia/

В той теме пишут нужно права на запись дать, только в версии OpenCart 2.2.0.0 нет той папки, поэтому вот и спрашиваю.
В чем проблема, какой папке права на запись дать, и какие конкретно права нужны 777 или 775 или еще какие?

Изменено пользователем Vadim1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Vadim1    0

Посмотрел папку /shop/image/cache/catalog/demo

и решил посмотреть есть ли картинки на которые он жалуется, походу этих картинок там нет

 

Например жалуется этой картинки нет /image/cache/catalog/demo/sony_vaio_1-228x.jpg 404 (Not Found)

В папке на хостинге да этой картинки нет, есть только такая sony_vaio_1-40x40.jpg

 

Ошибки отображаются в магазине на странице там где товары плиткой, и слева сбоку сайдбар с категориями. На странице просмотра товара ошибок нет, и картинки отображаются.

Изменено пользователем Vadim1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Vadim1    0

Решил проблему!

Нашел подобную проблему
http://forum.opencart.com/viewtopic.php?t=159122&p=607893

 

Там написано что это связано с темой. Но я в админке когда хотел посмотреть настройки темы мне написало доступ закрыт.
 подумал странно, погуглил. Нашел что нужно зайти Настройки/Группы юзеров/Администраторы

и там почему то были сняты галочки возле пунктов с темой, вообщем выбрал все галочки везде, нажал сохранить.

 

Потом пошел, в настройки темы, там настроек мало, я ничего не понял, и ничего не трогал, только нажал сохранить.

Проверил сайт, о чудо картинки отображаются, все супер.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу