Jump to content
Sign in to follow this  
vagan28

[Решено] Не переносится с openservera на nic.ru

Recommended Posts

Доброго времени суток!

 

Ситуация в следующем переношу сайт с локального сервера на хостинг и тут загвоздка, пишет:

 

Внимание : require_once (/home/хост/сайт/system/startup.php) [ function.require однократной ]: не удалось не удалось открыть поток: Нет такого файла или каталога в/home/хост/сайт/docs/index .php на линии 17 

Фатальная ошибка : require_once () [ function.require ]: не удалось открытия необходимого '/home/хост/сайт/system/startup.php' (include_path = '.: / Главная /хост / сайт / PHP ") в /home/хост/сайт/docs/index.php на линии 17

 

Прописал все пути, вроде правильно и один фиг такая загвоздка....

 

Подскажите плиз, уже второй день голову ломаю что не так. Ответов не нашел((((

Share this post


Link to post
Share on other sites
Прописал все пути, вроде правильно

 

Должно быть не ВРОДЕ, а правильно.Потому как при варианте "вроде" именно так и будет сыпать ошибками.

Share this post


Link to post
Share on other sites

Как правильно прописать пути, чтобы не создавалось такой проблемы?

Share this post


Link to post
Share on other sites

Как вариант удалить всё содержимое базы данных.Вернуть в магазин папку Install своей версии,вычистить оба конфига.Поставить как бы с нуля магазин.Если процесс установки прошёл удачно и нет ошибок.Опять зайти в базу,удалить только что созданные таблицы и импортировать базу с локалки.....

Share this post


Link to post
Share on other sites

Все срослось, спасибо огроменное.....)

Действительно, дело было в неправильных путях....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By valeron1978
      Столкнулся сегодня с проблемой. Делал сайт на локальном сервере (Openserver). Перестал открываться сайт. В панель управления захожу без проблем. В панели управления работает все хорошо. При попытки захода на сам сайт сообщение
      Не удается получить доступ к сайту
      Соединение сброшено.
      Попробуйте сделать следующее:
      Проверьте подключение к Интернету. Проверьте настройки прокси-сервера и брандмауэра. Выполните диагностику сети в Windows ERR_CONNECTION_RESET   Остальные сайты на этом же сервере открываются без проблем.
      Ничего в настройках не менялось.
      Антивирус отключал
      Кэш очищал
      Подскажите пожалуйста Куда смотреть
       
       
       
       
       
    • By Zubonick
      Насколько мне известно для того что бы xdebug работал с twig нужно указать путь к папке с кешом.Я пробывал 2 варианта C: \ OSPanel \ domains \ oc.test \ storage \ cache и C: \ OSPanel \ domains \ oc.test \ upload \ system \ storage \ cache но они оба не работают. Что я делаю не так?
    • By Marsimus
      Здравствуйте. Темы такой не нашел. Не разбираюсь в подобных вопросах вовсе, разработчик пропал. 
      Буду очень благодарен, если кто объяснит, куда смотреть и что сделать в след. вопросе: 
      Opencart 2.1.0.2.1 , приблизительно около 20 секунд сохраняется товарная позиция. На хостинге написали, что проблема кроется здесь, но мне сие ни о чем не говорит:
      | 484 | admin_gg2 | localhost | admin_gg2 | Sleep   | 40   |          |                                                                                                                                                                                                              | 0.000    |
      | 485 | admin_gg2 | localhost | admin_gg2 | Query   | 0    | updating | UPDATE oc_product_option_value SET  price = ROUND((base_price+(base_price/100*0.0000))*1, 4), cost = ROUND(base_price*1, 4)
                                          WHERE base_price > 0 AND product_id = '5016' | 0.000    |
    • By Vladkh
      Была рабочая версия сайта на локале, ошибок не было, но решил попробовать новый шаблон и не увидел, что он для другой версии опенкарт. После чего решил заново сделать локальную версию. Поставил чистый опенкарт, удалил все кроме двух файлов конфиг, скопировал все файлы сайта по фтп, создал и импортировал БД, поменял все пути в файлах конфиг. Все как бы работает, но не полностью. В админке часть кнопок не активна и не отображаеться, а на самом сайте поплыли стили и не работают  некоторые функции. Что самое интересное, так это то что в режиме инкогнито браузера, стили стоят на месте, но к примеру все слайдера не работают, меню не выпадает. Помогите пожалуйста, я в этом деле новый, немного не разбираюсь


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.