Jump to content
Sign in to follow this  
freelancer

[Решено] странная кодировка в шаблоне от павликов

Recommended Posts

шаблон pav_decor. кто-нибудь сталкивался?

GNNo84S.png

 

проблема проявляется только в фильтре и только с этим шаблоном

Share this post


Link to post
Share on other sites

что делать с творением вьетнамских гениев?

Share this post


Link to post
Share on other sites

а если в браузере указать другую кодировку?

Share this post


Link to post
Share on other sites

что делать с творением вьетнамских гениев?

 

Есть desktop прога для смены кодировки файлов, называется UTFCast. Можно ей попробовать поискать файл с неправильной кодировкой.

Share this post


Link to post
Share on other sites

файл фильтра fiterpro_product.tpl в кодировке utf-8 100%, проблема в том что в какой-то момент кодировка переменной $product['name'] перестает быть utf8 )

Share this post


Link to post
Share on other sites

mb_convert_encoding используется?

 

еще обратил внимание на пустую строку перед <!DOCTYPE html> - но это к кодировке вроде не относится, скорей приведет к пустой строке в браузере IE

Share this post


Link to post
Share on other sites

mb_convert_encoding нет. на проблемах с кодировками я сам не одну собаку съел, но тут что-то новое

задача специфичная, тут простые советы не подойдут. вопрос к тем кто сталкивался

Share this post


Link to post
Share on other sites

может, проблема связана не с именем, а с кратким описанием (точней, его выводом)?

 

в свое время пошел неправильным путем, с использованием mb_convert_encoding в связке с htmlspecialchars_decode

что приводило к аналогичным проблемам в случае отличий кодировки сайта и сервера

post-688391-0-72821000-1444638993_thumb.png

Share this post


Link to post
Share on other sites

mb_substr - проверь, может где фигурирует, заменить на utf8_substr.

Share this post


Link to post
Share on other sites

меня спас

$text = mb_convert_encoding($text, 'UTF-8', 'UTF-8');

Share this post


Link to post
Share on other sites

Какая дефолтная кодировка базы, таблицы, и даже полей.

наличие bom по пути, или пустой строки...

Share this post


Link to post
Share on other sites

кто знаком с этим шаблоном, тот знает, что у них там конфиг подключается в .tpl, возможно туда и затесался BOM.

в общем проблема решена. спасибо

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.