Перейти к содержанию
Lena82

[Решено] Версия php и некоторые модули

Рекомендуемые сообщения

Здравствуйте, могут ли быть сбои в модулях Опенкарт из-за смены версии php, у нас сайт на 5.3 работал прекрасно, как мы сменили вервию до последней 5.6 полетели модули связанных опций, аякс обновление цены в опциях при выборе и все что с ними связано в корзине и заказах.

 

Есть ли какая то связь, нам нужна новая версия для одного скрипта, но тогда вот такое происходит...

 

На локалке со старой версией все работает.

 

Подскажите)))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, могут. Чаще всего из-за функции split

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у толкового хостера всегда есть возможность выбрать используемую версию php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у толкового хостера всегда есть возможность выбрать используемую версию php

Речь не об этом. Им пришлось поднять версию php из-за модуля, который этого требовал.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

чего тогда менять обратно и просить переписывать под нужную версию?

 

да в некоторых файлах нашла split, хм хотя не понятно почему так, а как на локалке в Опенсервер настроить так что бы проверить?

 

я ставлю php 5.6 он ругается что нельзя...у нас апач-2.2.15, php 5.6.8. там такие не выставить ни как

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

проблема была в short_open_tag, в файле php.ini включили on и проблема ушла)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

проблема была в short_open_tag, в файле php.ini включили on и проблема ушла)

скакалкой по рукам разработчикам таких модулей.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

нет.

когда вокруг все написано с полными открывающими тэгами - писать ИНАЧЕ абсурд.

php поддерживает еще и такой синтаксис:

<%
так что - спускать таким "разработчикам" это с рук и винить хостера, у которого нормально обрабатывается

<?php
?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.