Перейти к содержанию
Lena82

[Решено] ошибки при переносе сайта на денвер (.htaccess)

Рекомендуемые сообщения

перенесла сайт на денвер с хостинга, хочу кое что проверить и переделать не поломав основной сайт, хотя все делают наоборот)))) ;)

 

так вот ошибка вылезла не пойму как ее поправить, помогите пожалуйста

 

 

скрин

 

http://www.picshare.ru/view/6113517/

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нужно настройки денвера подправить

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нужно настройки денвера подправить

подскажите какие, я и так там много сама сделала, а это что-то не пойму) опять пол интернета перерыть не хочется как то)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В config,php пропишите/исправьте 
// HTTP
define('HTTP_SERVER', 'http://some_local_url/');


// HTTPS
define('HTTPS_SERVER', 'http://some_local_url/');
В файл (если Windows XP) C:\WINDOWS\system32\drivers\etc\hosts добавьте 
 
127.0.0.1 some_local_url

Если some_local_url выглядит как mysite.ru, пропишите (на всякий случай)

127.0.0.1 mysite.ru 
и 
127.0.0.1 www.mysite.ru 
Изменено пользователем igon

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Меня в свое время достало с Денвером копаться каждый раз  :ugeek:

давно уже использую openserver ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

 

В config,php пропишите/исправьте 

было уже сделано и после ошибка та же.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если сайт на Денвере назван так же, как и в сети, то очистите кэш браузера и удалите куки своего сайта.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Если сайт на Денвере назван так же, как и в сети, то очистите кэш браузера и удалите куки своего сайта.

нет название немного изменила, что бы не путаться)

 

браузер почистила не помогает, а как я поняла там еще на кэш vqmod ругается и как почистить кэш самого сайта, думаю да в этом проблема?

нашла все и почистила без толку((

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

было уже сделано и после ошибка та же.

 

А файл hosts тоже поправили?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

да, я поняла что там в путях проблема в конфигах, какие туда верные прописать?

 

 

define('DIR_APPLICATION', 'Z:\home\test.com\www\catalog/');

у меня так

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

да, я поняла что там в путях проблема в конфигах, какие туда верные прописать?

 

у меня так

Читайте внимательнее.

1. О параметре DIR_APPLICATION в файле config.php речь пока вообще не идет.

2. Сейчас речь идет о параметре HTTPS_SERVER в этом же файле.

 

3. Файл hosts никакого отношения к конфигам ИМ не имеет. Это файл операционной системы, но, если его не подправить, денвер работать не будет.

Коль скоро вы обозвали свой сайт test.com, замените mysite.ru на test.com (см. мой пост выше).

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Читайте внимательнее.

1. О параметре DIR_APPLICATION в файле config.php речь пока вообще не идет.

2. Сейчас речь идет о параметре HTTPS_SERVER в этом же файле.

 

3. Файл hosts никакого отношения к конфигам ИМ не имеет. Это файл операционной системы, но, если его не подправить, денвер работать не будет.

Коль скоро вы обозвали свой сайт test.com, замените mysite.ru на test.com (см. мой пост выше).

он это туда пишет при запуске, проверила

// HTTPS
define('HTTPS_SERVER', 'http://www.test.com/');

вот это сейчас стоит в конфиге. Ладно, сама разберусь)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

вот это сейчас стоит в конфиге.

конфиге или таки конфигах?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

конфиге или таки конфигах?

в обоих, я поставлю чистый опенкарт, и посмотрю что он туда пишет и как)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Долой Денвера!!

По делу ничего не скажу, хотя уже сказал. =)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Здравствуйте еще раз!

 

Денвер снесла, поставила OpenServer)

 

С этими ошибками в конфигах разобралась, но...теперь почему то не доступны все категории и товары которые были дефолтовые, а те что новые добавляла доступны! Т.ею на все что пришло с дефолта пишет страница не существует. Заказы тоже не доступны в админке(

 

Что я делала:
1. Поставила Опенкарт с нуля

2. Перезаписала все папки на новые с бекапа

3. Перезаписала базу данных с бекапа.

 

Где косяк?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3. Перезаписала базу данных с бекапа.

 

у меня складывается впечатление, что про создание дампа БД и его восстановление вы забыли ;)

здесь смотрите

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

у меня складывается впечатление, что про создание дампа БД и его восстановление вы забыли ;)

здесь смотрите

сделала, админка поправилась) а вот со стороны пользователя, так и остались недоступны категории, товары, статьи. Пишет нет такого url.

 

ааа! Люди добрые!) Помогите)

 

Возможно ли, это из - за того что домены по другому назвала?

 

конфиги верные, seo url включен... не понимаю почему так...

 

О! Зато доступны товары у которых не прописан seo url!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

seo-url отключите, для проверки - если все нормально станет, смотрите, что у вас с именами - seo-url должны быть уникальны

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

seo-url отключите, для проверки - если все нормально станет, смотрите, что у вас с именами - seo-url должны быть уникальны

отключила работает на ура! но имена все уникальные.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

файл .htaccess в корне сайта не забыли переименовать случаем? чтоб именно .htaccess был, без расширения txt - маловероятно, но все же.

и в нем самом гляньте секции для seo-url (сравните например с чистым из дистрибутива)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все! Можете закрывать тему! УРА! все работает) я не переименовала файл htaccess, вот болда, из-за такой глупости, сколько мучилась) спасибо всем)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×