Jump to content
Sign in to follow this  
lando

В карточке товара не отображаются связанные товары

Recommended Posts

Почему-то в карточке товара не отображаются связанные товары:

 

во вкладке Связи выбираю "Рекомендуемые:" добавляю туда похожие или зависимые товары. На сайте при просмотре этого товара они не отображаются.

 

Подозреваю, это где-то в настройках нужно какую-то галочку поставить? Может кто-нибудь подсказать?

Share this post


Link to post
Share on other sites

движок? версия? тема оформления? ошибки в логах?

Share this post


Link to post
Share on other sites

opencart Version 1.5.4.1

 

Тема и ошибки не знаю: http://kip.su

 

Скажите, где посмотреть

Share this post


Link to post
Share on other sites

админка - система - журнал ошибок.

похоже, у вас просто вырезан этот функционал в используемой теме оформления.

прицепите файл catalog/view/theme/ВАША_ТЕМА/template/product/product.tpl

Share this post


Link to post
Share on other sites

если пакуете - делайте ZIP.

и тут загрузите, и люди открыть смогут (у меня, например, НЕТ ничего для работы с rar-архивами).

tpl можно выложить на http://pastebin.com/

лог ошибок - тут в CODE (если больше 20ти строк - еще и в SPOILER).

Share this post


Link to post
Share on other sites

очистите журнал -> попробуйте добавить "связанные товары" -> посмотрите журнал.

Share this post


Link to post
Share on other sites

т.е. в админке в товаре они сохранились, как положено (при обновлении формы товара они на месте)?

откройте теперь товар в каталоге и также посмотрите журнал.

и можете теперь прицепить еще и "catalog/controller/product/product.php"

Share this post


Link to post
Share on other sites

В админке сохранились, на сайте пробовала открывать тоже. Спустя какое-то время в журнале появилось:

 

2015-03-06 9:41:08 - PHP Notice:  Undefined variable: button_continue in /var/www/user444608/data/www/kip.su/catalog/view/theme/default/template/error/not_found.tpl on line 11

2015-03-06 9:41:51 - PHP Notice:  Undefined variable: button_continue in /var/www/user444608/data/www/kip.su/catalog/view/theme/default/template/error/not_found.tpl on line 11

product.zip

Share this post


Link to post
Share on other sites

визуально все в порядке.

"Undefined variable: button_continue" нам сейчас не интересно.

если используете vqmod

1) выкиньте все модули из папки xml и проверьте.

2) если рекомендуемые вернутся - возвращайте vqmod-модули по одному в папку xml - так найдете виновника.

если НЕ используете vqmod

- надо подумать, куда можно добавить отладочные выхлопы, написать вам куда и что;

- или непосредственно "щупать" магазин.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.