Перейти к содержанию
Kubinec

[Решено] Сайт перенесся на хостинг в искаженном варианте

Рекомендуемые сообщения

Добрый день всем, переносил сайт на хостинг, вс перенеслось нормально кроме страницы Категория и Продукт, на странице продукт пропало вобще все, пишет продукт не найдет, хотя на локальном все было в порядке. С чем может быть связана подобного рода проблемма? И вообще почему сайт может перенестиль в искаженном варианте на хостинг, возможно есть правильная последовательность действий при переносе, например: отключить все модули и после этого делать експорт базы данных.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

"как переносить магазин с локального компа на хостинг?" - масса тем/сообщений.

>> на странице продукт пропало вобще все, пишет продукт не найдет, хотя на локальном все было в порядке.

только если не перенесли базу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

"как переносить магазин с локального компа на хостинг?" - масса тем/сообщений.

>> на странице продукт пропало вобще все, пишет продукт не найдет, хотя на локальном все было в порядке.

только если не перенесли базу.

 

Вся масса тем - мусор, все темы копированы одна с другой, ее пишут даже те кто не переносил никогда ничего. Правила переноса я знаю, с роду скопировать с 1 папки в другую. Вопрос был почему сайт переносится не соблюдая пропорции которые были на локальном, изменяются размеры и страницы отображаются не корректно.

 

Про базу данных спасибо, возможно не так что то скопировалось, попробую отпишу, но думаю проблема не в этом, а все в тех же размерах, которые разлетелись по всему екрану на хостинге, в то время как на локальном все в норме

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

но думаю проблема не в этом, а все в тех же размерах, которые разлетелись по всему екрану на хостинге, в то время как на локальном все в норме

может потому, что хостинг шире, а ваш локальный сервер ýже ... :ugeek:

 

А вообще бред какой-то.

Давайте ссылку на сайт и посмотрим.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Покажите раздел // DIR в config.php

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Покажите раздел // DIR в config.php

 

// DIR

define('DIR_APPLICATION', '/home/логин/домен/www/catalog/');

define('DIR_SYSTEM', '/home/логин/домен/www/system/');

define('DIR_DATABASE', '/home/логин/домен/www/system/database/');

define('DIR_LANGUAGE', '/home/логин/домен/www/catalog/language/');

define('DIR_TEMPLATE', '/home/логин/домен/www/catalog/view/theme/');

define('DIR_CONFIG', '/home/логин/домен/www/system/config/');

define('DIR_IMAGE', '/home/логин/домен/www/image/');

define('DIR_CACHE', '/home/логин/домен/www/system/cache/');

define('DIR_DOWNLOAD', '/home/логин/домен/www/download/');

define('DIR_LOGS', '/home/логин/домен/www/system/logs/');

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

может потому, что хостинг шире, а ваш локальный сервер ýже ... :ugeek:

 

А вообще бред какой-то.

Давайте ссылку на сайт и посмотрим.

 

http://560508.butsik.web.hosting-test.net/ вот ссылка 2 дня еще будет работать пока настрою, если настрою, я тоже думаю что бред какойто. Ну если сравнить на локальном то даже размеры на некоторые div разные, на локалке в екран все влезло в этот div, на хосте располоение по другому, одно на одно залезло, возможно я что то не правильно перенес по таблицам, может нужно было перед переносом какойто модуль отрубить, например Категория. Раздел с одеждой работает на сайте только 1 - Платья, если можно назвать что он работает. Должно выглядеть так:

1. Стр. категория lhpOQB8ncyw.jpg

 

2. Стр. с товаром 4z6qwMiYJFw.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так на фото у вас 3 товара в категории Платья, а на сервере я вижу 1.

Удалите на локалке 2 товара из категории и посмотрите, как у вас поплывёт вёрстка)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так на фото у вас 3 товара в категории Платья, а на сервере я вижу 1.

Удалите на локалке 2 товара из категории и посмотрите, как у вас поплывёт вёрстка)

 

В том то и дело что должно было быть 3 на хосте тоже, перенес все так как на локальном

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Вся масса тем - мусор, все темы копированы одна с другой, ее пишут даже те кто не переносил никогда ничего.

 

а так?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Спасибо, так не пробовал еще, попробую сегодня и отпишу :wink:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Заработало, но к сожалению не плностью, появилась страница с товаром, а вот страница Категория осталась такой же, я предполагаю что что то там наделал не так, попробую восстановить с старых файлов и поглядим что выйдет. Спасибо за подсказку с установкой... :oops:

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

Подскажите подалуйста еще, думаю вы с таким сталкивались, в общем переделал я страницу Категория, но почемуто ее в таком виде (нормальном) отображает только в Firefox в браузере Chrome хоть чисть кеш хоть не чисть она кривая http://560508.butsik.web.hosting-test.net/index.php?route=product/category&path=20_59 Подскажите что не так? Не понимаю немного, буду очень благодарен... Кстати, убрал выбор товаров Сеткой, и Списком, поставил по усолчению сеткой таким образом:

 

Вместо этого:

if (view) { display(view); } else { display('list'); }

 

Прописал это:

if (view) { display(view); } else { display('grid'); }

 

У меня в 2х браузерах показывает норм, потому что я выбрал сетку сем (после того как вернул опять менюшку для выбора), на третем же браузере все без изменений, как было списком так и осталось, на других компах смотрел тоже самое, чистил кеш, ничего не выходит. Пока не нажмешь сеткой вручную то на екране отображается все списком, даже если установить по умолчению display('grid'); не понимаю почему так...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В общем решил проблему, в файле categiry.tpl поменял все надписи list на grid... Может кому то будет полезно... Всем спасибо за помощ, все получилось :-)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.