Перейти к содержанию
DrinkPozitive

Проблемы с переносом сайта

Рекомендуемые сообщения

Добрый день Уважаемые форумчане!!!

 

Переносил магазин на другой домен, у того же хостера, слил файлы на новый домен, поправил два конфиг файла, кэш почистил везде, админка запускается с ошибками вида

 

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/name/public_html/system/database/mysql.php on line 14

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/name/public_html/system/database/mysql.php on line 15

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/name/public_html/system/database/mysql.php on line 16

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home//public_html/ system/database/mysql.php on line 17

 

Дамп БД старой подсовываю импортом таблиц выдает ошибку

 

SQL-запрос:

TRUNCATE TABLE `oc_address` ;
 

Ответ MySQL: dot.gif

#1146 - Table 'name_store.oc_address' doesn't exist

 

не понимаю, что ему не нравится. Понимаю что БД не хватает, но вот почему.....

 

Помогите разобраться, или хотя бы подскажите в какую сторону копать

 

ocstore 1.5.5.1.1

 

Заранее спасибо!!!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Дамп БД старой подсовываю импортом таблиц выдает ошибку

если  подсовывается старая база в новую,то именно так и будет.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Так как мне импортировать БД??? Товар там только тестовый, а вот атрибутов, производителей, категории и пр......

 

Смотрел бэкап sql там и записей и путей нету к старому домену, так-же как и имя БД лог и пасс...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Импортировать нужно в пустую базу.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Остаются пути в конфигах.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Чем подсовываете?
Я сую Sypex, проблем не было, ни разу, версии mysql разные!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подсовываю обычным расширением mysql импорт

 

Это же значение у того же хостера по идее не меняется?

 

define('DB_HOSTNAME', 'localhost');

 

P.S. Я заново не инсталил oc а тупо копировал каталог public_html и правил пути в config, admin/config, ессно в админку не зайти он не понимает пользователя админки, раз БД не подключена

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все таки получилось импортировать таблицы в БД, Таблицы в новой БД из старой все есть

 

В админку так-же не дает зайти, ошибки вида

 

Warning: require_once(/home/name/public_html/system/startup.php): failed to open stream: No such file or directory in /home/name/public_html/admin/index.php on line 21

Fatal error: require_once(): Failed opening required '/home/name/public_html/system/startup.php' (include_path='.:/usr/local/lib/php') in /home/name/public_html/admin/index.php on line 21

 

Там на 21 строке 

require_once(VQMod::modCheck(DIR_SYSTEM . 'startup.php'));    - Кэш vqmoda чистил, сам вкумод инсталил заново

 

На фронте ошибки вида

 

Warning: mysql_connect(): Access denied for user 'name_login'@'localhost' (using password: YES) in /home/name/public_html/system/database/mysql.php on line 6

Notice: Error: Could not make a database link using name_login@localhost in /home/name/public_html/system/database/mysql.php on line 7

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все таки получилось импортировать таблицы в БД, Таблицы в новой БД из старой все есть

 

В админку так-же не дает зайти, ошибки вида

 

Warning: require_once(/home/name/public_html/system/startup.php): failed to open stream: No such file or directory in /home/name/public_html/admin/index.php on line 21

Fatal error: require_once(): Failed opening required '/home/name/public_html/system/startup.php' (include_path='.:/usr/local/lib/php') in /home/name/public_html/admin/index.php on line 21

 

Там на 21 строке 

require_once(VQMod::modCheck(DIR_SYSTEM . 'startup.php'));    - Кэш vqmoda чистил, сам вкумод инсталил заново

 

На фронте ошибки вида

 

Warning: mysql_connect(): Access denied for user 'name_login'@'localhost' (using password: YES) in /home/name/public_html/system/database/mysql.php on line 6

Notice: Error: Could not make a database link using name_login@localhost in /home/name/public_html/system/database/mysql.php on line 7

залейте дефолтные файлы index.php в корень и админку и после этого заново проинсталлируйте vqmod.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

залейте дефолтные файлы index.php в корень и админку и после этого заново проинсталлируйте vqmod.

 

Спасибо, залил index дефолтные, переустановил vqmod, кэш везде почистил, ошибки те-же

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

config.php и admin/config.php правьте, у вас там явно с путями напутано и данные для подключения к БД не верны.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Подсовываю обычным расширением mysql импорт

 

Это же значение у того же хостера по идее не меняется?

 

define('DB_HOSTNAME', 'localhost');

 

P.S. Я заново не инсталил oc а тупо копировал каталог public_html и правил пути в config, admin/config, ессно в админку не зайти он не понимает пользователя админки, раз БД не подключена

На не которых прописываю define('DB_HOSTNAME', 'mysql.host.ru'); это зависит от самого хостера, как правило это localhost

 

Да, не забывайте про права к папкам и файлам!

 

А в логе ошибок что?

 

Так же проверьте правильность написания логина и имени базы, ну и пароль!

И кто ваш хостер?

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Расставил права на фалы и каталоги, при открытии фронта и админки, ошибок нету, ответ сервера 500

 

По пути system/logs нету файла ошибок errors, хотя помню в админке ставил чтоб лог ошибок писал

 

Хостер avahost.ru проблем с ним никогда не возникало

 

Да дело не в хостере

 

в конфигах прописано все верно, уже раз 10 все проверил, тем более делал по аналогии со старого домена

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
, тем более делал по аналогии со старого домена

 

 

это как?Пути на новом хостинге  свои и делать всё по аналогии никак нельзя.Всё это легко проверить .Удалите таблицы из базы.Почистите конфиги.Вставьте папку Install своей версии.Установите с нуля магазин.Потом созданные таблицы новой базы удалите и импортируйте  старую.Вот тогда и проверим  смысл 10 кратной проверки путей в конфигах))))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

это как?Пути на новом хостинге  свои и делать всё по аналогии никак нельзя.Всё это легко проверить .Удалите таблицы из базы.Почистите конфиги.Вставьте папку Install своей версии.Установите с нуля магазин.Потом созданные таблицы новой базы удалите и импортируйте  старую.Вот тогда и проверим  смысл 10 кратной проверки путей в конфигах))))

 

Я видимо просто не правильно выразился, ессно в конфигах все пути к каталогам и к БД прописал свои, имел ввиду смотрел как правильно были прописаны все пути в старых конфигах, прописал свои

 

Хотел и раньше так попробовать, заного установить и БД потом старую импортить

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну так  пробуйте.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну так  пробуйте.

Вообщем как посоветовал Том сделал, магазин поднялся,спасибо, админка работает, фронт работает, кроме:

При заходе в подкатегорию с товаром, выскакивает ошибка

Fatal error: Call to undefined method ModelToolImage::onesize() in /home/name/public_html/catalog/controller/product/category.php on line 233

Самое интересное, что когда заходишь в товар из подкатегории, скажем в "рекомендуемых", то все заходит хорошо и все показывает

И показывает когда у товара нету фото, только стоит добавить фотку к товару, причем как вручную так и через модуль, сразу валится данная ошибка

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все разобрался, оказывается ошибка с категориями вызывал vqmod, видимо кэш где то висел

 

Всем спасибо, думаю тему можно закрыть

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.