Перейти к содержанию
cmd

В OpenCart 1.5.5 отсутствует метод Loader::language()

Рекомендуемые сообщения

Я слоупок, но все-таки. САБЖ. В предыдущих и последующих версиях метод на месте. Какого черта это было? Много пользователей на 1.5.5?

 

UPD: Нашел тему. Очень лень все перечитывать. Может кто-то в курсе всего и в двух словах опишет ситуацию - буду весьма признателен.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да что там описывать. DK изменил (вместо `$this->load->language` стало `$this->language->load`), его заклевали про совместимость, он побрыкался, потом кажется плюнул и вернул как было.

https://opencartforum.com/topic/16806-ura-vyshel-openkart-155/page-2#entry117149

и чуть ниже:

https://opencartforum.com/topic/16806-ura-vyshel-openkart-155/page-2#entry117354

то есть

if(version_compare(VERSION, '1.5.5', '>=')) {
  $this->language->load('feed/yandex_yml');
}
else {
  $this->load->language('feed/yandex_yml');
}
и все дела.

Правда, я точно не помню, вернули как было или остался новый вариант. Поэтому версию и знак '>=' может придётся подрихтовать.

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да что там описывать. DK изменил (вместо `$this->load->language` стало `$this->language->load`), его заклевали про совместимость, он побрыкался, потом кажется плюнул и вернул как было.

https://opencartforum.com/topic/16806-ura-vyshel-openkart-155/page-2#entry117149

и чуть ниже:

https://opencartforum.com/topic/16806-ura-vyshel-openkart-155/page-2#entry117354

то есть

if(version_compare(VERSION, '1.5.5', '>=')) {
  $this->language->load('feed/yandex_yml');
}
else {
  $this->load->language('feed/yandex_yml');
}
и все дела.

Правда, я точно не помню, вернули как было или остался новый вариант. Поэтому версию и знак '>=' может придётся подрихтовать.

В этой же теме немного ниже я писал, что это справедливо для версии 1.5.5 (которая жила всего пару дней и которой никто не пользуется), а в 1.5.5.1 этот баг пофиксили.

То есть для новых модулей желательно использовать language->load

а для старых работает load->language

В лоадер добавили код:

 

public function language($language) {
return $this->language->load($language);
}
 

 

то есть при вызове load->language, вызывается language->load.

И не нужно никаких version_compare(VERSION, '1.5.5', '>=')

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.