Lon

Проблема с отображением категорий в Internet Explorer

Рекомендуемые сообщения

Lon    0

Доброго времени суток. Столкнулся с такой проблемой, - категории и подкатегории сайта некорректно отображаются в internet explorer. Главная страница сайта и страница самого товара отображаются вполне нормально. Если у кого-нибудь есть идеи по решению данной проблемы, буду премного благодарен.

Вот примеры:

Категория http://smartphone4you.ru/smartphones.htm

Подкатегория http://smartphone4you.ru/smartphones/Samsung.htm

post-669188-0-24968900-1371027542_thumb.png

post-669188-0-69535800-1371027543_thumb.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
RGB    1 034

У меня идея - обратится к автору вашего шаблона

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Lon    0

У меня идея - обратится к автору вашего шаблона

Вы не могли бы подсказать, а возможно что причина некорректного отображения это установленные модули?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
RGB    1 034

Ну причин может быть много, главная - ошибки в шаблоне, которые нормальные браузеры пропускают, а ие теряется, например вот похожий случай

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Похожий контент

    • От lavrentyev
      Всем привет!
      Есть трудность. В opencart кнопка "добавить в корзину" не работает (т.е никак не реагирует) в IE. Выдает такую ошибку:
      SCRIPT5009: "TDMAddCartProduct" не определено
      air (1949,65)
      Вот код кнопки:
      <a href="javascript:void(0)" class="tdcartadd" OnClick="TDMAddCartProduct('<?=$arPrice['PHID']?>','<?=$arPart['PKEY']?>')" title="<?=Lng('Add_to_cart',1,0)?>">Į krepšelį</a> А вот, как я понимаю код функции, на которую вызывает атрибут Onclick:
      /* Add to Cart */ function TDMAddCartProduct(PHID,PKEY){ PKEY = PKEY || ''; var QTY = ''; if(jQuery("#Qt_"+PHID).val()!=''){QTY=jQuery("#Qt_"+PHID).val();} var CurHref = window.location.href; if(PKEY!=''){ PKEY="#item"+PKEY; CurHref = CurHref.replace(PKEY,""); } jQuery("#PartsBoxOverlay").prependTo(".tdm_content"); jQuery("#PartsBoxOverlay").width(jQuery(".tdm_content").outerWidth()).height(jQuery(".tdm_content").height()).show(); jQuery("<form action='"+CurHref+PKEY+"' id='addcartform' method='post'><input type='hidden' name='PHID' value='"+PHID+"'/><input type='hidden' name='QTY' value='"+QTY+"'/></form>").appendTo('body'); jQuery("#addcartform").submit(); return false; } Я нагуглил, что проблема именно в Onclick. Но как решить проблему не знаю. Может что-нибудь подскажете. ))
    • От mastertim
      Подскажите кто сталкивался с такой бедой, в Internet Explorer 11 страница товара, превращается в фарш.
      Всё сдвигается вниз и черте куда. В категориях тоже самое.
       
      В других браузерах все нормально... :wub:
       

    • От fakir
      Здравствуйте! столкнулся с проблемой некорректного отображения в Internet Explorer 9 , на других версиях не проверял. В остальных браузерах все в порядке.  Версия  opencart 1.5.5.1.2. 
      сайт lifeinsport.com.ua Если кто знает в чем причина, помогите. 
    • От Propeller
      Добрый день!
      Заметил, что мой сайт криво работает в Internet Explorer, при этом в прочих браузерах (Chrome, Firefox, Opera) работает корректно.
      Некорректность заключается в том, что после оформления заказа, иногда после нажатия на кнопку, "Оформление заказа", а иногда - "Подтверждение заказа" выводится следующее окно.
       
      Где нужно искать причину сбоя?
      Заранее большое спасибо!


    • От Archy
      Здравствуйте, форумчане.
      Уже видел подобную тему, но в ней не дан ответ, поэтому создаю свою тему в надежде на вашу помощь, с желанием всё-таки получить ответ!
      Проблема в отображении главного меню: при открытии сайта в Internet Explorer'e, главное меню сайта отображается столбиком, а не в строку.
      Использую чистую OpenCart 1.5.6  с руссификатором, никаких модулей не устанавливал.
       
       

       
      Скрин взят из подобной темы, на которую ведет данная ссылка (если кому интересно).
       
      Заранее благодарю за помощь!!!
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу