asidnin

Не работают seo url

Рекомендуемые сообщения

asidnin    0

Перечитал весь форум и faq.

Проблема в следующем: при включённом seo при нажатии на ссылку для просмотра товара автоматически перекидывает на главный сайт(магазин на поддомене site.ru/market/), хотя урл отображает правильно. При выключенном всё нормально. .htaccess.txt переименовал в .htaccess как описано в faq.

Хостинг majordomo

Содержимое .htaccess

Options +FollowSymlinks

Options -Indexes

<FilesMatch "\.tpl">

Order deny,allow

Deny from all

</FilesMatch>

RewriteEngine On

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers

### Uncomment the commands by removing the # sign in front of it.

### If you get an "Internal Server Error 500" after enabling, then restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:

php_flag register_globals off

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
akobelkov    1

Перечитал весь форум и faq.

Проблема в следующем: при включённом seo при нажатии на ссылку для просмотра товара автоматически перекидывает на главный сайт(магазин на поддомене site.ru/market/), хотя урл отображает правильно. При выключенном всё нормально. .htaccess.txt переименовал в .htaccess как описано в faq.

Хостинг majordomo

Содержимое .htaccess

Options +FollowSymlinks

Options -Indexes

<FilesMatch "\.tpl">

Order deny,allow

Deny from all

</FilesMatch>

RewriteEngine On

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers

### Uncomment the commands by removing the # sign in front of it.

### If you get an "Internal Server Error 500" after enabling, then restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:

php_flag register_globals off

Попробуйте заменить

RewriteBase /

На

RewriteBase /market/

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
asidnin    0

Попробуйте заменить

RewriteBase /

На

RewriteBase /market/

Спасибо заработало)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу