Jump to content
Sign in to follow this  
VolkoV

[Решено {php mCrypt extension}] Проблема с установкой на Denwer

Recommended Posts

Поиском не найдено. При установке OpenCart на Denwer появляется такое: "Warning: mCrypt extension needs to be loaded for OpenCart to work!". В php.ini строку extension=php_mcrypt.dll раскомментировал, mcrypt.dll есть в папке ext, denwer перезапускал, ничего не помогло. ЧТО ДЕЛАТЬ???

Share this post


Link to post
Share on other sites

мне ничего не помогла, была такая же проблема. Пришлось сносить денвер и ставить openserver и все как по маслу.

Share this post


Link to post
Share on other sites

Всем привет.

Ставлю на сервер ocstore_v1.5.4.1.zip, без локальной установки; включается "Warning: mCrypt extension needs to be loaded for OpenCart to work!"

Порылса на English - все толкуют про WAMP. А я здесь при чем?

Какие будут мнения?

Всем спасибо.

Share this post


Link to post
Share on other sites

обратитесь к хостеру с просьбой включить "mCrypt extension" в php

Share this post


Link to post
Share on other sites

обратитесь к хостеру с просьбой включить "mCrypt extension" в php

Спасибо, так и сделаю :eek:

Share this post


Link to post
Share on other sites

Насчёт локальной установки используя денвер, попробуйте winginx установить.

Share this post


Link to post
Share on other sites

такая же проблема, ставлю ocstore_v1.5.4.1 на денвер и на втором шаге регистрации выстреливат: Warning: mCrypt extension needs to be loaded for OpenCart to work! что с этим делать?

Share this post


Link to post
Share on other sites

да все вроде очевидно :)

- создать файл, например inf.php, такого содержания:

<?php
phpinfo();
?>

- поместить его в корень сайта и вызвать, например так:

http://localhost/inf.php

- убедиться, что данная версия PHP скомпилирована с поддержкой "mcrypt" - "--with-mcrypt=static"

Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--disable-isapi" "--enable-debug-pack" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze" "--with-pgo"

- найти раздел "mcrypt" и убедиться, что он включен:

mcrypt support enabled

mcrypt_filter support enabled

- и самое главное, выкинуть на помойку эту нафталиновую хрень denwer!

хочется все в одном, тогда уж XAMPP

  • +1 1

Share this post


Link to post
Share on other sites

1) создал

2) поместил, вызвал

3) неубедился

Configure Command

cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--with-snapshot-template=d:\php-sdk\snap_5_2\vc6\x86\template" "--with-php-build=d:\php-sdk\snap_5_2\vc6\x86\php_build" "--with-pdo-oci=D:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=D:\php-sdk\oracle\instantclient10\sdk,shared" "--without-pi3web"

4) не могу найти

5) XAMPP работает с 32-х разрядными ОС Microsoft - у меня 64-bit Windows 7

6) ?? что делать

Share this post


Link to post
Share on other sites

3) неубедился

Configure Command

cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--with-snapshot-template=d:\php-sdk\snap_5_2\vc6\x86\template" "--with-php-build=d:\php-sdk\snap_5_2\vc6\x86\php_build" "--with-pdo-oci=D:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=D:\php-sdk\oracle\instantclient10\sdk,shared" "--without-pi3web"

4) не могу найти

5) XAMPP работает с 32-х разрядными ОС Microsoft - у меня 64-bit Windows 7

ну, раз "не убедился", значит как я уже писал - "в помойку" !

5) XAMPP работает с 32-х разрядными ОС Microsoft - у меня 64-bit Windows 7

win 32 приложения превосходно работают на 64 битных системах, а вот наоборот нет :)

- ставь и не парься :)

никто не станет делать полностью 64 битную "all-in-one" систему. Попросту делать не из чего. Гарантированное решение, которое есть, это MySQL 64 бит. Все остальное 32 бита, не считая "выкрутасов частных лиц", которые компилят под 64 битные ОСи

PHP 5.4.5 and PHP 5.3.15 x64 (64 bit) for Windows

http://www.apachelounge.com/download/win64/

но все это частные случаи.

Share this post


Link to post
Share on other sites

Установил на денвер (на ноуте) ocstore_v1.5.4.1 - все отлично установилось...

Устанавливаю на денвер (на комп) ocstore_v1.5.4.1 - на втором шаге такая же ошибка: Warning: mCrypt extension needs to be loaded for OpenCart to work!

Share this post


Link to post
Share on other sites

уже все сказано...

не думаю, что кто-то станет комментировать последний пост. Можно много фантазировать, но смысла в этом нет никакого!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.