Jump to content
MayAvt

500 ошибка в админке после установки модуля (и после его удаления)

Recommended Posts

Ситуация, как всегда "сама дура"

Но все же.

у меня opencart.pro 2.3, купила и поставила модуль для просто opencart 2.3. До этого сделала бэкап (базу данных из админки, файлы по ftp)

После установки модуля и обновлении модификаторов - админка белый экран, сам магазин работает.

Ошибка следующая.

PHP Parse error:  syntax error, unexpected '\xef\xbb\xbf' (T_STRING) in /var/www/www-root/data/www/....ru/system/storage/modification/admin/model/sale/order.php

Почитала в инете - какие-то boom-символы в строке (хотя файл точно кодировка без boom, по крайней мере нотепад++ так пишет)

 

Перезалила файлы из бекапа обратно - все заработало. Отключила модификатор, потом удалила модификатор, удалила 3 файла, которые ставит модуль. Удалила кэш, обновляю модификаторы - админка снова лежит.

Пробовала удалять руками этот файл в storage/modification, на который ошибка.

Ничего не помогает, только положить  этот файл из бекапа на сервер - тогда админка начинает работать.

 

Что мне делать? совсем растерялась. Вроде из бекапа файлы вернула, но при обновлении модификаторов все ломается. Так я не смогу дальше модули ведь ставить?

Бекап у хостера - старый. По закону подлости бекапила на гугл-аккаунт, а там как раз пару дней назад закончилось пространство.

 

При сравнении файлов из бекапа и после обновления модификатора на сервере system/storage/modification/admin/model/sale/order.php

в 2 строках нотепад показывает разницу, но эти символы не отображат. Выходит это  как раз '\xef\xbb\xbf', на которые ругается админка, когда не работает.

 

Как мне найти теперь, что портит файл system/storage/modification/admin/model/sale/order.php?

 

Базу проверила - там больше модификатора нет, файлов модуля нет. Что же исправляет файл при обновлении моификатора? Может что в кэше застряло как найти? Есть еще один модуль, который этот файл правит, но он стабильно работал уже давно. Могло ли что-то у него сломаться из-за неподходящего другого модуля?

 

Share this post


Link to post
Share on other sites

Решила проблему.

Заменила файл, на который была ошибка в логах на файл из более старого бекапа и все заработало.

Видимо, вчера как-то повредила этот файл в последнем бекапе (открывала его много раз и вероятно изменила как-то)

Share this post


Link to post
Share on other sites

А теперь обновите кеш модификаторов....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
You are posting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

On our site, cookies are used and personal data is processed to improve the user interface. To find out what and what personal data we are processing, please go to the link. If you click "I agree," it means that you understand and accept all the conditions specified in this Privacy Notice.