Перейти к содержанию
ilya_r

Не пускает в админку. Неправильная токен-сессия

Рекомендуемые сообщения

Установил ocstore_v0.1.4 на хост от iphoster.ru. Магазин исправно работал около недели. На днях пришло письмо от хостера что ip адрес моего сайта изменен, после этого немогу зайти в админ-панель, если ввожу неправильный логин/пароль сразу выскакивает ошибка, если ввести правильные данные, то на странице ничего не происходит, а через некоторое время появляется ошибка: HTTP шлюз не отвечает. Писал в поддержку хостинга, ответили что проблема не у них, пробовал устанавливать заново, создавал новую базу и т.д. и т.п. Устанавливается успешно, магазин открывается, но в админ панель непускает. Подозреваю, что все таки с хостингом проблемы, может что подскажете?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Копай в настройки php. Скорее всего ошибка там.

Если скинешь phpinfo. можно будет что то подробнее сказать.

Если даже новая установка не работает, то 100% беда в хостинге или в настройках этого хостинга.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый день!

Проблема почти таже. Установил скрипт на хост, на третьем шаге указал логин, пароль и почту. Все поставилось без проблем. При попытке входа в кабинет пишет что логин или пароль не верные. попытался восстановить, говорит, что данного е-майла не существует. Проблема в хосте или в чем то ещё? если в хосте, то что именно сервесникам сказать?

Проблема решена

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Добрый день!

Проблема почти таже. Установил скрипт на хост, на третьем шаге указал логин, пароль и почту. Все поставилось без проблем. При попытке входа в кабинет пишет что логин или пароль не верные. попытался восстановить, говорит, что данного е-майла не существует. Проблема в хосте или в чем то ещё? если в хосте, то что именно сервесникам сказать?

Проблема решена

Скажете в чем была проблема?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Скажете в чем была проблема?

Такое ощущение что на этом форуме никто не хочет делиться решенной информацией))))))

Все пишут РЕШЕНО, а как решили не пишут))))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Нарвались на такую же проблему при установке на субдомен.

 

С большой вероятностью проблема либо в папке-путях для сессий, либо потому что сессия просто не стартовала когда пытались зайти в админку.

 

Может кому-то поможет один из вариантов:

 

1й) закомментировал php.ini тот что был в каталоге admin

 

2й) прописал путь к сессиям в основном php.ini (возможно что если Вы даже пропишите его не правильно, то у вас все равно сработает параметр session_start ()

http://php.net/manual/en/function.session-save-path.php

 

Какой из этих вариантов  оказался правильный ... - не знаю, но на данном этапе помогло и в админку пустило.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.