Перейти к содержанию

Рекомендуемые сообщения

Добрый день, использую стандартный модуль, который генерит по ссылке: https://semenovip.ru/index.php?route=extension/feed/google_base

 

Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 26Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 27Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 28Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 31Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 26Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 27Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 28Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 31Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 26Notice: Undefined index: USD in /home/semenovi/public_html/system/library/cart/currency.php on line 27Notice: Undefined index: USD 

 

и т.д., потом начинается уже описание товаров. 

merchants.google так не принимает :( не подскажите как пофиксить эти Notice ....

 

OpenCart 3.0.2.0 

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

https://github.com/opencart/opencart/blob/3.0.2.0/upload/catalog/controller/extension/feed/google_base.php

Откройте файл:

catalog/controller/extension/feed/google_base.php

 после линия 65 добавте 'RUB',

$currencies = array(
                    'RUB",
					'USD',
					'EUR',
					'GBP'
);

 

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

О! Спасибо, нотисы исчезли!

 

merchant файл кушает, но товары не принимает, пишет:

Цитата

 

ERROR: Неподдерживаемая валюта в атрибуте: price.

Укажите одну из поддерживаемых валют или выберите валюту по умолчанию в настройках фида.
ERROR: Обязательный атрибут price отсутствует или указан с ошибкой.
Проверьте, включены ли в фид данных все обязательные атрибуты и нет ли в их значениях ошибок.

 

 
 
Может и с этим поможете? :)
 
по ссылке теперь кракозябры не пойму и где этот тэг и есть( :
<?xml version="1.0" encoding="UTF-8" ?><rss version="2.0" xmlns:g="http://base.google.com/ns/1.0">  <channel>  <title>РРџ Семенов</title>  <description>Рнтернет-магазин РРџ Семенов. Производство Рё продажа душевых кабинок, раздевалок  Рё сопутствующих товаров: погружные насосы, сигнализаторы СѓСЂРѕРІРЅСЏ. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Дайте доступи в личку, посмотю. Там сам опенкартвский код неправильний.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Agatha65 большой спасибо за помощь с решением проблемы с ругательством на price.

в файле: catalog/controller/extension/feed/google_base.php

было заменено это:

$output .= '<description><![CDATA[' . strip_tags(html_entity_decode($product['description'], ENT_QUOTES, 'UTF-8')) . ']]></description>';

 

на это:

$output .= '<g:description><![CDATA[' .  htmlentities(html_entity_decode($product['meta_description'], ENT_QUOTES, 'UTF-8')) . ']]></g:description>';

  • +1 1

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 10.02.2018 в 21:50, WaveYO сказал:

ERROR: Неподдерживаемая валюта в атрибуте: price.

Укажите одну из поддерживаемых валют или выберите валюту по умолчанию в настройках фида.
ERROR: Обязательный атрибут price отсутствует или указан с ошибкой.
Проверьте, включены ли в фид данных все обязательные атрибуты и нет ли в их значениях ошибок.

Так а как решили эту проблему?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Тоже интересует как решили проблему.

у меня проблема с price ушла.

но появилась проблема с разделителем.

 

За прайс спасибо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Agatha65 сказал:

Вот файл для 2.3

google_base.zip

Спасибо.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

@Agatha65  может скажите еще как быть с GTIN

который является обязательным.

у меня ошибка из-за него:

Для товара GTIN является обязательным

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 minutes ago, Esox said:

@Agatha65  может скажите еще как быть с GTIN

который является обязательным.

у меня ошибка из-за него:

Для товара GTIN является обязательным

Прочитайте что требуеть Гугл и решайте какой у вас казус(какие атрибути имеет товар, в смисле атрибути как общие характерстики по документация Г).

Потом уже придется менять фийд.

https://support.google.com/merchants/answer/160161?hl=ru

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Вообще ничего не получается.

Пробовал вставить и MPN и EAN и еще разные.

Брал EAN от такого же товара на eBay.

Ни в какую не прокатывает.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ав самом фиде есть эти поля?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, chukcha сказал:

ав самом фиде есть эти поля?

 

посмотрел.

upc - есть.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ну, в контроллере фида пропишите ему тупо g:gtin

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Похожий контент

    • От baroyanliana
      Нужно специалист по настройкам Google Merchant до полного выгрузки.  
    • От danineo1
      Добрый день!

      Помогите настроить модуль "UKSB Google Merchant v4.3.1" под требования Google Merchant.
      Пишите в телеграмм, или в личку, или под этим постом.
       
      Благодарю.
    • От danineo1
      Использовал кто этот модуль для Merchant?
      Не ругается ли на YML файл Google?  Или есть лучше модули для Мерчант?
      https://www.opencart.com/index.php?route=marketplace/extension/info&extension_id=13373
       
      Благодарю за советы!!!
    • От pmshirshov
      Нужен модуль для загрузки файла в формате XML на сервис гугл что бы магазин появился в Googl покупках.
      Всё настроено только остался этот пункт.

      Регистрация нового фида
      Автозагрузка (по расписанию)
      Задайте частоту и время загрузки, затем укажите URL фида. Внимание! URL должен начинаться с префикса "http://", "https://", "ftp://" или "sftp://".
      Google Merchant Center поддерживает автоматическую загрузку по расписанию с помощью протоколов HTTP, HTTPS, FTP или SFTP.
      При настройке в аккаунте Merchant Center автоматической загрузки (по расписанию) нельзя указывать в качестве URL фида ссылку на FTP- или SFTP-сервер Google (ftp://uploads.google.com bkb sftp://partnerupload.google.com).

      Подробнее тут - https://support.google.com/merchants

      Нужен ответ по срокам и цене вопроса.
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.