Перейти к содержанию

Рекомендуемые сообщения

Добрый день!

Магазин на версии 2.0.1.1

В данный момент установлен стоковый modification.php от этой версии. Однако есть необходимость его обновить на более новый - от версии 2.1.0.2

При замене этого файла на новый ложится пользовательская часть сайта с ошибкой HTTP ERROR 500 (админка - ок). Если включить отображение ошибок, то ошибка имеет следующий вид:

Parse error: syntax error, unexpected '}' in /var/www/site/data/www/site.ru/vqmod/vqcache/vq2-system_modification_catalog_view_theme_theme546_template_product_product.tpl on line 236

Один знающий человек подсказал, что проблема связана с тем, что какой-то вкмод или модификатор (видимо оба сразу) правят этот файл и получается ошибка.

нужно последовательно отключать модификаторы или вкмоды ну или сразу тот, который правит этот файл.

 

если открыть этот файл, на который ссылается ошибка, то вот код в диапазоне строк 233-246:

</div>
					<script type="text/javascript">
					$(document).ready(function() {
						
						$(".colors").fancybox({
							openEffect : 'elastic',
							closeEffect : 'elastic',
							fitToView   : false,
							autoSize    : true,
							closeClick  : false							
						});
					});
					</script>
				<?php } ?>

Вкмодов всего 2 штуки: blog manager2 и google remarketing. Окмодов побольше...

 

В общем задача такая: найти корень проблемы (вкмод и окмод), которые кладут сайт, подружить их, чтобы они больше не конфликтовали и можно было спокойно использовать modification от 2.1.0.2.

Может кто-то помочь, возможно уже решали подобные проблемы?

Предлагайтесь и цены сразу в лс!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А зачем ставить vqmod на opencart 2 ?
vQmod не совместимое по сути дополнение с opencart 2
Об этом Даниэль не раз упоминал
Вы видите они конфликтуют фактически
Я сталкиваюсь постоянно с конфликтами vqmod и ocmod
Ну не дружат они ни в какую ни в какой "официальной" версии vqmod
Есть ветки vqmod integreted и т п но и они частенько конфликтуют, потому что патчи иудет уже модифицированного ocmod кода а не оригинального кода
 

Только не говорите что без vqmod нельзя потому что модули на vqmod
Если разработчик сделал модуль для opencart 2.x на vqmod то это или квалификация разработчика слабая и тогда место модуля в мусорке или он лентяй, тогда вам модуль и поддерживаться нормально не будет и ему место тоже в мусорке
 

Забудьте про vqmod - только СТАНДАРТНЫЙ, ШТАТНЫЙ - ocmod, как официальный "локальный" инструмент совместной разработки (что то типа git -а но прямо на сайте)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.