Перейти к содержанию
kagan

Opencart 2.1.x или 3.0.1.x для свежего проекта?

Opencart 2.1.x или 3.0.1.x для свежего проекта?  

20 проголосовавших

You do not have permission to vote in this poll, or see the poll results. Пожалуйста, войдите или зарегистрируйтесь для возможности голосования в этом опросе.

Рекомендуемые сообщения

Приветствую!
И вот опять новый проект, но стал вопрос - что использовать "Opencart 2.1.x или 3.0.1.x".

На 2.1.x много всяких модулей и нет проблем с их адаптацией, но минут в том что кодить нужно больше по сравнение с использованием OC 3.х.

Попробовал 3.х., сразу понравилось что начали использовать twig (шаблонизатор), но минус в том, что у большиства модулей нет адаптации. Еще непонятно как в 3.х. обстоят дела с seo_url.

В целом нужен совет, какой лучше использовать для нового проекта?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
17 минут назад, kagan сказал:

seo_url.

встроенный,

 

Если у вас один язык, один магазин - можно юзать

 

Модули

Вы же не используете куб в своих модулях?
Поэтому практически любой сможете адаптировать

 

Твиг - нельзя сказать что очень хорошо, но при разработке - легче. В продакшине чуть-чуть тежелее.

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

2302

ocStore или opencart.pro|cms
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

opencart 2.1.0.2 хорошо

на поправки вылезающих лагов в 3 версии нет сил бороться

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

все зависит от целей проекта и от бюджета на него

если из коробки 3,0 подходит, то брать его

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
15 hours ago, theRGD said:

opencart 2.1.0.2 хорошо

на поправки вылезающих лагов в 3 версии нет сил бороться

О каких именно лагах идет речь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

выбрать 2.3 и не переживать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
18 минут назад, kagan сказал:

О каких именно лагах идет речь?

кое где кое чего не работает, 3.0.2.0/21b поставил, по включал default функционал, полезли ошибки - поставьте, посмотрите.

с темами не все ровно, косолапые они на на 3.0 - поставьте посмотрите.

вас не смущает что 3.0 версия это всего лишь такой тестовый переходник? и совместимости с 3.1 вдруг если появится когда нибудь очень вероятно не будет - см. прежние релизы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×

Важная информация

На нашем сайте используются файлы cookie и происходит обработка некоторых персональных данных пользователей, чтобы улучшить пользовательский интерфейс. Чтобы узнать для чего и какие персональные данные мы обрабатываем перейдите по ссылке. Если Вы нажмете «Я даю согласие», это означает, что Вы понимаете и принимаете все условия, указанные в этом Уведомлении о Конфиденциальности.