tdslava

Стоит ли обновляться с 2.1 до более поздней?

Рекомендуемые сообщения

tdslava    2

Запустили разработку летом на Opencart 2.1 (на базе ocStore), сделали на 70% и отложили. Теперь нужно доделывать, но появилось желание проапдейтить сайт, чтобы не отставать от актуальной версии. А разработчик нам говорит, что это вовсе не нужно, придется все переделывать, допиливать все компоненты и это обойдется в большие деньги. Правда ли, что версии 2.* настолько несовместимы? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
lletol    10

Скажем не на столько все плохо как кажется, но кучу геморроя получите, по адаптации темы ни чего сказать не могу, а вот модули придется переделывать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
tdslava    2
3 минуты назад, lletol сказал:

Скажем не на столько все плохо как кажется, но кучу геморроя получите, по адаптации темы ни чего сказать не могу, а вот модули придется переделывать.

Т.е. нет такого как во многих CMS - в админке нажал "обновить" и все благополучно обновилось :huh:

Где же хваленая продуманная архитектура...

А что мы получим с обновлением? А если не обновимся, не останемся у разбитого корыта через пару лет, когда вместо помощи в доработке все будут предлагать "снести это старье" и переделать на новую версию за немалые деньги?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
AlexDW    764
33 минуты назад, tdslava сказал:

А разработчик нам говорит, что это вовсе не нужно, придется все переделывать, допиливать все компоненты и это обойдется в большие деньги. Правда ли, что версии 2.* настолько несовместимы? 

если сам разработчик это говорит - какого ответа ожидаете? - "нет, не правда, пусть все бесплатно переделывает!!!"

 

различия действительно есть

и в зависимости от самих компонентов/решений/доработок - сильно вероятно что потребуется их адаптация с 2.1 на 2.3

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
pashast    370

Смысла переделывать нет. Пока переделаете под 2.3, там уже и 3 выйдет, опять переделывать придется :)

Я до сих пор использую ocStore 2.1.0.2.1, в 2.3 есть ошибки.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
nash    3
Только что, pashast сказал:

Я до сих пор использую ocStore 2.1.0.2.1, в 2.3 есть ошибки.

какие ошибки, например?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
wprizzz    28

Если шаблон, модули поддерживают версию 2.3 разве трудно переехать?
Там же только базу данных подключить нужно, или я ошибаюсь?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу